Computer freezing for a few seconds

Recommended Posts

3 hours ago, CptAnonymou5 said:

Sorry to reopen an older thread =X I have a 7700k @5.1ghz & 1070sc. GPU gets around 70cish while gaming so I don't think its heat and my CPU is around 60 while gaming. Win 10 installed on a m.2 ssd not a Samsung drive but I do have a Evo 850 500gb for open world games. I have the same exact issues as OP.. MOBO is a Maximus code IX latest bios I will try what OP thought it might be. I have tried many other VooDooy tricks including reg edits, reformatting, & ect.. Nothing seems to help thus far and its extremely annoying to have these 5-6 second freezing especially on MP games. Did setting to 2x work for you? I'am going to look into that right now. @patseguin


I also looked in Event Viewer to find nothing error wise around the time of freeze. Driver are up to date I use Snappy Driver Installer its an open source driver installer pretty handy.


If anyone else has the issue lets hope it works.



The problem stopped happening and I'm not even sure what fixed it. I have a feeling it might have been one of the m2 settings in bios that I had turned on thinking it was a performance increase. I'll have to take a look at what that setting was and see if you have the same thing enabled.


Edit: it was this I think: "I changed the m2 slot setting in the bios to X4" when I got my 970 pro m2. I'm pretty sure the problem stopped after I changed that setting back.

Link to post
Share on other sites



Might want to make sure the latest Samsung NVMe driver is installed.  It looks like a new version was released in late September (early October?) on Samsung's web site at (look for Samsung NVMe Driver towards the middle of the page).




Aryeh Goretsky


Link to post
Share on other sites
  • 1 year later...
On 30/03/2019 at 14:20, patseguin said:

For anyone curious if I solved this, I'm pretty sure I did. I set that X4 BIOS setting for my m2 SSD back to X2 and haven't had a freeze since. My computer wakes from sleep properly now too.

work for me, solved too, tks, i suspected that, but i have 6 ssd , and when x4 is enables ports (sata)  gone disabled,  tks

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.