• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

WiFi instability in Windows 10 under Boot Camp

Recommended Posts

Seizure1990    252
Posted (edited)

So technically a Windows question of sorts, but given this is specific to Apple hardware and Boot Camp, I am guessing this is the place to go. Sorry if I've misjudged.

 

I have a MacBook Pro, 2016, 15 inch. When in OS X, the internet works exactly as expected. Decent speeds, relatively stable ping. However, in the Windows 10 installation under Boot Camp,, it's quite the opposite. The connection frequently drops and reconnects, and when it is connected, the ping is absolutely atrocious, which bottlenecks the bandwidth as well. I tested this by running ping commands in both environments, using the local router as my test point. In OS X, ping was averaging under 30 ms, with a median somewhere in the 5 - 15 range, and the occasional spike of about 50. Not exactly stellar, but it's WiFi in an old apartment which likely has odd building materials, so can't really complain. In Windows though, the ping would jump around sporadically from 60 ms to the high triple digits, with spikes going as long as 2.5 seconds. (!!!!!) And this is when the connection hasn't dropped entirely.

 

I've tried manually downloading the Boot Camp driver package provided by Apple and installing it inside the Windows installation, but this didn't fix anything. I've seen tons of random suggestions on Google. One said there was a strange incompatibility between Wacom devices/drivers and the WiFi (I have no Wacom devices or software installed within Windows). Another was to turn down the energy consumption of the wireless device from 100% to 25%. Strange, but tried it, and no, did not work. Turned off power management. Etc. Tons of other people seem to have this problem as well, and it very much seems like a driver issue. I would have tried installing drivers directly from Broadcom, but I have absolutely no clue how to look up the exact model of Broadcom WiFi which the MacBook uses... Just a bit surprised Apple has done nothing to try and fix this, seeing as this is a 2016 model, so it's been a few years.

Just kind of hoping at this point that there is some small tidbit I missed while searching on my own, or that someone has had the same problem and successfully fixed it, and can tell me what to do.

 

Thanks in advance for any help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.