• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

  • 0
Sign in to follow this  

ESP-Board visible in the firmware flasher-tool, but not VSCode - what to do!?

Question

tarifa    0

hello dear Community,

 

the topic: ESP-Board visible in the firmware flasher-tool, but not VSCode - what to do!?


ESP-Board visible in firmware flasher-tool, but not VSCode I use MicroPython to program microcontrollers, especially the ESP32/ESP8266 types. These two microcontrollers are pretty  good compatible with MicroPython and it is easy to integrate sensors and actors programming using this language

 

 

i run vscode on windows - and on Linux.   on Windows i am facing several issues: i am happy that i am using MicroPython extension, and have successfully flashed the MicroPython  firmware (Operating System) to the ESP8266 target device. 

 

Note:  The Flashing was pretty easy: it worked as a breeze i  was using the NodeMCU flasher tool through a serial COM port of the Notebook.

 

i have installed / enabled the following plugins/extensions so far: 

 

- C++
- Native Debug
- Code Outline or AL Outline (to display and navigate properties)
- Additionally - ASM Code Lens extension - for ULP ASM
- PyMakr https://blog.jetbrains.com/pycharm/2018/01/micropython-plugin-for-pycharm/
and https://github.com/vlasovskikh/intellij-micropython

a great guide also visible here https://lemariva.com/blog/2018/12/micropython-visual-studio-code-as-ide

I did the following steps: After creating a new project by selecting the project folder. 
Then i want to look for the ports to connect. 
 
but the system gives back that "auto detection of COM ports isn't available for Windows
version of Visual Studio Code. I'm prompted to manually enter the COM port 
I've tried tp connect the target MicroPython device (a ESP 8266) to, and VSC gives back the following report:

 

Port not exist, please connect device and try again!


what did i have tried: 
- I've tried all available 3 USB ports, 
-  reinstalled the driver software, 
- rebooted the computer, 
- power cycled the target device and 
- made sure the target device is in program flash mode (that i did to allow application to be written to it) each time I try to connect VSC to it!


what do you suggest me to do!?


many thanks for every idea sharing and help

 

 

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.