• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Monitor(s) sometimes don't enter sleep state when locking PC

Recommended Posts

Steven P.    13,776

My multi monitor setup never falls to enter a sleep state after 30 mins of inactivity when the PC is not locked (screens turn off when I am not using it) but when I lock my PC with ctrl+alt+del the screens SOMETIMES turn off after a minute, and sometimes they just stay on all night, so they don't even power off as they normally would after 30 minutes if I didn't lock the PC. It is dumb.

 

What can cause the screens to sometimes enter sleep state after locking my PC and sometimes not?

 

An example of leaving the PC on all night is if I plan to use Plex or if I am downloading some torrents. I mean I don't expect help from Microsoft because this has been broken for the longest time I can remember. I made a feedback hub though to be proactive https://aka.ms/AA66hjv

Share this post


Link to post
Share on other sites
hellowalkman    2

is the power plan settings set correctly? in the control panel

Share this post


Link to post
Share on other sites
Steven P.    13,776

Yes, although the next morning I saw that qbittorrent hadn't closed properly and was hung in task manager, crap like that (which is far too common with third party apps) can result in issues like this, but my whole point is that why is it possible to sleep state screens after 30 mins of idling, but it is impossible to do the same if the system gets hung due to an incorrect closed app when the PC is locked. I mean okay screens don't enter sleep state after a minute due to it (maybe) but why don't they sleep after half an hour like they always do without fail when the PC is unlocked?

 

Microsoft's QA is just terrible.

Share this post


Link to post
Share on other sites
Brandon H    3,019

any GPU driver updates available steve?

 

all too often I've had a similar issue after a build upgrade until the next GPU driver release (using a GTX 750 Ti); though oddly I've had less issue with that since ditching chrome and moving to Brave as my browser as well, not sure if that's just coincidence or not.

Share this post


Link to post
Share on other sites
Steven P.    13,776

That's not it, a new driver was released yesterday but my problem was the night before. I haven't been able to troubleshoot it, and tbh when I notice the light from my screen is on 10mins after I've washed up and brushed my teeth (from upstairs), I am not in the mood to hunt for bugs, I just go downstairs and turn the screens off 😛

Share this post


Link to post
Share on other sites
goretsky    1,049

Hello,

These types of problems are often more complex than they appear at first, because they involve correctly detecting and setting power-states for various hardware classes, which are seemingly unrelated, but all affect each other.  Many years ago, I went through the process of getting a network driver WHQL-certified, and almost all of the issues surrounding it involved power management (setting state for suspend, deep sleep, hibernation, etc.).  Here's a few things to work down through:

 

  1. Make sure motherboard has latest BIOS (UEFI) firmware installed.
  2. Make sure video card has latest BIOS (UEFI) GOP firmware installed (this applies to any other expansion cards installed which have an UEFI option ROM, like mass storage controllers, sound cards, etc).
  3. Make sure motherboard has latest chipset device drivers installed.
  4. Make sure video card has latest device drivers installed.  If you have on-board graphics and a discrete (add-in) video card, make sure both of them have the latest device drivers.

The issue with the qBitTorrent application hanging is going to be more complex:  You'll need to report to the developers the problem it had, and see if there are any debugging logs, process dumps, etc., they can use to isolate the problem.  Once that is fixed, the system should be able to query it prior to changing the power state for the monitors and then get a response that allows it to proceed.

 

Regards,

 

Aryeh Goretsky

 

 

Share this post


Link to post
Share on other sites
Steven P.    13,776
31 minutes ago, goretsky said:

These types of problems are often more complex than they appear at first, because they involve correctly detecting and setting power-states for various hardware classes, which are seemingly unrelated, but all affect each other.  Many years ago, I went through the process of getting a network driver WHQL-certified, and almost all of the issues surrounding it involved power management (setting state for suspend, deep sleep, hibernation, etc.).  Here's a few things to work down through:

  1. Make sure motherboard has latest BIOS (UEFI) firmware installed.
  2. Make sure video card has latest BIOS (UEFI) GOP firmware installed (this applies to any other expansion cards installed which have an UEFI option ROM, like mass storage controllers, sound cards, etc).
  3. Make sure motherboard has latest chipset device drivers installed.
  4. Make sure video card has latest device drivers installed.  If you have on-board graphics and a discrete (add-in) video card, make sure both of them have the latest device drivers

The card is from August 2019 (Gigabyte GeForce RTX 2070 SUPER) there's no new firmware for it and I have the latest drivers installed. I also have the Intel Driver & Support Assistant and it shows no available drivers, I also have the latest BIOS (F10) installed for my motherboard.

 

I did switch my secondary IPS Philips 272S4L screen to DisplayPort 1.2 through the OSD (it was on 1.1 setting) and I could see that the backlight immediately turned off when entering power saving (after 30mins idle) although I haven't tested lock state yet, I will do that today at some point.

 

I am not even sure what difference DisplayPort 1.2 makes over the default setting of DisplayPort 1.1 for the screen, I tried to look for documentation about it, but couldn't find any.

Share this post


Link to post
Share on other sites
Steven P.    13,776

I just looked it up, the setting in Power Options (advanced) is called Console lock display off timeout (which is set to 1 minute) and is the exact setting that sometimes works and sometimes doesn't.

 

SNAG-0001.png

Share this post


Link to post
Share on other sites
Sulphy    1,441

Without knowing what version of Windoze you are on, not too sure. But i have the same issue! 

I have 2 2K monitors, and sometimes, they sleep, but for some reason, one of them decides to wake up, but doesnt display anything, just has the back lighting turned on. If i move my mouse or press a key, it wakes immediately.. and all is good after sleeping again.

OR, they enter sleep mode fine, but when i try wake them, only 1 will wake, and have to pull the power from the second monitor wait a few seconds, and apply power again, then the 2nd monitor comes up too.

It is annoying as heck, and only seems to go away if i do a full format and re-install windoze. BUT, invariably, it seems to come back again.

All drivers and firmwares are regularly updated (when available), checked all power settings.. and MSFT was of little to no help. Just the usual boilerplate troubleshooting, check power settings, check drivers etc BS :)

 

I am on the RP ring of Win10, and this PC is the only one i have with multi monitor setup. But it appears, i will be doing a rebuild when 1909 lands :)

 

Not much help, but i feel your pain man!

Share this post


Link to post
Share on other sites
Steven P.    13,776
6 minutes ago, Sulphy said:

Without knowing what version of Windoze you are on, not too sure. But i have the same issue! 

I have 2 2K monitors, and sometimes, they sleep, but for some reason, one of them decides to wake up, but doesnt display anything, just has the back lighting turned on. If i move my mouse or press a key, it wakes immediately.. and all is good after sleeping again.

OR, they enter sleep mode fine, but when i try wake them, only 1 will wake, and have to pull the power from the second monitor wait a few seconds, and apply power again, then the 2nd monitor comes up too.

It is annoying as heck, and only seems to go away if i do a full format and re-install windoze. BUT, invariably, it seems to come back again.

All drivers and firmwares are regularly updated (when available), checked all power settings.. and MSFT was of little to no help. Just the usual boilerplate troubleshooting, check power settings, check drivers etc BS :)

 

I am on the RP ring of Win10, and this PC is the only one i have with multi monitor setup. But it appears, i will be doing a rebuild when 1909 lands :)

 

Not much help, but i feel your pain man!

I'm on Windows 10 1903 with the latest updates, also read a couple of posts back, I may have solved the backlight not turning off issue by switching the screen from DisplayPort 1.1 to 1.2 through the OSD. This issue only happened when the screens turned off through the PC idle state (after 30mins) when the screens turned off after 1 minute (after locking the PC) the backlight always turned off. 

 

So it's a multifaceted problem :/ 

 

I suggest you check through your monitor's on screen display if there's a DisplayPort 1.2 setting (assuming that is what you are using, and not HDMI or DVI).

Share this post


Link to post
Share on other sites
Sulphy    1,441
1 hour ago, Steven P. said:

I'm on Windows 10 1903 with the latest updates, also read a couple of posts back, I may have solved the backlight not turning off issue by switching the screen from DisplayPort 1.1 to 1.2 through the OSD. This issue only happened when the screens turned off through the PC idle state (after 30mins) when the screens turned off after 1 minute (after locking the PC) the backlight always turned off. 

 

So it's a multifaceted problem :/ 

 

I suggest you check through your monitor's on screen display if there's a DisplayPort 1.2 setting (assuming that is what you are using, and not HDMI or DVI).

Indeed, i am using DP for my screens. I have a pair of Asus ROG swift PG279Q... and didnt see an option to change to 1.2... so will dig into some manuals! Thanks for that headsup!

Share this post


Link to post
Share on other sites
Steven P.    13,776
1 minute ago, Sulphy said:

Indeed, i am using DP for my screens. I have a pair of Asus ROG swift PG279Q... and didnt see an option to change to 1.2... so will dig into some manuals! Thanks for that headsup!

Actually, I don't have the option on my Dell S2716DG which might just mean it is already at 1.2 spec, the option with 1.1 or 1.2 is on my older Philips screen which is from 2015.

 

Yours already supports DP 1.2 https://tweakers.net/pricewatch/448588/asus-rog-swift-pg279q-zwart/specificaties/ (it is Dutch). Maybe it switches automatically if there's no option.

Share this post


Link to post
Share on other sites
Sulphy    1,441
Just now, Steven P. said:

Actually, I don't have the option on my Dell S2716DG which might just mean it is already at 1.2 spec, the option with 1.1 or 1.2 is on my older Philips screen which is from 2015.

 

Yours already supports DP 1.2 https://tweakers.net/pricewatch/448588/asus-rog-swift-pg279q-zwart/specificaties/ (it is Dutch). Maybe it switches automatically if there's no option.

Hoi!

HA! You beat me to it! I just read that my screens should support 1.2 natively! I have however, noticed that the screen refresh on the OSD was set to 165Hz, but in the Nvidia control panel, were on 60Hz.. so set them both now to 165. Lets see what happens!

FYI, i have a EVGA GTX1070 Hybrid. 

The testing continues.

Doei!!

 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.