• 0

wordpress: forbidden: no permission to access site: ways, methods to get the access back


Question

tarifa

hello dear experts

 

forbidden: no permission to access site: ways, methods to get the access back

 

i am looked out - and cannot access the page any more: 

 

the questioin is: how to disable theme using ftp or how to do some configurations that help me to get back again. 

 

 

to begin with the beginning: 

 

- running wP 5.3 - with the theme 2020
- note; the site is not active in a true sense: it was just installed several days ago. So there is not much content on it. i can do fresh install. No problem here. 

the conditions: and the preliminaries: server and setup 
- i am on a root-server which is maintained by a friend of me. 
- i have webmin and access to the logfiles and the apache and mysqlserver.
- i have access to the backend via ftp

what happened: several days ago i have been doing some minor changes in the backend - while this job i have fallen asleep (believe it or not) and the next day i get the following:

 

Forbidden: You don't have permission to access this resource.
 


the logfiles look like so: 

 

[Fri Apr 10 19:07:39.79231 2020] [core:error] [pid 15263] (13)Permission denied: [client 73.43.47.323:56979] AH00035: access to /favicon.ico denied (filesystem path '/sites/www.site_one.org/favicon.ico') because search permissions are missing on a component of the path, referer: http://www.site_two.org`

 

interesting: both sites are vhosts on my server: the site one is not active - and the site two is the site i cannot access at the moment. 

regarding the settings
i have set the site to theme 2020 - twentytwenty.

at the moment i do not have a idea what to do: 

can i restore the site via backend...

 

 

sensu: how to disable theme using ftp  https://wordpress.org/support/topic/how-to-disable-theme-using-ftp/

One of my themes, Avada, is currently causing a white screen with the message, “The site is experiencing technical difficulties” on both front and backend. If I rename the Avada folder using FTP, the message changes to “The theme directory “Avada” does not exist”.
So I know it is calling the theme. How do I go about disabling the Avada theme using FTP (since backend is not accessible) and how do I activate another theme, e.g. Twentynineteen? Any help is much appreciated! Thanks, Rutger 

end of quote... 

 

the  questions are

- can i do something via backend - that is: via ftp-backend? 
- renameing themes - that is  switching off themes 
- renaming plugins - that is  switching off  plugins

 or do something else alike 
 
- or should i  do a update & to the newest version 5.4 

note: the site does not (!) have a bunch of content - it was just in a freshly install-mode. 


look forward to hear from you 

regards

Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0
devobitch

i believe renaming it would disable it

 

  • Thanks 1
Link to post
Share on other sites
  • 0
NJ Louch

How exactly are you having so many issues with a system as straightforward as wordpress?

  • Thanks 1
Link to post
Share on other sites
  • 0
tarifa

hello dear DevoBitch hello dear +Human.online

 

first of all many thanks for the quick reply - happy to hear from you. Well i guess youre right DevoBitch - this might be helpful

 

@+Human.online: well sure thing WP migth be straight forward: but imagine: 

 

you have

-  55 000 ( in words 55 thousands)  of plugins

- approx. 100 different server-ideas to customize a server

 

and now: with all that you get into approx 55 000 0000 0000 different conditions that can restrict the work or at least have an impact of "how it works" 

 

to compare with another topic. - if you ever have set up a python development - but if so - then you might have noticed that there you also can run into dependency-issues.

that can stop your work 100 % ... 

 

 

that said - i compare this with the simple WP installation - with 

- zero plugin

- 10 plugin 

- 20 plugins

 

... guess you imagine what i want to say - even the simplest system can get a nightmare if you do not have all the dependencies under controll

 

 

regarding python - ( - here some readings to explain what the example should say:) 

 

https://packaging.python.org/tutorials/managing-dependencies/

https://realpython.com/products/managing-python-dependencies/
 

Quote

 


Python’s syntax seemed quite clear and intuitive by comparison, and I saw a (relatively) obvious path to learning it.
But when it came to Python’s 100k+ librariesand frameworks—
That was simply an OVERWHELMING amount of information to digest.
Even when I knew there had to be a library out there that already solved a problem I was facing—I drew a blank when it came to researching it.
 


 

 

note: i am currently workin on a good development environment for Python - on a. Windows10 and Linux - and i am coming along  these days - but i have been faced lots of issues - so many that i thought sometimes:  i take Anaconda or Miniconda to avoid all that dependencies and nightmare-situations i am facing ... 

 

 

havin said that - i agree with you - WP is overall pretty straightforward - but i now have to find out what causes the issue -and where the issues are  rootet. 

 

again - many thanks for your replies

 

have a great day. 

 

tarifa.

 

  • Facepalm 1
Link to post
Share on other sites
  • 0
tarifa

hi there 

 

just wiped the whole installation  - and set the new files of WP 5.4 

 

but the page ist not visible --- not yet

 

guest@dnstools.ch:~> ping www.mydomain.com  
PING www.mydomain.com (133.34.65.114) 56(84) bytes of data. 
 --- www.mydomain.com ping statistics --- 
16 packets transmitted, 0 received, 100% packet loss, time 7620ms 
 

 

 but the info.php file with the data is visible


http://www.mydomain.com/info.php
 

Link to post
Share on other sites
  • 0
tarifa
Posted (edited)

hi there 

 

just wiped the whole installation  - and set the new files of WP 5.4 

now i try to fiind out why the Vhosts on Webmin look so ugly. 

there are some issues here. 

 

will report later the weekend.

 


 

Link to post
Share on other sites
  • 0
tarifa
Posted (edited)

 

 currently reading some chapters in the webmin-manual - very interesting: 

 

 

since i have some interesting findings on the webmin . 
 

 15260    root    2 days ago    /usr/local/apache/bin/httpd -D SYSTEMD -k start
 8076    wwwrun    13 hours ago    /usr/local/apache/bin/httpd -D SYSTEMD -k start
 20982    wwwrun    2 hours ago    /usr/local/apache/bin/httpd -D SYSTEMD -k start
 21820    wwwrun    an hour ago    /usr/local/apache/bin/httpd -D SYSTEMD -k start
 21823    wwwrun    an hour ago    /usr/local/apache/bin/httpd -D SYSTEMD -k start
 21830    wwwrun    an hour ago    /usr/local/apache/bin/httpd -D SYSTEMD -k start
 22955    wwwrun    an hour ago    /usr/local/apache/bin/httpd -D SYSTEMD -k start

 

 

i am going to read some documents:  cf http://www.webmin.com/apache.html

 

Quote

 

WARNING : Running Webmin under Apache is almost never necessary unless you are on a very low-memory system that is already running Apache. Doing so will make Webmin slower, break some features and force use of the old ugly UI.

Webmin comes with a very simple webserver called miniserv.pl that is capable of doing all that is necessary for Webmin to run. However, it is not as fast or memory efficient as a well-developed server such as Apache. To use Apache instead of miniserv.pl, follow these steps :

Create a new Apache virtual server with the document set to the directory where you installed Webmin, using a directive like DocumentRoot /usr/local/webmin.

Configure Apache to treat all files with the .cgi extension as CGI programs, with the AddHandler cgi-script .cgi directive.

Add index.cgi to the DirectoryIndex directive.

Webmin CGI programs have their config directory passed to them in the WEBMIN_CONFIG, WEBMIN_VAR and MINISERV_CONFIG environment variables. For Apache to do this, you need to add the directives

 

 

and then this code follows 

SetEnv WEBMIN_CONFIG /etc/webmin
SetEnv WEBMIN_VAR /var/webmin
SetEnv SERVER_ROOT /usr/local/webmin
SetEnv MINISERV_CONFIG /etc/webmin/miniserv.conf

 

 

and then they continue: 

 

Create a new <Directory> section for the root directory, like
<Directory /usr/local/webmin>
</Directory>

 

Add the directive Options ExecCGI to the new <Directory> section.

 

Password-protect the virtual server by putting directives like
AuthName Webmin
AuthType basic
AuthUserFile /etc/webmin/htusers
require valid-user

 

Inside the <Directory> section. The file /etc/webmin/htusers must contains users who match up with those in /etc/webmin/webmin.acl.

Make all the Webmin programs owned by root and setuid with the commands

 

chown -R root:root /usr/local/webmin
chmod -R 6755 /usr/local/webmin

 

Add the -U flag to the perl line in all the Webmin scripts. This can be easily done with the following command run from the webmin directory
find . -name "*.cgi" -o -name "*.pl" | perl perlpath.pl "/usr/bin/perl -U" -
This assumes that Perl is installed as /usr/bin/perl on your system.

 

well i guess that i should not use this old and ugly UI 

 

 

 

cf http://www.webmin.com/apache.html 

Link to post
Share on other sites
  • 0
NJ Louch
22 hours ago, tarifa said:

even the simplest system can get a nightmare if you do not have all the dependencies under controll

No,  sorry - wordpress plugin management is actually really simple.  Sorry, all I see here is you creating your own problems.

  • Thanks 1
Link to post
Share on other sites
  • 0
tarifa
On 4/12/2020 at 2:40 PM, Human.Online said:

 

No,  sorry - wordpress plugin management is actually really simple.  Sorry, all I see here is you creating your own problems.

 

Hello deaer +Human.Online - many thanks for the reply and the continued support here - fixed this thing. Have had some issues with the Vhost-sepup.

Now all is fixed. Currently i am sorting out what caused the things - but after a fresh sepup all goes well now. 

 

AND YES: i fully agree that - wordpress plugin management is actually really simple

i also have made good experiences _ and i love Wordpress very much. 

 

 

Have a great day

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.