• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

  • 0
Sign in to follow this  

LG tv drops wifi after netgear upgrade to dd wrt

Question

capr    37

Hi everyone, I have a netgear R6700V3 and an LG OLED TV with model OLED65B6P.  I use the LG tv's built in WebOS to watch youtube and netflix... 

 

long story:

netgear has had a bunch of security issues lately and their newest router firmware is buggy as ... see here for the speed issues users have had starting with version 1.0.4.78 and i can confirm these issues persist in the latest version 1.0.4.96. 

 

nutshell: 

I decided to switch to DD-WRT and found out that my router has been stably supported for a while. So I made the switch and followed all the guides. I named the new wireless network the same as my old one and most of my devices picked up the new connection and work great. A few needed to rejoin but no biggy. The big outstanding problem is my LG TV. It refuses to stay connected to the network. It will randomly drop the wifi connection and give no real error message. It refuses to rejoin the network and i have to unplug the TV and rejoin the network before it starts working for X hours and we start all over. 

 

I have no idea what the issue is and while many people are complaining about their LG TV not connecting to wifi, my issues only started as soon as i switched to dd-wrt. Something is miss configured but i have no idea how to troubleshoot. Would hate to go back to the less secure netgear firmware... 

 

any help would be much appreciated. 

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
+BudMan    3,724

And what are the details of your configuration?  What channel, what VHT... Are you trying to run 40 mhz channels on 2.4 ghz?

 

If the ssid and psk where the same, makes no sense that some would auto rejoin and other clients would not..   Unless you have 2 different ssids for your bands and one matched up and the other did not, etc.  And then depending on which the client was using..

 

Have you messed with any of the power settings that dd-wrt might allow you to adjust, that some native would not like beacon interval, dtim interval.. Basic rates, Frame bursting, CTS protection, etc. etc..  There are many variables to play with something like dd-wrt that most likely not there with some native firmware..

Share this post


Link to post
Share on other sites
  • 0
capr    37
14 hours ago, BudMan said:

And what are the details of your configuration?  What channel, what VHT... Are you trying to run 40 mhz channels on 2.4 ghz?

 

If the ssid and psk where the same, makes no sense that some would auto rejoin and other clients would not..   Unless you have 2 different ssids for your bands and one matched up and the other did not, etc.  And then depending on which the client was using..

 

Have you messed with any of the power settings that dd-wrt might allow you to adjust, that some native would not like beacon interval, dtim interval.. Basic rates, Frame bursting, CTS protection, etc. etc..  There are many variables to play with something like dd-wrt that most likely not there with some native firmware..

I am connecting the TV to the 5ghz network and have named it differently than the 2.4 ghz network. 

Network mode is AC/N-Mixed

Wireless Channel is Auto

Channel Width is VHT80 

Extension Channel is "lower lower"

wireless SSID Broadcast is enabled and everything else is disabled. 

 

Another tip I got from google was to change the "Key Renewal Interval" under wireless security. I set it to 86400 seconds. I am not sure what this means but this is a lot higher than the default. 

 

I have not messed with any of the power settings that dd-wrt offers.

 

 

Lastly, the TV is now consistently doing this when it drops. 

1) no connection. 

2) I select the network and the TV tries to connect. 

3) TV fails to connect and provides a non-descriptive error message without any error code. 

4) I select the network again. 

5) TV asks for the password this time. 

6) TV connects with the right password and everything works for a while .... (I am keeping track to see if it works for about an hour when that key renewal interval is set). 

Share this post


Link to post
Share on other sites
  • 0
+BudMan    3,724
9 hours ago, capr said:

Extension Channel is "lower lower"

And what channel are you running on.. When you set that up and trying to use 80 VHT that determines which other channels are to be used, client might not like that, or there might be interference on the other channels of the VHT. 

 

"Wireless Channel is Auto"  really wouldn't be a good idea if trying to use specific settings for the VHT channels to use..   I would suggest you set your specific channels..

 

On 5 ghz there are really only 2 channels that can be used for 80 VHT.. 36 and 149 if not using the DFS ranges.  Those would be the lower channels and then the upper channels would be used for the VHT..

 

Also looks like there might be some issues depending on what build you are using

https://wiki.dd-wrt.com/wiki/index.php/QCA_wireless_settings#Extension_Channel

 

The group renewal is how often that key gets changed for multicast/broadcast traffic..   If I recall there was some sort of issue with that, and setting to 0 was a fix or using a watchdog script?  I have not been active in dd-wrt for long time.  But thought that was an issue after the krack fix..

 

If it happens on a specific time interval - you sure its not dhcp related, where the lease on your dhcp is just expiring and not renewing like it should.

Share this post


Link to post
Share on other sites
  • 0
capr    37
On 7/9/2020 at 3:44 AM, BudMan said:

"Wireless Channel is Auto"  really wouldn't be a good idea if trying to use specific settings for the VHT channels to use..   I would suggest you set your specific channels..

On 5 ghz there are really only 2 channels that can be used for 80 VHT.. 36 and 149 if not using the DFS ranges.  Those would be the lower channels and then the upper channels would be used for the VHT..

I set it to 149 to see what happens. Can experiment with this. I live in a small apartment and interference could easily be the answer. Strange that only one device is impacted... maybe all the others are using a channel that's not being interfered with? is that how it works when it's set to auto? 

On 7/9/2020 at 3:44 AM, BudMan said:

Also looks like there might be some issues depending on what build you are using

https://wiki.dd-wrt.com/wiki/index.php/QCA_wireless_settings#Extension_Channel

I am using Firmware: DD-WRT v3.0-r43652 std (07/03/20) and per the link you kindly posted, I selected UU. 

On 7/9/2020 at 3:44 AM, BudMan said:

The group renewal is how often that key gets changed for multicast/broadcast traffic..   If I recall there was some sort of issue with that, and setting to 0 was a fix or using a watchdog script?  I have not been active in dd-wrt for long time.  But thought that was an issue after the krack fix..

might as well try it... Happened again mid watching something yesterday. 

On 7/9/2020 at 3:44 AM, BudMan said:

If it happens on a specific time interval - you sure its not dhcp related, where the lease on your dhcp is just expiring and not renewing like it should.

This happened much more frequently before I changed the Key Renewal Interval. Last night, it happened in just about 24hrs. 

All my DHCP settings are the default. Client Lease Expiration is set to 1440 minutes. so again 24hrs.... coincidence? I haven't changed this value since the upgrade and the frequency of the problem has gone down. Not sure that's enough to rule out DHCP settings being the issue though. What can i do to rule this out? I tried assigning a static IP to the TV as a random trouble shooting step. It didn't help much.

Share this post


Link to post
Share on other sites
  • 0
+BudMan    3,724

If you set static on your TV, that would rule out dhcp as your problem for sure.

 

The key renewal could be causing you to disconnect I guess, have never ran into this before.. But sure guess its possible.. Try setting it to 0 so group doesn't renew and see if that fixes your issue.

 

As to interference only being noticed on the tv.. Possible its location and where the interface is sourced.   Other thing you could try - would be moving the TV, even if just for a day or so to test if connectivity is an issue in the spot its currently in.

 

Best option if you ask me - is use a wire ;)  TVs normally don't move around much... wifi is meant for mobile device - if its not mobile than it should have a wire ;)  But not all tvs have that option even.  Add the freaking $1 wired interface TV makers!!

 

In my house if it has ethernet and not mobile is wired.. When I was playing with old chromecasts, I got the wired adapter for it.. Well worth the $15 cost.. When I bought higher end roku device.. Made sure it had a wire.. If it doesn't move - and it can, it should be wired.. IMHO..  My current roku TV has a wire.. I wouldn't off gotten that model/brand if it didn't have a wire.

Share this post


Link to post
Share on other sites
  • 0
capr    37
5 hours ago, BudMan said:

As to interference only being noticed on the tv.. Possible its location and where the interface is sourced.   Other thing you could try - would be moving the TV, even if just for a day or so to test if connectivity is an issue in the spot its currently in.

 

Best option if you ask me - is use a wire ;)  TVs normally don't move around much... wifi is meant for mobile device - if its not mobile than it should have a wire ;)  But not all tvs have that option even.  Add the freaking $1 wired interface TV makers!!

I have 1 cat5 running to the place where the TV is located and I use it for HDMI over Ethernet to beam over apple tv, xbox, and my media server to the TV. Used to have an adapter that also had Ethernet pass through but that one had tons of issues and I replaced it. This all worked fine on the default firmware, so if interference is the issue, there has to be a channel that doesn't have interference which i was using before. 

 

thanks for your help so far. I changed the TV back to static IP to rule out the DHCP server and set the key renewal interval to 0 to see if that helps. Will have to wait and see if it breaks. 

 

 

Share this post


Link to post
Share on other sites
  • 0
+BudMan    3,724
14 hours ago, capr said:

so if interference is the issue, there has to be a channel that doesn't have interference which i was using before.

Possible... And its also possible someone moved in or changed there setup and now there is interface on all the channels.

 

You really should fire up something like

https://www.acrylicwifi.com/en/wlan-wifi-wireless-network-software-tools/wlan-scanner-acrylic-wifi-free/

 

To see what is out there - how strong the signals are, and what channels they are on.

 

The other option if all the known channels are being stepped on, is having a router (and the client) that support the DFS channels.. Pretty much nobody uses these - since most soho routers do not support them, and clients like tvs, iot, etc. most likely don't support them either..  (52-144)

 

dfs.thumb.png.7aaf01a803b4e9dd165b6c2d483ef5f0.png

 

Its always a good idea to do a survey of your area to see what is the best channel(s) for you to use.. You want to use the channel that has the least amount of signal from others in your area..

 

 

 

Share this post


Link to post
Share on other sites
  • 0
capr    37

We angered it. it has been happening every few hours... since the changes from last night. Before it was doing it every 24 hrs. I am going to switch back to the manufacturer's firmware to rule out the TV just bugging out all of a sudden and being the problem. 

 

I can also take better note of of what defaults the manufacturer sets so I can use the same values if I switch back. 

Share this post


Link to post
Share on other sites
  • 0
capr    37

been working fine on the netgear firmware. Will look for some kind of settings file where I can get all the defaults that netgear uses so i can replicate on ddwrt. 

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.