PC BUILD BUILD HELP


Recommended Posts

Little_JZ

Hello, I have a problem after building my pc, I don’t have any video display. Everything looks good except no video. I looked up multiple things on YouTube and nothing had the solution. I wonder if it’s a cord in the wrong place or my motherboard has a red light for cpu. Any thoughts? I am really upset, I just spent $1000 on this and I have had just non stop problems and issues.

Link to post
Share on other sites
Jim K

" I just spent $1000 on this "

 

Under warranty?  Return it.

 

red light for cpu" ?  Are we talking about the motherboard or the case?

Does it have a dedicated GPU ... are you plugged into the right HDMI/DisplayPort?

 

... you probably need to be more specific.  Brand/Model?  

  • Like 1
Link to post
Share on other sites
Zoea

Sounds like you chose all the parts yourself. Can you check if the stock bios supports your CPU? A red light for processor is never good.

Link to post
Share on other sites
+xrobwx71

Yes, we need waaay more details or otherwise its guessing game. 

 

Do you have links to where you bought the parts?

 

Motherboard, CPU, GPU, PSU. PSU is as important as anything.  

Link to post
Share on other sites
Mindovermaster

As above, we need more information. A red CPU light is never a good thing...

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.