• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

  • 0
Sign in to follow this  

HTAccess and Apache

Question

Endoscient    0

Trying to get .htaccess work on my own server. But keep getting an Internal Server Error (500). I changed the httpd.conf (and restart apache everytime I do). this is my

the (.htaccess)

AuthType Basic
AuthUserFile /var/www/passwd/passwords
require valid-user

/var/www/passwd/passwords file (change actual thing)

username:password

httpd.conf (poriton of it)

<Directory "/var/www/html">
    Options Indexes FollowSymLinks
    AllowOverride AuthConfig
    Order allow,deny
    Allow from all
</Directory>

Any help would be greatly appreciated. I think this is the right forum. If not please move.

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
Mouton    0

username:password

The password need to be generated in an encrypted form. This is not the plain text password.

htpasswd execute would allowd to generate such password.

Share this post


Link to post
Share on other sites
  • 0
Endoscient    0

its is encrypted one, just changed it here to show example.

Share this post


Link to post
Share on other sites
  • 0
Endoscient    0

I fixed. The problem if any one is wondering I just I had AllowOveride for / to none so it didn't allow anything to be overridden.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.