• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

[HOWTO] Get X.org CVS running

Recommended Posts

Knight'    0

Yikes, looks great but I don't want to install it just yet incase it breaks my system. I'll wait for the final release :)

Share this post


Link to post
Share on other sites
bolerodan    1

heh it worked fine until i rebooted, then it borked my X system, so i uninstalled it and reinstalled Xfree4.4 and now X works again, ill wait for a stable release

-bolero

Share this post


Link to post
Share on other sites
JimmyT    0

From make World:

bison -y -d pswparser.y

/bin/sh: line 1: bison: command not found

I guess I have to install bison as well. Put it on the list with autoconf, cvs, gcc...

I have a question... Why is it that I want to install something, if that something is lets say at CD1, it asks CD2, then CD4, then CD3 and then CD1? It doesn't read anything from the other 3 cds, stupid Mandrake 10...

Share this post


Link to post
Share on other sites
JimmyT    0

And flex :crazy: Put that on the list too.

EDIT:

gcc -m32 -o resize -O2 -fno-strength-reduce -fno-strict-aliasing -ansi -pedantic -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prot otypes -Wmissing-declarations -Wredundant-decls -Wnested-ext erns -Wundef -L../../exports/lib resize.o xstrings.o -lncurses -Wl,-r path-link,../../exports/lib

/usr/bin/ld: cannot find -lncurses

collect2: ld returned 1 exit status

make[4]: *** [resize] Error 1

make[4]: Leaving directory `/home/jimmyt/xc/programs/xterm'

What the hell is that now? What do I need to do?

Edited by JimmyT

Share this post


Link to post
Share on other sites
boomn    0

could be the ncurses-dev package, not really sure

Share this post


Link to post
Share on other sites
Knight'    0

hey guys, I finally plucked up the courage to install it. And it's GREAT! These shadows are NICE and transparency.

The only thing I haven't figured out yet is how to get windows to automatically go transparent when I drag them (in gnome 2.6.3) and how to get xcompmgr to run at startup?

And has anyone noticed during window minimzation small black lines left on the desktop? I'm using the .905 release...They go away when you drag a window over it.

Share this post


Link to post
Share on other sites
SaguratuS    0

True....Transparancy....Xorg....Drooooooooooooooooooooooooooooooooooooooooooooooooool

:drool:

Share this post


Link to post
Share on other sites
Trip    0
xcompmgr: error while loading shared libraries: libXcomposite.so.1: cannot open shared object file: No such file or directory

but it is there in /usr/X11R6/lib

Please make sure the /usr/X11R6/lib is listed in /etc/ld.so.conf

And then run

ldconfig

Worked for me

Share this post


Link to post
Share on other sites
netllama    0

Has anyone been able to build this on Fedora Core 2? I just tried this morning and 'make World' bombed out:

making all in lib/fontconfig...

make[4]: Entering directory `/root/stuff/xc/lib/fontconfig'

rm -f fcatomic.o

gcc -m32 -c -O2 -fno-strength-reduce -fno-strict-aliasing -ansi -pedantic -Wall -Wpointer-arith -Wundef -I/usr/include/freetype2 -I/usr/include/freetype2/con fig -I../../extras/fontconfig/src -I../../extras/fontconfig -I../../export s/include/X11 -I../.. -I../../exports/include -Dlinux -D__i386__ -D_POSIX_C_S OURCE=199309L -D_POSIX_SOURCE -D_XOPEN_SOURCE -D_BSD_S OURCE -D_SVID_SOURCE -D_GNU_SOURCE -DFUNC PROTO=15 -DNARROWPROTO -DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -DFC_DEFAUL T_FONTS='""' -DHAVE_EXPAT -DXFREE86_FT2 -DFONTCONFIG_PATH='"/etc/fonts"' -fPIC fcatomic.c

In file included from ../../extras/fontconfig/fontconfig/fcfreetype.h:27,

from ../../extras/fontconfig/src/fcint.h:38,

from fcatomic.c:49:

/usr/include/freetype2/freetype/freetype.h:2442: error: syntax error before "ERN ING_UNFITTED"

fcatomic.c: In function `FcAtomicLock':

fcatomic.c:101: warning: unused variable `fd'

fcatomic.c:102: warning: unused variable `f'

make[4]: *** [fcatomic.o] Error 1

make[4]: Leaving directory `/root/stuff/xc/lib/fontconfig'

make[3]: *** [all] Error 2

make[3]: Leaving directory `/root/stuff/xc/lib'

make[2]: *** [all] Error 2

make[2]: Leaving directory `/root/stuff/xc'

make[1]: *** [World] Error 2

make[1]: Leaving directory `/root/stuff/xc'

make: *** [World] Error 2

Share this post


Link to post
Share on other sites
BaronGanut    0

Hail!

I have installed the 6.7.99.904 release of X.org and I got translucency and shadows working, however it is really bad performance, when moving the windows they lag like hell aswell as switching between them.

My computer:

700++ mb ram

1,4 ghz amd athlon

ati radeon 7200

It doesn't seem like you have this problem but does anyone know anything?

Share this post


Link to post
Share on other sites
markjensen    98

Are you using the optimized ATI drivers?

I know that graphics rendering is slow on my PC if I don't use the nVidia drivers.

Share this post


Link to post
Share on other sites
BaronGanut    0

Arg! bloddy oh. No optimized drivers for radeon 7200! bugger! fack!

Share this post


Link to post
Share on other sites
MrA    6
Arg! bloddy oh. No optimized drivers for radeon 7200! bugger! fack!

Try using DRI. You may have to recompile the kernel and X.

Share this post


Link to post
Share on other sites
moomoofish    0

great tutorial, but sadly i dont quite have x.org running yet :(. the error message i receive is attached

using gcc (GCC) 3.3.4 (Debian 1:3.3.4-6sarge1)

xorg_error

Share this post


Link to post
Share on other sites
karma_police    0

How do you know which version of xorg is running? any commands?

Share this post


Link to post
Share on other sites
kjordan2001    246
great tutorial, but sadly i dont quite have x.org running yet :(. the error message i receive is attached

using gcc (GCC) 3.3.4 (Debian 1:3.3.4-6sarge1)

Seems like a problem with PAM?

Share this post


Link to post
Share on other sites
karma_police    0

bah!!! no luck, everything working until I typed 'xcompmgr' every window crashed, using Fedora Core 2, latest NVIDIA drivers, kernel 2.6.8-1.

Share this post


Link to post
Share on other sites
moomoofish    0

thanks kjordan, i'd missed that in my frustration and was looking at gcc. i think i might have a bash with the official release instead and see if that gives me any joy instead :happy:

Share this post


Link to post
Share on other sites
beh    0
The only thing I haven't figured out yet is how to get windows to automatically go transparent when I drag them (in gnome 2.6.3) and how to get xcompmgr to run at startup?

to have xcompmgr to go on startup add it to your .xinitrc file for example mine says

exec fluxbox & xcompmgr -c

Share this post


Link to post
Share on other sites
Zerosleep    0

EDIT: n/m

I got everything working and it all runs kinda slow. Oh well.

Edited by Zerosleep

Share this post


Link to post
Share on other sites
M. Sullivan    0

Alright I have it all installed and it all works fine... until I enable the composite manager in xorg.conf. When I have the composite manager enabled, in flux I seemingly don't have "layers." So basically, I can't bring a window into focus, they stay in order on the desktop from the time the window was opened, and I can't bring any to the front. Also, when I start up xcompmgr, windows "stick." I don't know any better way to put this. When I move a window, the window moves, but it leaves it's print where it was previously. I hope you can understand that in those terms.

Any help would be greatly appreciated.

Share this post


Link to post
Share on other sites
Rob2687    72

For the xcompmgr part I get:

./autogen.sh: line 2: autoreconf: command not found

When I do the ./autogen part......

Share this post


Link to post
Share on other sites
fackamato    0
For the xcompmgr part I get:

./autogen.sh: line 2: autoreconf: command not found

When I do the ./autogen part......

585491453[/snapback]

Install autoreconf.

Share this post


Link to post
Share on other sites
_R2D2    0

My compile ends with this:

In file included from auth.c:45:

dm.h:110:31: error: security/pam_appl.h: No such file or directory

In file included from auth.c:45:

dm.h:425: error: syntax error before ?*? token

dm.h:425: warning: type defaults to ?int? in declaration of ?thepamhp?

dm.h:425: warning: data definition has no type or storage class

dm.h:426: error: syntax error before ?*? token

dm.h:426: warning: type defaults to ?int? in declaration of ?thepamh?

dm.h:426: warning: data definition has no type or storage class

make[4]: *** [auth.o] Error 1

make[4]: Leaving directory `/home/johan/Kompileringar/xc/programs/xdm'

make[3]: *** [all] Error 2

make[3]: Leaving directory `/home/johan/Kompileringar/xc/programs'

make[2]: *** [all] Error 2

make[2]: Leaving directory `/home/johan/Kompileringar/xc'

make[1]: *** [World] Error 2

make[1]: Leaving directory `/home/johan/Kompileringar/xc'

make: *** [World] Error 2

After a while.

Should I install, or fix something?

Share this post


Link to post
Share on other sites
Maxious    0
My compile ends with this:

In file included from auth.c:45:

dm.h:110:31: error: security/pam_appl.h: No such file or directory

In file included from auth.c:45:

dm.h:425: error: syntax error before ?*? token

dm.h:425: warning: type defaults to ?int? in declaration of ?thepamhp?

dm.h:425: warning: data definition has no type or storage class

dm.h:426: error: syntax error before ?*? token

dm.h:426: warning: type defaults to ?int? in declaration of ?thepamh?

dm.h:426: warning: data definition has no type or storage class

make[4]: *** [auth.o] Error 1

make[4]: Leaving directory `/home/johan/Kompileringar/xc/programs/xdm'

make[3]: *** [all] Error 2

make[3]: Leaving directory `/home/johan/Kompileringar/xc/programs'

make[2]: *** [all] Error 2

make[2]: Leaving directory `/home/johan/Kompileringar/xc'

make[1]: *** [World] Error 2

make[1]: Leaving directory `/home/johan/Kompileringar/xc'

make: *** [World] Error 2

After a while.

Should I install, or fix something?

586581907[/snapback]

I'll take a stab in the dark and say you need the pam development files. Didn't say which distro but for ubuntu/debian thats package "libpam0g-dev" and for redhat/fedora thats "pam-devel"

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.