Archived

This topic is now archived and is closed to further replies.

Soundblaster Audigy 2 drivers?

Recommended Posts

vincent    154

Are there any for Ubuntu and where? :huh: And how do i go about installing them? :blush:

Share this post


Link to post
Share on other sites
dotRoot    1
Are there any for Ubuntu and where? :huh: And how do i go about installing them?  :blush:

585745223[/snapback]

http://opensource.creative.com/

Share this post


Link to post
Share on other sites
vincent    154

Can i do an apt-get for them and install them that way?

Share this post


Link to post
Share on other sites
dotRoot    1
Can i do an apt-get for them and install them that way?

585745266[/snapback]

I think you already have ALSA which should support Audigy 2. But you can always type:

apt-cache search alsa

and see what it finds. Also I suggested in another thread, you should type:

apt-get update
apt-get install synaptic

And then go through your menus and execute Synaptic. Gives a good GUI front-end for APT and also makes searching for apps on it a breeze.

Share this post


Link to post
Share on other sites
vincent    154

suhweet! thanks man

Share this post


Link to post
Share on other sites
dotRoot    1
suhweet! thanks man

585745386[/snapback]

Watch it, you might find out GNU/Linux isn't hard. Don't tell the Windows users. :D

Share this post


Link to post
Share on other sites
SeaClearly    0
ur steps didnt work at all

and not even the steps off here

http://www.ubuntuforums.org/showthread.php?t=21211

WTF DO I DO?!!!

585748646[/snapback]

If you have the Audigy 2 Value (SB0400) it seems to not work with many distros ATM. ALSA 1.0.8 supports this card but for some reason Mepis, ubuntu, debian and many others dont' currently support it even though they should. Now I tried Linspire Five-O just for kicks and for some crazy reason they actually support this sound card even though I think they use ALSA 1.0.6 but I think Linspire works with this card because it uses something called I think Jack Audio or something. I have a funny feeling that this jack software is what is supporting this card. I've tried getting this card to work with the latest stable version of Fedora Core 3 and it only worked after I installed ALSA 1.0.8 from source but I haven't tried Fedora Core 4 test 1 yet nor the latest version of Mandrake or Mandriva as they call it now.

Edit...Oh and if you don't mind using something a little older you can use Ubuntu Warty because I'm pretty sure this card worked with that version because I remember quite clearly how ****ed off I was when Hoary came out and refused to work with my soundcard. I quit using Ubuntu once they moved to Xorg because the thing just refused to work with my Dell E173FP LCD while the same version of Xorg works fine with other distros. I'm understanding more and more why I hate Xorg over Xfree86 because it never works.

Share this post


Link to post
Share on other sites
vincent    154

see, i'm not gonna reformatt, i just got the right kernel and nvidia drivers setup right for this pc. And don''t plan on going through that headache again. anyways (on the link i posted)

cd /usr/src

sudo wget ftp://ftp.alsa-project.org/pub/driv...r-1.0.8.tar.bz2

tar xvjf alsa-driver-1.0.8.tar.bz2 <---^ is this step just one line or 2 seperate lines? ive tried both and they seem to download the drivers

cd alsa-driver-1.0.8 <---- this is where i get stuck, i do this and it says no such file or directory

sudo ./configure --with-cards=emu10k1 --with-sequencer=yes

sudo make

sudo make install

sudo nano /etc/modules

add in

snd-pcm-oss

snd-emu10k1

snd-mixer-oss

Can someone help me. I know if do these steps it will work.

Share this post


Link to post
Share on other sites
SeaClearly    0

First line is this below which is downloading the file with wget.

sudo wget ftp://ftp.alsa-project.org/pub/driv...r-1.0.8.tar.bz2

Second line is unpacking the file or un tarring it.

tar xvjf alsa-driver-1.0.8.tar.bz2. Now I think to untar it you might need to be root and as such its a safe bet to instead type in this below.

sudo tar xvjf alsa-driver-1.0.8.tar.bz2

Now to be on the safe side I would enter into a root console while you do the rest.

Now if you typed those top two lines first that I think would cause your no such file or directory because nothing was ever unpacked.

Once you get the sudo make you might get an error asking to specify your kernel sources and those I had to ask Ubuntu support where they were and I can't think of what they said ATM but I would ask for this while your at it. After that everything should work very well. Now the Kernel sources could have been called kernel headers and for some reason I might be getting those two mixed up.

Also to add the modules you would enter this below and just in case I could be wrong and am going by pure memory right now.

type "sudo pico etc/modules/alsa.conf" without the quotes. You should see text and a list of modules and just add the modules listed into this file and save it as always making a backup of the file first. Now at a root console type lsmod and see if those modules are listed and if so they are loaded.

But I'm telling you know that at least for me getting my audigy 2 value to work under ubuntu was a pain and even after your done you need to type at a console alsamixer and unmute or mute one of the digital outputs to actually get the sound to work plus increasing all the volume levels. If you don't want to bother with this you would always use the warty release and if that doesn't come with KDE 3.4 for example or the latest gnome for example you can always just apt-get them with great ease and save yourself all this trouble. Bottom line is that there are some problems with Hoary with soundcards and video not working when they worked great in the previous warty.

Share this post


Link to post
Share on other sites
blik    1

First things first, have you made sure sound isnt just muted?

Fire up alsamixer (type alsamixer) and unmute everything...

Share this post


Link to post
Share on other sites
SeaClearly    0
First things first, have you made sure sound isnt just muted?

Fire up alsamixer (type alsamixer) and unmute everything...

585750812[/snapback]

That most likely won't help because there are known issues with Hoary with many soundcards that should be supported and have been supported in Warty and all Ubuntu says is that those will be fixed after hoary final is released which has happened so now we have to wait and see how long until this has been fixed. Also Xorg is having major problems that need fixing as well.

Share this post


Link to post
Share on other sites
blik    1
That most likely won't help because there are known issues with Hoary with many soundcards that should be supported and have been supported in Warty and all Ubuntu says is that those will be fixed after hoary final is released which has happened so now we have to wait and see how long until this has been fixed.  Also Xorg is having major problems that need fixing as well.

585750823[/snapback]

When I used to use Ubuntu, it picked up my Audigy 2 without any configuration needed...

Share this post


Link to post
Share on other sites
SeaClearly    0
When I used to use Ubuntu, it picked up my Audigy 2 without any configuration needed...

585750827[/snapback]

You have an older Audigy 2 while I think this user has the newer Audigy 2 Value (SB0400) which has never worked in Ubuntu Hoary but only in Warty. Those two models are a big difference.

Share this post


Link to post
Share on other sites
vincent    154
First line is this below which is downloading the file with wget.

sudo wget ftp://ftp.alsa-project.org/pub/driv...r-1.0.8.tar.bz2

Second line is unpacking the file or un tarring it.

tar xvjf alsa-driver-1.0.8.tar.bz2.  Now I think to untar it you might need to be root and as such its a safe bet to instead type in this below.

sudo tar xvjf alsa-driver-1.0.8.tar.bz2

Now to be on the safe side I would enter into a root console while you do the rest.

Now if you typed those top two lines first that I think would cause your no such file or directory because nothing was ever unpacked.

Once you get the sudo make you might get an error asking to specify your kernel sources and those I had to ask Ubuntu support where they were and I can't think of what they said ATM but I would ask for this while your at it.  After that everything should work very well.  Now the Kernel sources could have been called kernel headers and for some reason I might be getting those two mixed up.

Also to add the modules you would enter this below and just in case I could be wrong and am going by pure memory right now.

type "sudo pico etc/modules/alsa.conf" without the quotes.  You should see text and a list of modules and just add the modules listed into this file and save it as always making a backup of the file first.  Now at a root console type lsmod and see if those modules are listed and if so they are loaded.

But I'm telling you know that at least for me getting my audigy 2 value to work under ubuntu was a pain and even after your done you need to type at a console alsamixer and unmute or mute one of the digital outputs to actually get the sound to work plus increasing all the volume levels.  If you don't want to bother with this you would always use the warty release and if that doesn't come with KDE 3.4 for example or the latest gnome for example you can always just apt-get them with great ease and save yourself all this trouble.  Bottom line is that there are some problems with Hoary with soundcards and video not working when they worked great in the previous warty.

585750784[/snapback]

tha don't work. and alsammixer, everything is turned on. but the "Analog/digital output Jack is [off] how do i turn that on?

Share this post


Link to post
Share on other sites
vincent    154

anyone? :unsure: :blush:

Share this post


Link to post
Share on other sites
dotRoot    1
anyone? :unsure: :blush:

585752215[/snapback]

I'd help you, but I don't use Ubuntu and as I've researched your problem, it seems that it is Ubuntu specific. Also it seems that 'Warty' supports your card fine.

Share this post


Link to post
Share on other sites
vincent    154

I FIXED it!!!!!!!1

alsamixer

and hit "m" to turn on the Analog/digital out

to turn it on!!!1

:happy: :happy: :happy: :happy:

Share this post


Link to post
Share on other sites
dotRoot    1

And then the Earth cracked and the Heavens opened.

Share this post


Link to post
Share on other sites
blik    1
I FIXED it!!!!!!!1

alsamixer

and hit "m" to turn on the Analog/digital out

to turn it on!!!1

:happy: :happy: :happy: :happy:

585752868[/snapback]

Good job (Y)

Although I thought "m" unmuted :unsure: I've never used digital out anyway...

Share this post


Link to post
Share on other sites
SeaClearly    0
Good job (Y)

Although I thought "m" unmuted :unsure: I've never used digital out anyway...

585753959[/snapback]

Funny because I could never get Ubuntu to actually run alsamixer so maybe I should submit another bug for this. Now for the user that fixed it was is your actual sound card model number. Is this an Audigy 2 Value SB0400 or another model.

Share this post


Link to post
Share on other sites
vincent    154

uhm, i think it its the SB0400 cant check right now though. I'm at work, but yes, alsamixer turned it on for me. :p And my sound seems soo much clearer in Linux than Windows, the bass is deeper and i have turned off the bass on my wub and in Alsamixer. I'm not complaining i love it, i'm just imressed.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.