PlayStation 2 Component Cables don't work


Recommended Posts

seanmccann    0

I just bought some PS2 component cables for my SCPH-39001 PS2. My TV is a Philips 46PP9302 Epic 46" Digital Widescreen HDTV-Ready TV.

My PS2 is all set to use component cable and all I get is the sound. The picture that shows up is a bunch of blurry lines the go up. The lines are the proper colors.

Can anyone tell me what I need to make these cables work?

Link to post
Share on other sites
Martog    70

Hook up the normal set of A/V cables to the PS2, go into system configuration and make sure "Component Video Out" is set to Y Cb/Pb Cr/Pr and NOT RGB, that might be your problem.

Link to post
Share on other sites
BroChaos    1

just make sure that your component input actually supports progressive. some tvs have ypbpr and ycbcr.

Link to post
Share on other sites
SonComet    0

Just plugging in component cables to the PS2 doesn't make the output 480P, its 480i until you enable 480P in a game that supports it. So I don't see why it would matter if the input supports progressive scan. My SCPH-30001 works perfectly with my sony component cables. Maybe there is a compatability issue with your tv? If your ps2 is set to component in the interface maybe you could go to an electronics store, act like you are interested in a new tv and bring the ps2 with components along to test some tvs.

My component cables also work on my SCPH-70012 (my older PS2 stopped reading cd games and newer dvd games...grumble).

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.