• 0

[HELP] Linksys WRT54G v5 looses IP address


Question

nav1

I've recently purchased the above mentioned wireless router (mainly to play Mario Kart DS, mind you :p), but I've been having issues with it. My ISP requires a static IP address (10.0.0.2) in order to talk to my ADSL modem, which when I set it through the web interface works perfectly. However, almost every day it seems to set it to 0.0.0.0, unabling me to access the internet until I go to the router settings and put the correct one. I've searched around, but have found no concrete answers

The router is configured to DHCP for my PC and DS, allowing up to 5 clients to connect, the firmware version I have is 1.0.4, and the local network IP is a different range than the internet IP (192.0.0.*). I don't think this matters, but just in case, WEP (128 bits) and MAC address filtering are enabled.

Hope someone can shed some light.

Link to post
Share on other sites

23 answers to this question

Recommended Posts

  • 0
P!P

Get rid of that v5 crap. Since it's not based on Linux, they had to re-write the OS and it has many known problems. If you can, return it for a v4 or WRT54GL.

Link to post
Share on other sites
  • 0
Evolution

When you set the IP Address, did you enter it as the local ip address or the under the place when you select Static IP?

BTW the internal range should be from 192.168.1.* for clients using DHCP.

Maybe there's a firmware update for this issue, you should check it out.

Link to post
Share on other sites
  • 0
Rob2687

I've seen some threads on the same problem in other forums but no solution. The V5 is crap indeed.

Link to post
Share on other sites
  • 0
nav1

When you set the IP Address, did you enter it as the local ip address or the under the place when you select Static IP?

BTW the internal range should be from 192.168.1.* for clients using DHCP.

Maybe there's a firmware update for this issue, you should check it out.

It's the internet IP, which is set to "STATIC IP". The local IP I set it to 192.0.0.* just cause I didn't feel like leaving values by their defaults. I believe this shouldn't matter, but just in case, I'll try with the default (192.168.1.*).

As far as exchanging it for a v4 or below, that's not really an option. I got it from amazon, and I don't live in the states, so it can be quite a hassle to return it. Plus, since the only issue I have is with the IP, the rest of the features work perfectly, so, I'm inclined to believe there has to be something I can do.

Thank to everyone, I'll keep checking your feedback. I didn't really know about the v5 issues, and I installed the latest firmware for it, but in the changelog it doesn't specify anything regarding this issue.

Link to post
Share on other sites
  • 0
+BudMan

here's a thread which seems to be the same problem

http://www.linksysinfo.org/modules.php?nam...ewtopic&t=11364

As to having to have a static IP of 10.0.0.2? That does not seem right - that is a PRIVATE IP address, and not routable on the public net. What is the make and model of your modem? You sure its not a modem/router combo?

Is it possible your loosing power -- and the device is just really saving your config? Curious -- if you set your WAN static.. and then unplug the router -- does it stay?

Link to post
Share on other sites
  • 0
nav1

here's a thread which seems to be the same problem

http://www.linksysinfo.org/modules.php?nam...ewtopic&t=11364

As to having to have a static IP of 10.0.0.2? That does not seem right - that is a PRIVATE IP address, and not routable on the public net. What is the make and model of your modem? You sure its not a modem/router combo?

Is it possible your loosing power -- and the device is just really saving your config? Curious -- if you set your WAN static.. and then unplug the router -- does it stay?

Yeah, I read that thread, but they don't say anything helpful there. As for the IP, i's not a public IP, it's just for being able to talk to the ADSL modem (Zyxel 600 Series) which then connects to the internet. The ADSL modem is configured as the default gateway of the Wi-Fi router.

Regarding power, that's what I think may be the issue. Whenever the power goes out, the IP goes away as well. However, I've seen it happening without any power interruption, so I'm not so sure. Could the ADSL router be overwriting the IP, or maybe even my PC?

Link to post
Share on other sites
  • 0
+BudMan

What is the EXACT model number of your Zyxel 600 Series.. Cuz everything on website that I looked under 600 series is a modem/router combo.. If that is the case you have no need for the 2nd router.. And or could just use it as a switch and or wireless access point.

Link to post
Share on other sites
  • 0
skylab

ok thanks a bundle.. gonna go check it out now. :laugh:

Link to post
Share on other sites
  • 0
nav1

What is the EXACT model number of your Zyxel 600 Series.. Cuz everything on website that I looked under 600 series is a modem/router combo.. If that is the case you have no need for the 2nd router.. And or could just use it as a switch and or wireless access point.

Can't remember the exact model, I'll look into it when I get home. I do need both, though: The zyxel for ADSL, and the Linksys for Wi-Fi.

Thanks for the feedback, will keep you posted.

EDIT: I checked the website, and I believe mine is a Zyxel Prestige 623.

Edited by nav_uno
Link to post
Share on other sites
  • 0
+BudMan

Can't remember the exact model, I'll look into it when I get home. I do need both, though: The zyxel for ADSL, and the Linksys for Wi-Fi.

Thanks for the feedback, will keep you posted.

EDIT: I checked the website, and I believe mine is a Zyxel Prestige 623.

Well that is a modem/router - and does have a built in DHCP server, etc.. Which exact model?

623-41, 623R-A1, 623R-T1, etc..

You can use your wrt54g as just a wired switch and access point.. Here -- http://www.dslwebserver.com/main/wireless-...cess-point.html

In a nutshell turn on your dhcp server in your 1st router.. turn it off on the linksys and set the lan IP address of the linksys to be in the network of your 1st device.. but not to conflict with anything. Then plug your first devices to one the LAN ports of the linksys.. Now you have more ports for wired on your network, and also wireless.. Use your first device to configure port forwarding, etc..

I do believe the default IP address for the 623 is 192.168.1.1 or .2? But since you say your IP has to be 10.0.0.2.. I would guess it has been changed to 10.0.0.1 ?

What did you set your linksys WANs gateway to be? That would be the ip address of your modem/routers interface.. call it up in a web brower.. to get to its config interface;

post-14624-1136327437_thumb.jpg

Link to post
Share on other sites
  • 0
nav1

I changed the LAN IP of the WiFi router to something else as someone sugested, just to rule out that it's not some silly error due to the choice of IP addresses. I'll have to check tomorrow if the issue is still there or not.

My ADSL router is a Zyxel Prestige 623-41. I read the link you provided, and it seems like a choice to try if it still fails. Since the v5 does not support any of the alternative firmwares, like openWrt (damnit), there really isn't much I can get from it other than wireless access, so it's feasible to use it just as an access point.

Thank you very much for the time your taking to assist me. Will keep you posted possibly tomorrow (unless it fails before that :ninja:)

Link to post
Share on other sites
  • 0
+BudMan

Yeah let me know -- glad to help.. Yeah I would suggest you just use your modem/router and turn your wrt into a switch/access point..

I have never been a big fan of the combo setups.. but just looking at some of the screens from the manual.. those ZyXeLs dont look like too bad ;)

Link to post
Share on other sites
  • 0
nav1

Yup, the damn IP address went lost again. And I tried your sugestion, but again it brings a problem. The Zyxel router goes back to default (no DHCP server) whenever it powers down, and in third world countries like mine the power goes away almost everyday, so that's not a viable option. btw, this is also true for the linksys. It seems the reason it looses it's IP is when it powers down, for the above mentioned reason.

So I guess the only option now is to somehow manage to hardcode the Linksys router with the static IP, so it does not looses it and avoid the hassle of having to set it every time. Maybe custom modding the firmware? Does anyone know how to do something like that? I'll look into it in the meantime.

Link to post
Share on other sites
  • 0
nav1

Small update: The Linksys router's web interface has an option to save/load the current configs as a *.bin file (same as the firmware updates). I saved everything as I have now, and then loaded it (which I believe should ovewrite whatever is there as default), after which the router rebooted itself. I powered down everything for 20 minutes, turned on all of them, and what do you know? the IP was there! Again, I'll need to check tomorrow to see if it's all saved for good.

Link to post
Share on other sites
  • 0
+BudMan

How do you have it now? Did you turn it into a access point, or do you still have it setup with your double natting mess?

Here I finally got fed up with all the questions on how 2 routers should be setup.. This drawing works for your setup as well

http://www.neowin.net/forum/index.php?showtopic=416316&hl=

And to answer your 3rd party firmware? No the new V5s can not use 3rd party firmware.. you need the wrt54gL model now to use 3rd party.

Link to post
Share on other sites
  • 0
nav1

Currently it's set to the "double natting mess" (not really a mess, I might add). Thanks for the link, but I got it from the first one :p Like I mentioned in my previous post, that won't be a solution, since if I set the Zyxel as a DCHP server, as soon as it powers down, it goes back to normal, so it won't really solve it. It's better to use the Linksys for DHCP in my case, since the only setting that goes away with that one is the IP address.

Hopefully the setting I put yesterday will solve my issue, I'll check it when I get home. Thanks for the support and the efforts. That's a nice drawing you got there.

Link to post
Share on other sites
  • 0
+BudMan

You can use the the linksys for dhcp if you wanted too... To be honest - how many machines do you have? A dhcp server is not even required, if all you have is a handful of machine.. just set them all static.

Im a bit lost.. Can you access your Zyxel or not? Your saying any changes you make do not stay? What does "goes back to normal" actually mean??

And yes double NATTING is a MESS, plain and simple - there is not reason what so ever to do it, it makes the forwarding of any ports a freaking nightmare.. Unless you have your 2nd router in the DMZ of the first.. any forwards would have to be done in both places..

When you say you have to have a static of 10.0.0.2 to talk to your Zyxel? Does that mean that 10.0.0.3 does not work?

It really all comes down to if you have control over the Zyxel or not? If you can not make changes to the Zyxel -- that stay.. then yes your limited in your options.. what exactly is the point of a router, that does not allow the Owning/User to make any changes.. Does your ISP have it preconfigured -- and everytime it reboots it goes back to these?

From your first post it sounded like your linksys was not holding its static setting of 10.0.0.2 on its wan interface.. Is this the case or not?? Or did you correct that with your saving of the config??

Link to post
Share on other sites
  • 0
nav1
You can use the the linksys for dhcp if you wanted too... To be honest - how many machines do you have? A dhcp server is not even required, if all you have is a handful of machine.. just set them all static.
1 machine, the DS, and in a month my cousin's PC next door. I just would like to have DHCP on the LAN portion purely for convenience, in case anyone comes home with a laptop or something like that.
Im a bit lost.. Can you access your Zyxel or not? Your saying any changes you make do not stay? What does "goes back to normal" actually mean??
I can access it, if I set it to DHCP server, it works well, but whenever it turns off, it restores it's original configuration, which does not have DCHP server on.
And yes double NATTING is a MESS, plain and simple - there is not reason what so ever to do it, it makes the forwarding of any ports a freaking nightmare.. Unless you have your 2nd router in the DMZ of the first.. any forwards would have to be done in both places..
You know, i've never thought about it, but you're right. For basic internet and stuff, which is pretty much what've been using lately since I got it, it's ok, but for stuff like bittorrent and stuff, that require specific ports and such, it may become an issue. Could I just turn NATting off in one of them? I don't think using the DMZ would be the best.
When you say you have to have a static of 10.0.0.2 to talk to your Zyxel? Does that mean that 10.0.0.3 does not work?
No, I can use any IP in that range, and it works.
It really all comes down to if you have control over the Zyxel or not? If you can not make changes to the Zyxel -- that stay.. then yes your limited in your options.. what exactly is the point of a router, that does not allow the Owning/User to make any changes.. Does your ISP have it preconfigured -- and everytime it reboots it goes back to these?
I have control over it, but the settings are restored back to defaults that my ISP had set whenever it's turned off.
From your first post it sounded like your linksys was not holding its static setting of 10.0.0.2 on its wan interface.. Is this the case or not?? Or did you correct that with your saving of the config??
Yes, that's exactly the issue. When I saved the config, I turned both routers off for like 20 minutes, and after powering them on again, the WAN IP of the Linksys router was there, and the network was working properly, so the issue may be resolved by that. Need to double-check when I get home if it's a definitive solution.
Link to post
Share on other sites
  • 0
+BudMan

dude it sure seems like what you want is to turn the linksys into a access point.. You can use the dhcp server on the linksys -- since you say your Zyxel does not turn that on with a power loss.. Set it in the linksys then..

The drawing I pointed you too is what you want to set up.. as I thought from the start... just a address scheme of 10.0.0.x is all you need..

Set the linksys LAN IP to be 10.0.0.2 setup a dhcp scope of 10.0.0.10 to 50 or something pointing to your Zyxel as the gateway 10.0.0.1? Connect from your Zyxel to a LAN port on your linksys.. Your good to go.

You can then port forward anything you want on you Zyxel -- sure if it reboots you will not have them setup any more.. guess you have to live with that... But your linksys should save that it should be a dhcp server, with its scope, and whatever wireless security you setup, etc..

Like said -- the picture I pointed you to is the correct setup for your network.. just change the IPs from the 192.168.x.x network the 10.x.x.x

Link to post
Share on other sites
  • 0
nav1

dude it sure seems like what you want is to turn the linksys into a access point.. You can use the dhcp server on the linksys -- since you say your Zyxel does not turn that on with a power loss.. Set it in the linksys then..

The drawing I pointed you too is what you want to set up.. as I thought from the start... just a address scheme of 10.0.0.x is all you need..

Set the linksys LAN IP to be 10.0.0.2 setup a dhcp scope of 10.0.0.10 to 50 or something pointing to your Zyxel as the gateway 10.0.0.1? Connect from your Zyxel to a LAN port on your linksys.. Your good to go.

You can then port forward anything you want on you Zyxel -- sure if it reboots you will not have them setup any more.. guess you have to live with that... But your linksys should save that it should be a dhcp server, with its scope, and whatever wireless security you setup, etc..

Like said -- the picture I pointed you to is the correct setup for your network.. just change the IPs from the 192.168.x.x network the 10.x.x.x

Well, actually the Linksys only looses the WAN IP, not the LAN, so, that would work, since the WAN would then not be used in that configuration. I'm going home now, will update as soon as I get there.

Link to post
Share on other sites
  • 0
nav1

Update: I came home, and all settings were there, so my original issue has been resolved by saving/loading my configuration :D

Either way, the setup you sugested seems to be a better choice, so I'll probably do it anyway. Thanks a lot for your support, BudMan

Link to post
Share on other sites
  • 0
+BudMan

Either way, the setup you sugested seems to be a better choice, so I'll probably do it anyway. Thanks a lot for your support, BudMan

Your more than welcome - if you have any questions.. just ask.
Link to post
Share on other sites
  • 0
mantrl

Looks like I found a potential bug.

Im using firmware v1.00.6; I have the router setup with a static ip, and just like most people, when the router was powered off then on, or even randomly, the static ip magically disappeared. So to get internet working again, I had to login to the router and setup the static ips again.

Now for the bug. Under Administration, and Management, theres an option: UPnP: Enable (default) or Disable. When this setting is enabled the router ALWAYS looses the ip when it is restarted. I set it to disable, and the problem was gone. Now I have to wait and see if this also fixes the problem of randomly loosing the ip without a restart. But for now, even if the router is restarted, the ip does not disappear!.

So to recap, if you are using a WRT54G v.5 Router w/firmare v1.00.6, DISABLE the UPnP option.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.