• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

Howto: Ubuntu Dapper and Wireless home network

Recommended Posts

Z3r0    0

Sorry about this, I tend to just put all of my thoughts into a post without making myself very clear

This post provides information on how to get an Atheros PC Card (the D-Link DWL-G630) to work under Ubuntu Dapper flight 6 without installing any additional software

The initial diagnosis of the problem is that the PC Card does not light up and ubuntu is not showing the device under the GUI

From the command line I issued the dmesg | less command which shows all the activities of the linux devices being loaded/unloaded and noticed that there was no ath_pci driver

After reading this troubleshooting document https://wiki.ubuntu.com/WirelessTroubleshootingGuide

I was able to determine that my laptops CPU was unable to access the PCI bus of the PC Card.

I resolved this by:

1. editing the grub bootloader options by sudo gedit /boot/grub/menu.lst and adding pci=assign-busses to the following line as so

kernel /boot/vmlinuz-2.6.15-20-386 root=/dev/hda2 ro quiet splash vga=0x323 pci=assign-busses

2. rebooting

The lights on the device now alternate as it has been detected by linux and drivers loaded

My next problem was the lack of ability of my linux laptop to communicate with the outside world

My setup is as follows:

Router -> ethernet -> Windows PC -> wireless -> Ubuntu Laptop

I had originally configuring the Static IP Addresses for linux as I had with windows before but this didn't work

This was solved by:

1. Configuring the network settings with the Ubuntu Gnome Network Settings program

2. Disabling WEP for both the PC and the Laptop (leave the ascii field blank in the above program)

3. Since my network was PC to PC I had to set ath0 as Ad-Hoc networking via the terminal using iwconfig ath0 mode Ad-Hoc (for persistence you can add "wireless-mode Ad-Hoc" to /etc/network/interfaces and reboot), obviously if you are connecting directly to a router leave this as Managed

4. I then gave the data a route to travel on via the terminal with sudo route add default gw 192.168.0.1 (this seems to be persistent, you can also specify a device with dev ath0 appended)

5. Enabling the connection via the terminal with ifconfig ath0 up, this will now work each time you reboot :)

If anything doesn't remain persistent try adding commands to /etc/rc.local this file is executed each time you boot up

Give the system a few reboots to check that it's all working

Now onto WEP, it took me a while to work out what was wrong, I finally found out that I had enabled shared mode on the windows pc, fixed by changing to open mode

--------------------------------------------------------------------------------------------------------------------------------

Just for clarity

/etc/network/interfaces should look like this:

auto lo

iface lo inet loopback

auto ath0

iface ath0 inet static

address 192.168.0.2

netmask 255.255.255.0

gateway 192.168.0.1 #my windows PC

dns-nameservers 10.0.0.138 #my router or your ISPs DNS server instead

wireless-mode Ad-Hoc

wireless-essid Z3r0

wireless-key s:1234567891011 #my wireless key

wireless-key1 s:1234567891011 #my wireless key

/etc/resolv.conf should look like this:

nameserver 10.0.0.138 #my router or your ISPs DNS server instead

Here are two wikis (with info about WPA/WPA2)

One for the AR5212

http://forums.whirlpool.net.au/index.cfm?a=wiki&tag=ar5212

One for the RT61

http://forums.whirlpool.net.au/index.cfm?a=wiki&tag=rt61

Enjoy :)

Edited by Z3r0

Share this post


Link to post
Share on other sites
Arch    2

Are you working from the GUI or trying to do everything from terminal?

Under Ubuntu I've never had to drop down to the terminal to get wireless running, just did it all from the GUI.

Do you know if your wireless card is supported by the linux kernel? If not just try installing ndiswrapper from the repos (it's on the CD) and then just add a new wireless device from the Networking GUI box and select ndiswrapper.

Share this post


Link to post
Share on other sites
Z3r0    0

Hi,

GUI/Terminal whatever works

Most of this can be done without the terminal but assigning a default route requires use of the terminal

The atheros chipset wireless card is supported by madwifi in the restricted package which is installed by default

I've edited my post to make it a little clearer what I was doing and i've removed all the ip address settings

Share this post


Link to post
Share on other sites
Aaron    27

Great "How To". Thanks for putting the time into it...

Thread Moved.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.