• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

  • 0
Sign in to follow this  

WoW Interface and WTF Folders Empty

Question

+Bryan R.    1,147

I have installed WoW after a fresh install of Vista x64 and I also installed all the patches which I had pre-downloaded. I then went to install my Addons and noticed that none of the Blizzard UI Addons were in the Interface folder as well no Addon subfolder. I then created the Addon folder myself and copied my addons there. I started up the game to see what would happen, and it worked fine. However, it seems it likes to lose some of my settings/prefrences, such as where I moved the icons of the addons around the minimap. So I renamed the Interface and WTF folders to see if the game would re-create them, but it didn't...But the game still runs even without the Interface folder or WTF O_o. I'm afraid that the game will at some point crash or realize it is missing some things.

Some notes: I have installed Vista x64 before on the same PC and WoW, and everything worked beautifully. Also, I have another XP machine with WoW installed with all the correct directories, should I copy them over to my Vista machine?

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0
RottGutt    80
Also, I have another XP machine with WoW installed with all the correct directories, should I copy them over to my Vista machine?

The simply answer is "yes". Once you have your WoW set up just the way you like it, copy your Interface and WTF folders over. Make SURE you delete the Interface and WTF folders on the new computer instead of overwriting them. This is how I carry my custom interface around and instantly use it on new computers. Also, for the record, anytime you want to re-install your OS, just copy/backup your WoW folder, and move it back to your newly refreshed computer, as it contains all required files to run WoW. You can even burn it to a DVD or keep it on an external hard drive and play if you like. Ultimately this will save you hours of downloading and installing the game and all the patches one at a time.

One caveat to copying the Interface and WTF folders over to a new install is that if the new computer runs a different resolution than the original one, then the interface may look a little different, therefore you may have to move a few things around. Maybe that is what occured in your above post?

Share this post


Link to post
Share on other sites
  • 0
+Bryan R.    1,147

Thanks a lot for that. Very good to know exactly know the game works at the file level. I have found something new though. I'm not sure if this is something unique is Vista x64 or just Vista in general (both x86 and x64), but I found this directory "C:\Users\%username%\AppData\Local\VirtualStore\Program Files (x86)\World of Warcraft" which actually had all the folders and settings that were missing from the main installation folder. I copied my addons to this and I will see if I still have issues with my settings not saving. Thanks for the quick reply!

Share this post


Link to post
Share on other sites
  • 0
+Bryan R.    1,147

Everything seems to be saving correctly. All except when you first start the game, it always prompts you to accept the EULA. Theres two of them.

Share this post


Link to post
Share on other sites
  • 0
+Bryan R.    1,147

EDIT: Sorry pressed the button twice.

Share this post


Link to post
Share on other sites
  • 0
Mr. Gibs    3,865
Everything seems to be saving correctly. All except when you first start the game, it always prompts you to accept the EULA. Theres two of them.

Go to the WTF folder and open Config.wtf in notepad

Add these two lines if they don't already exist:

SET readTOS "1"
SET readEULA "1"

Save the file and then set it as read-only

Share this post


Link to post
Share on other sites
  • 0
+Bryan R.    1,147
Go to the WTF folder and open Config.wtf in notepad

Add these two lines if they don't already exist:

SET readTOS "1"
SET readEULA "1"

Save the file and then set it as read-only

Hmm theres serveral lines in Config.wtf that have -1 as their value, including the ones you described.

SET readTOS "-1"

SET readEULA "1"

SET readScanning "-1"

SET readContest "-1"

SET readTerminationWithoutNotice "-1"

I changed the first two to 1, which didn't resolve the issue. In my previous post I said I found a directory with the WTF and Interface folders other than in Program Files which is where I found Config.wtf. I copied the Config.wtf to the WTF folder in the usual Program Files directory but that didn't work either.

Share this post


Link to post
Share on other sites
  • 0
Mr. Gibs    3,865

Hm, delete all the config.wtf instances you can find and then reload wow, reset your settings and it should work.

Share this post


Link to post
Share on other sites
  • 0
Phillip    0

also, run WOW as administrator and accept the Eula.

Share this post


Link to post
Share on other sites
  • 0
+Bryan R.    1,147
Hm, delete all the config.wtf instances you can find and then reload wow, reset your settings and it should work.

Ok will do this tonight.

also, run WOW as administrator and accept the Eula.

I do have local administrative rights on my PC.

Share this post


Link to post
Share on other sites
  • 0
+Bryan R.    1,147
Hm, delete all the config.wtf instances you can find and then reload wow, reset your settings and it should work.

I deleted the config.wtf and it did reset the game the default video/sound settings. But that's it =/. I still got the messages to accept the EULA and such. So I compared the config.wsf on my desktop to my laptop and they matched for the most besides the obvious video settings that differed. So I looked elsewhere and found RunOnce.wtf in the Program Files directory, unlike the config.wtf, which was in my User directory. That had the following:

SET readTOS "1"
SET readEULA "1"
SET readScanning "1"
SET readContest "1"
SET readTerminationWithoutNotice "1"

I changed all the values to 1 and it as Read Only and like magic everything works. I would imagine that if I did a re-install of the game it would fix the issues, but that would do away with all the fun of figuring out the prblem at hand :p . Thanks again for the insite, and hopefully someone else doesn't have to wade through so much to fix their similar issue.

Share this post


Link to post
Share on other sites
  • 0
+Bryan R.    1,147

Sorry the "1's" in the code above should be "-1". That was a copy/paste from the fixed version.

Share this post


Link to post
Share on other sites
  • 0
Phillip    0

you may have administrative rights, but Vista still doesn't run them as so. Right click on the wow shortcut and run as administrator.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.