Archived

This topic is now archived and is closed to further replies.

PSP cannot connect to wifi

Recommended Posts

Demersynth    0

I picked up a PSP today, and I can't seem to get it to connect to wifi...It can see the access point, but it won't let me connect. I have entered all the details in EXACTLY as they should be, and have checked this several times. I've got the MAC address and put that into the access point. Everything is as it should be. But it just drops the connection immediately. Any ideas?

Share this post


Link to post
Share on other sites
+Audioboxer    2,874

What security is setup on your router?

Share this post


Link to post
Share on other sites
Coldgunner    11

its not mac filtered?

Share this post


Link to post
Share on other sites
+Audioboxer    2,874
its not mac filtered?

Yeah I don't understand why he is talking about MAC addresses.

I just tell my PSP to scan for connections, it finds my router and I enter my WEP key, bingo.

Just like how I would connect a laptop or PC to my router.

Share this post


Link to post
Share on other sites
Demersynth    0

Well the way the access point is setup is that it will exclude anything trying to connect unless the MAC address of that unit is put into the router. Stops items I don't know about connecting, but isn't that much of a hassle to set up.

Share this post


Link to post
Share on other sites
+Audioboxer    2,874
Well the way the access point is setup is that it will exclude anything trying to connect unless the MAC address of that unit is put into the router. Stops items I don't know about connecting, but isn't that much of a hassle to set up.

I'm not sure then :/

I find a simple password suitable enough for protection. Never dealt with MAC codes/addresses.

Share this post


Link to post
Share on other sites
Coldgunner    11
Well the way the access point is setup is that it will exclude anything trying to connect unless the MAC address of that unit is put into the router. Stops items I don't know about connecting, but isn't that much of a hassle to set up.

I used to have something like this set up, and never caused me issues neither. what encryption are you using? as the PSP may not support it correctly.

Share this post


Link to post
Share on other sites
Demersynth    0

WPA-PSK. It can see the network if I set it to autoscan, but it does not get the SSID so I enter it manually, enter the IP and DNS settings, but it fails to connect every time. I am extremely puzzled, as I have done this repeatedly and have made sure the settings are perfect. So I just fail to see why it can see the signal, but can't connect. I might to a manual firmware update once this is fully charged and see if using the latest firmware makes a difference.

Share this post


Link to post
Share on other sites
+Audioboxer    2,874

Well you could remove/downgrade your routers security temporarily to see if the PSP does in fact connect ok.

Then you know it's an issue with the security you have in place and you can work on a solution.

Share this post


Link to post
Share on other sites
popisdead uk    0

Try removing the security for a minute and connecting? I had a similar problem and removing the security whilst I connected everything up helped me troubleshoot the problem.

Share this post


Link to post
Share on other sites
Demersynth    0

Still no luck. Reckon it is faulty?

Share this post


Link to post
Share on other sites
+Audioboxer    2,874
Still no luck. Reckon it is faulty?

Take it to a friends and see if it connects to their router!

Share this post


Link to post
Share on other sites
Andrew    2,731

Do you have the SSID set to hidden? If so, change it to allow SSID broadcasting and then try connecting. Once it has, change the SSID back to hidden.

Share this post


Link to post
Share on other sites
morficus    0

afaik, the PSP only support 802.11b, right?

so you might have your router set to only do 802.11g. make sure it's set to do both b and g

also.. does the PSP support WPA? I know that the DS only does WEP... not sure about the PSP

I just tell my PSP to scan for connections, it finds my router and I enter my WEP key, bingo.

tsk tsk... WPA is the way to go :yes:

WPA > WEP

Share this post


Link to post
Share on other sites
+Audioboxer    2,874
tsk tsk... WPA is the way to go :yes:

WPA > WEP

I know, but I live in a village - No one is going to try and use my connection :p

Maybe one day ill change, but I have a fair few devices that would need updated.

Share this post


Link to post
Share on other sites
Andrew    2,731
afaik, the PSP only support 802.11b, right?

so you might have your router set to only do 802.11g. make sure it's set to do both b and g

also.. does the PSP support WPA? I know that the DS only does WEP... not sure about the PSP

tsk tsk... WPA is the way to go :yes:

WPA > WEP

The PSP supports WEP and yes it's only 802.11b

Share this post


Link to post
Share on other sites
morficus    0
what encryption are you using? as the PSP may not support it correctly.
WPA-PSK. It can see the network if I set it to autoscan, but it does not get the SSID so I enter it manually.

yup.. you'll have to set your router to use WEP in place of WPA (also make suer it supoprts b and g)

Share this post


Link to post
Share on other sites
Demersynth    0

Wow, I can't believe it was as simple as setting my access point mode to mixed. Thank you so much guys, every single one of you has helped a great deal, you've no idea how much I appreciate it! This is exactly why I stay at Neowin, I'm even considering becoming a subscriber now =D

Share this post


Link to post
Share on other sites
popisdead uk    0

Great news mate :)

Share this post


Link to post
Share on other sites
morficus    0

glad we could be of some assistance :yes:

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.