• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

  • 0
Sign in to follow this  

Network and Password

Question

wilfried    0

I have set up a small home network (2 computers.)

I did this before and, at the time Windows asked me for a password everytime I wanted to access a shared folder/files.

Now on that network I have it just opens the folder/files without asking for a password... Is that normal? Safe?

(WindowsXP)

Thanks

W

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
dr3w2k3    0

are you using the same username and password to log on to both systems? If so, that is why you dont get the prompt. WinXP will try to use the same credentials you use to log on to your system and if those don't work you get prompted for a username and password.

Share this post


Link to post
Share on other sites
  • 0
wilfried    0

Yes!

Thanks for the quick reply :)

Share this post


Link to post
Share on other sites
  • 0
Guest Quick Reply   
Yes!

Thanks for the quick reply :)

Your Welcome, before I even gave a solution :happy: ;)

Share this post


Link to post
Share on other sites
  • 0
wilfried    0

Hummm.. I take it back... I am not using the same password/usernames on both computer. One user name is my last name and on the other computer it's my full name. I got mixed up.

Soooo shouldn't it be asking me for a password when browsing the network?

Share this post


Link to post
Share on other sites
  • 0
alpoinacan    0

RU using simple file sharing? Are you logging on at both computers, or do you

have it so you log on automatically on both computers.

Tools, folder options, view, simple file sharing.

Share this post


Link to post
Share on other sites
  • 0
wilfried    0

Yes I am using simple sharing. And I do not have auto login enabled.

Share this post


Link to post
Share on other sites
  • 0
alpoinacan    0

1. Disable simple file sharing.

2. Once you log on to both computers, you should be

able to click on a share on either computer and it should

ask you for a usename and password.

3. Type in the user name and password for the other computer

and you share should show up in explorer.

4. If you are using a firewall, then additonal configuration for

the firewall may be requried.

If you are let us know.

Share this post


Link to post
Share on other sites
  • 0
wilfried    0

Thanks.!

So I did all that and the laptop is on Windows XP Home. It seems that XP Home only support Simple Sharing (it's not an option in Folders/Options). I tried to set the permission on my desktop (XP Pro) but XP Home won't prompt me. It just says access denied.

Is that a limitation of XP Home? If it is it sucks.

Share this post


Link to post
Share on other sites
  • 0
alpoinacan    0

Yep,

That is a limitation of XP Home. Uses the guest account to log in and uses the

everyone group. I should have asked it if was XP Home.

You can read about it here. Microsoft Knowledge Base Article - 304040

Some of the wierd stuff:

When Simple File Sharing is enabled, remote administration and remote registry editing does not work as expected from a remote computer because all remote users authenticate as Guest, which has no administrative privileges.

When Simple File Sharing is enabled, if you configure specific user ACEs, remote users are not affected when Simple File Sharing is enabled because all remote users authenticate as Guest when Simple File Sharing is enabled.

Remote users may receive an "Access Denied" message on a share to which they have previously connected to successfully after the hard disk is converted to NTFS. This behavior occurs on Windows XP-based computers that have Simple File Sharing enabled that were upgraded from Windows 98, Windows 98 Second Edition, or Windows Me, and occurs because the default permissions of a hard disk that is converted to NTFS does not contain the Everyone group, which is required for remote users that are using the Guest account to access the files. To correct this behavior, unshare and reshare the affected folders. The permissions are reset and users can connect again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.