• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

Cannot block website usings Hosts file in Windows 7

Recommended Posts

maash    19

in Windows XP and Vista, you can go into your c:\windows\system32\drivers\etc\ directory and add websites in the Hosts file to block them from being accessed by any windows browser. But in Windows 7 it still opens the websites despite me adding them to the Hosts file.

is there a different way website blocking works in Windows 7?

Thanks

Share this post


Link to post
Share on other sites
ThreeLies    0

Try to see if it directly is ignoring the hosts file or just something with the browser.

1. Change a site in the hosts file and redirect it to '127.0.0.1'

2. Open Command prompt and try these commands 'ipconfig /flushdns' and then 'ping <website you blocked>'

If all is correct it should return 127.0.0.1

Share this post


Link to post
Share on other sites
maash    19
Try to see if it directly is ignoring the hosts file or just something with the browser.

1. Change a site in the hosts file and redirect it to '127.0.0.1'

2. Open Command prompt and try these commands 'ipconfig /flushdns' and then 'ping <website you blocked>'

If all is correct it should return 127.0.0.1

thats the thing, for example if i added www.website.com into the hosts file and ping it. it times out. but even after i close the browser and come back , it still goes to www.website.com in the browser

but yes, it seems to be ignoring the Hosts file

Share this post


Link to post
Share on other sites
Eric    1,605
thats the thing, for example if i added www.website.com into the hosts file and ping it. it times out. but even after i close the browser and come back , it still goes to www.website.com in the browser

but yes, it seems to be ignoring the Hosts file

Did you try clearing your browser's cache?

Also, if I recall, the hosts file does not support wildcards, so a list like this:

www.blockdesite.com
forums.blockedsite.com
www1.blockdesite.com
www.blockedsite.org

must have a separate entry.

Share this post


Link to post
Share on other sites
kronckew    54

i also find the hosts file is not working in win7 rtm, i have 'shortcut' in there

192.168.2.1 router

to allow me to just type router in the address bar to connect to my router admin page. works fine in xpsp3. does not work in win7.

added a few real addresses to speed up dns lookups, they also were not recognised. i tried adding them to the similar lmhosts file. that worked. it appears win7 is indeed ignoring the hosts file.

lmhosts (no extension) lives in the same dir. as hosts. slightly different syntax allows directives, see lmhosts.sam.

it indicates lmhosts is parsed only AFTER dynamic lookups fail. wonder if hosts behavior has similarly been changed.

i'd prefer it to work the old way as in all pre-win7 microsoft os's all the way back.

Share this post


Link to post
Share on other sites
Saint Shiv    4

Make sure you disable DNS Client service via services.msc before you add any files to your host file, and as mentioned, flush your DNS cache afterwords. Using HostsXpert personally, works fine?

Share this post


Link to post
Share on other sites
nicolasavru    0

See if making the edit to hosts and then rebooting makes any difference. While experimenting with the DNS settings for my domain, I had to reboot before certain changes were 'seen' by Windows 7. Cleared DNS cache and browser cache, even tried a different browser, no change until I rebooted.

Share this post


Link to post
Share on other sites
ComputerGump    0

I have been banging my head for hours on this and I think I have found the answer. For whatever reason Microsoft has decided that a tab in between your ip and hostname in the host file will not work in Windows 7. Try taking out the tab and using a space instead. Microsoft sucks!!!

Share this post


Link to post
Share on other sites
+BudMan    3,737

Nonsense - tab clearly still works.. Not sure what you were doing wrong, but tab is just fine.

post-14624-0-51925700-1302883141.jpg

Share this post


Link to post
Share on other sites
ComputerGump    0

Nonsense - tab clearly still works.. Not sure what you were doing wrong, but tab is just fine.

post-14624-0-51925700-1302883141.jpg

If I take the tab out it works if it is in it doesn't. Not nonsense. If you are having problems I suggest you try it. It takes 2 seconds and if it doesn't work you are out 2 seconds.

Share this post


Link to post
Share on other sites
Ulpian    30

Are you using 64-bit version ?

Share this post


Link to post
Share on other sites
ComputerGump    0

Are you using 64-bit version ?

Yes I am.

Are you using 64-bit version ?

I take that back. This was on my VM machine which was running 32 bit.

Share this post


Link to post
Share on other sites
Blaze_Zewi    51

This is not the best way to block a website. Any person over 13 with half a brain can bypass this method.

Unless you manage to block all search engine like Google, Yahoo, Bing etc. This method is only useful for folks that are not computer illiterate.

All right enough of my of topic nonsense...

Like other have said. After making change to the host file. Clear your DNS and restart and see if it works.

Share this post


Link to post
Share on other sites
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.