• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Archived

This topic is now archived and is closed to further replies.

IE8 64-bit crashes visiting www.news.google.com

Recommended Posts

slamfire92    1,658

Before anyone asks: My PC is 100% clean. I run KIS 2009 and scan with SAS as backup. No problems when I ran IE7.

Everytime I visit www.news.google.com IE8 crashes:

Problem signature:

Problem Event Name: BEX64

Application Name: iexplore.exe

Application Version: 8.0.6001.18702

Application Timestamp: 49b3aebc

Fault Module Name: StackHash_c43a

Fault Module Version: 0.0.0.0

Fault Module Timestamp: 00000000

Exception Offset: 000000016fc2d590

Exception Code: c0000005

Exception Data: 0000000000000008

OS Version: 6.0.6001.2.1.0.256.6

Locale ID: 1033

Additional Information 1: c43a

Additional Information 2: 4eac8d2e259eeedd6d49ff64eae8b43e

Additional Information 3: 90a5

Additional Information 4: e50686b41abe2ccf7ebdcd4d03cb755d

If I send an error report I get a page telling me that "A malfunctioning or malicious add-on has caused Internet Explorer to close this webpage.". and under more information: " Windows Data Execution Prevention detected an add-on trying to use system memory incorrectly. This can be caused by a malfunction or a malicious add-on."

Again, the PC is clean, so it must be an incompatible add-on but the problem is that it doesn't tell me which add-on is causing the problem. I disabled every add-on and its still crashing on that page. Any way I can go about troubleshooting this?

Share this post


Link to post
Share on other sites
tinyavengerva    0

Firefox? :) It's not an addon if you are running "clean".

Share this post


Link to post
Share on other sites
ToneKnee    292

Works fine. Windows 7 build 7057.

Share this post


Link to post
Share on other sites
tinyavengerva    0

Check the event viewer?

Share this post


Link to post
Share on other sites
Raa    1,505

Ahh, you said KIS. Try ditching it for the test. Then ditch it permanently if it works.

Share this post


Link to post
Share on other sites
slamfire92    1,658
Ahh, you said KIS. Try ditching it for the test. Then ditch it permanently if it works.

I disabled KIS and still have the problem. My main browser is FF, but I don't like it when things are broke ;) No trouble at all from the 32-bit IE7.

Share this post


Link to post
Share on other sites
+Preppy    33

KIS? Doesn't their script checker cause problems like this? What happens if you rename or unregister srchpg.dll ?

Share this post


Link to post
Share on other sites
slamfire92    1,658

Update:

I installed IE8 on another Vista x64 PC and it too crashes on the very same page. Not only that, but I found that Windows Sidebar crashes when executed on both PCs as well. Sidebar has clock, weather, RSS feeds and calendar widgets running.

Share this post


Link to post
Share on other sites
+Preppy    33

Do you have KIS installed there too? Can you reproduce this on a system *without* Kaspersky?

Share this post


Link to post
Share on other sites
Snowl    41

Conspiracy theory? LOL.

Try running it under safe mode.

Share this post


Link to post
Share on other sites
slamfire92    1,658
Do you have KIS installed there too? Can you reproduce this on a system *without* Kaspersky?

Yes, both PCs run Kaspersky Internet Security 2009. One is build 454 and mine is running build.506. Unfortunately, I don't have anymore PCs to test on. I disabled the web traffic component (includes script blocking) and the problem remains. Turning KIS off completely does nothing to help, either.

@zach: Where is the location of srchpg.dll? I searched for it, but couldn't find it.

Share this post


Link to post
Share on other sites
slamfire92    1,658

I've confirmed Kaspersky Internet Security is the problem. Completely uninstalled and now IE8 64-bit and Windows Sidebar are functioning normally.

Share this post


Link to post
Share on other sites
slamfire92    1,658

Here is the fix. Credit goes to ShuttleXpC from the kaspersky forums:

Cause: Kaspersky blocks the jscript.dll from being registered for the x64 system.

1) Turn off Kaspersky and go to an elevated command prompt (Run as Admin) then simply type in:

2) regsvr32 jscript.dll

3) You are done, this registers the dll and fixes what Kaspersky blocked.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.