There are many great features available to you once you register at Neowin, including:

  • Richer content, access to many features that are disabled for guests like commenting on the front page
  • Access to a great community, with a massive database of experience on hard & software issues, gaming and recreational activities, and more
  • Access to the Neowin IRC - you could make a friend from across the world and talk to them live
  • Access to Neowin contests & subscription offers and forums that are not open to guests/li>
  • It's simple, and FREE! · Register here

Keeping Seagate Barracuda LP / Western Digital Green Drives Spinning


 Share

Recommended Posts

I recently purchased some cheap Seagate Barracuda LP 2TB drives on Newegg (they were on sale for 69.99). As i'm sure some of you know, these drives stop spinning after a period of inactivity to conserve power.

My question is, how can I prevent this? Yes, i'm horrible for not wanting to conserve power but it's quite annoying waiting for them to spin up every time I want to access some files. I was thinking of some program that would read/write a small file every 5 minutes, that *should* prevent it from happening.

I also have some WD Green drives which basically do the same thing.

Link to comment
Share on other sites

It's due to your power settings.

Go to Control Panel > Hardware and Sound > Power Options.

Click the "Change plan settings" link of your currently selected power plan.

click "Change advanced power settings" link

In the list of the window that comes up, click on Hard Disk. There you go.

I think this applies to all your hard drives plugged in.

Link to comment
Share on other sites

It's due to your power settings.

Go to Control Panel > Hardware and Sound > Power Options.

Click the "Change plan settings" link of your currently selected power plan.

click "Change advanced power settings" link

In the list of the window that comes up, click on Hard Disk. There you go.

I think this applies to all your hard drives plugged in.

Unfortunately, the Green hard drives, (at least with WD that is) will still power down, they do this automatically and quite quickly after you stopped accessing data from them.

Link to comment
Share on other sites

for WD green drive; search for a command line program called WDIDLE3. create a dos bootable disk and when you boot to dos; you can change the default spindown time. In my desktop; I set the spindown time to 5 mins from default 8 second of green drive.

Link to comment
Share on other sites

Hmm... Well, I know that Trillian keeps my hard drive from spinning down (as long as someone logs in/out every so often). Also, Folding@Home will make periodic writes to your hard drive (full writes of data as frequent as every 3 minutes), so there's that.

Edit: Oh, I wasn't aware of the command line program. That's useful

Link to comment
Share on other sites

Thank you for your valuable input.

Not only you'll age your drive early but you'll warm up you system couple of degrees since HD will create lot of heat over time. Also if the drive overheats for long period you'll start losing data.

Link to comment
Share on other sites

Not only you'll age your drive early but you'll warm up you system couple of degrees since HD will create lot of heat over time. Also if the drive overheats for long period you'll start losing data.

Heating does not tend to be that big a factor in MTBF for hard disks.

Link to comment
Share on other sites

Optimal operating temp for his HDD is 60?C, while mine even with good cooling is at 47?C right now. I can imagine the drive working at least 10/day would be running well beyond 60?C.

post-30626-0-83568200-1301880248.png

Link to comment
Share on other sites

It's better for disks to spin continously than to stop/start/ regularly.. as they are designed to continually spin..

Also does your system have poor airflow? That seems really high!

Link to comment
Share on other sites

It's better for disks to spin continously than to stop/start/ regularly.. as they are designed to continually spin..

Really that's the first time I heard of that.

Also does your system have poor airflow? That seems really high!

I got 6 drives, E6600, gt470 and 900W PSU all in a ATX Midtower case. :(

Link to comment
Share on other sites

My WD Green drive used to do this.

It is the head that is parking every few seconds to save power (the feature of the green drive series); nothing to do with Windows power options. The cure (as stated above) a firmware setting that needs a re-flash. Here's a topic regarding the excessive head parking.

The solution (to WD green drives excessive head parking):

1: Dowload WDIdle3 from the Western Digital site

2: Create an MS Dos startup disk. I had trouble with this in Windows 7 (the option was always greyed out); but HP created a piece of software that will allow you to create one. There is a nice topic with screenshots but Neowin blocks out the URL. This is what's left: /tutorials/46707-ms-dos-bootable-flash-drive-create.html.

3: Extract wdidle3 on to the start up disk you just created.

4: Boot the system using the new start up disk.

5: Type (without quotes) "wdidle3.exe /d". The /d disabled the idle timer all together. Then you can use Windows power options to control it.

6: The software will scan the drives you have attached and make changes where suitable. It should tell you everything is complete.

8: Reboot and load Windows. You may hear a lot of clicking, I thought I had broken my drive, but it needs a complete power on and power off cycle.

9: Turn off the PC completly and then turn it on again. It should now be fixed.

You may want to test to check the utility has worked. If so, slot these into the above:

4.1: Type "wdidle3 /r" to have the software report the current idling time out

6.1: Type "wdidle3 /r" to check it has been removed.

Other links of interest:

Load/Unload counter continue to increase for the WD RE2-GP SATA II hard drives

Load/Unload counter keeps increasing on a SATA 2 hard drive

Or you could, you know, not have bought green power drives...

Unfortunately, Western Digital's 2Tb drives are always in their "green" series. If you want large storage from WD, it has to be green.

Thanks

Link to comment
Share on other sites

Unfortunately, Western Digital's 2Tb drives are always in their "green" series. If you want large storage from WD, it has to be green.

While their biggest drive (3TB) is in fact only available in the Green series, they do make a 2TB Black drive.

Link to comment
Share on other sites

While their biggest drive (3TB) is in fact only available in the Green series, they do make a 2TB Black drive.

Oh - ha ha, so they do!

But then at ?127, I'll stick with the Green (?65) and run the hack :p

Link to comment
Share on other sites

My WD Green drive used to do this.

It is the head that is parking every few seconds to save power (the feature of the green drive series); nothing to do with Windows power options. The cure (as stated above) a firmware setting that needs a re-flash. Here's a topic regarding the excessive head parking.

The solution (to WD green drives excessive head parking):

1: Dowload WDIdle3 from the Western Digital site

2: Create an MS Dos startup disk. I had trouble with this in Windows 7 (the option was always greyed out); but HP created a piece of software that will allow you to create one. There is a nice topic with screenshots but Neowin blocks out the URL. This is what's left: /tutorials/46707-ms-dos-bootable-flash-drive-create.html.

3: Extract wdidle3 on to the start up disk you just created.

4: Boot the system using the new start up disk.

5: Type (without quotes) "wdidle3.exe /d". The /d disabled the idle timer all together. Then you can use Windows power options to control it.

6: The software will scan the drives you have attached and make changes where suitable. It should tell you everything is complete.

8: Reboot and load Windows. You may hear a lot of clicking, I thought I had broken my drive, but it needs a complete power on and power off cycle.

9: Turn off the PC completly and then turn it on again. It should now be fixed.

You may want to test to check the utility has worked. If so, slot these into the above:

4.1: Type "wdidle3 /r" to have the software report the current idling time out

6.1: Type "wdidle3 /r" to check it has been removed.

Other links of interest:

Load/Unload counter continue to increase for the WD RE2-GP SATA II hard drives

Load/Unload counter keeps increasing on a SATA 2 hard drive

Unfortunately, Western Digital's 2Tb drives are always in their "green" series. If you want large storage from WD, it has to be green.

Thanks

This is exactly the solution I was looking for, thank you Mr. Spoon!

Link to comment
Share on other sites

This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.