Jump to content



Photo

Windows 8/8.1 right click start menu shortcut

win8

  • Please log in to reply
22 replies to this topic

#16 +BeerFan

BeerFan

    Neowinian Senior

  • Joined: 19-July 06

Posted 11 September 2013 - 13:35

Have you installed any tools or utilities to replace the start button/menu that could've hijacked that area?

 

Nope. On the laptop I'm on right now, I just did a fresh install of the 8.1 Pro .iso yesterday after they made it available on MSDN.

 

I ran into this once -- turned out the folder containing these commands was missing.  Check yours:

 

C:\Users\<your_userid>\AppData\Local\Microsoft\Windows\WinX

 

Make sure you have content there and compare it to a new user (you may have to make one).  If yours is empty, copy from the new user.

 

-Forjo

 

Weird!  My domain account user folder does not even contain a \WinX subfolder.  It does exist on my local account, though.  Is this a bug?  Or is some weird domain policy preventing it?  I'll try creating a new domain profile to see what happens on that one.

 

are you able to right click elsewhere on the taskbar? can you access the taskbar properties?

 

Yes, right-clicking elsewhere on the Taskbar brings up the normal menus.




#17 +BeerFan

BeerFan

    Neowinian Senior

  • Joined: 19-July 06

Posted 11 September 2013 - 13:47

Update:  All new domain profiles created on either machine behave the same way:  no right-click menu on the Start Button.  So I'm guessing it has something to do with a domain policy.  Any idea where the specific policy might be hidden?



#18 Eric

Eric

    Neowinian Senior

  • Tech Issues Solved: 11
  • Joined: 02-August 06
  • Location: Greenville, SC

Posted 11 September 2013 - 13:52

There is a Windows+X group policy. It may be turned off.It's located in User Configuration's admin templates under the path "/Windows Components/File Explorer/Turn off Windows+X hotkeys".It may be located somewhere else on a domain but you can use the filter feature in gpedit

#19 Forjo

Forjo

    Neowinian

  • Joined: 17-January 13
  • Location: Houston, TX
  • OS: Windows 8.1, Windows Phone 8.1
  • Phone: Lumia 920

Posted 11 September 2013 - 13:55

 

Weird!  My domain account user folder does not even contain a \WinX subfolder.  It does exist on my local account, though.  Is this a bug?  Or is some weird domain policy preventing it?  I'll try creating a new domain profile to see what happens on that one.

 

If the folder doesn't exist, you won't get the menu. Copy the one from your local account to the same path of your domain account.

 

-Forjo



#20 +BeerFan

BeerFan

    Neowinian Senior

  • Joined: 19-July 06

Posted 11 September 2013 - 18:40

If the folder doesn't exist, you won't get the menu. Copy the one from your local account to the same path of your domain account.

 

-Forjo

 

Thank you for the reply and for the information.  I understand that the folder should be there in order for the WinX menu to be present.  What I'm trying to figure out is why it isn't there.

 

I just went in to Group Policy Management Console, and did a Block Inheritance (i'm a domain admin) from the OU that my machines get put in.  I wiped and reinstalled 8.1 Pro on my laptop.  Then, I deleted the old AD entry for it, rejoined the domain, and verified that upon 1st boot, my laptop was in the proper OU w/ the Block Inheritance option checked.  So in theory, it shouldn't be getting any kind of control from group policies.  However, the WinX menu is still missing from all domain accounts.

 

In other words, no progress yet.  Any suggestions as to how the menu is getting turned off would be appreciated.



#21 Forjo

Forjo

    Neowinian

  • Joined: 17-January 13
  • Location: Houston, TX
  • OS: Windows 8.1, Windows Phone 8.1
  • Phone: Lumia 920

Posted 12 September 2013 - 00:44

Thank you for the reply and for the information.  I understand that the folder should be there in order for the WinX menu to be present.  What I'm trying to figure out is why it isn't there.

 

I just went in to Group Policy Management Console, and did a Block Inheritance (i'm a domain admin) from the OU that my machines get put in.  I wiped and reinstalled 8.1 Pro on my laptop.  Then, I deleted the old AD entry for it, rejoined the domain, and verified that upon 1st boot, my laptop was in the proper OU w/ the Block Inheritance option checked.  So in theory, it shouldn't be getting any kind of control from group policies.  However, the WinX menu is still missing from all domain accounts.

 

In other words, no progress yet.  Any suggestions as to how the menu is getting turned off would be appreciated.

 

Are you using roaming profiles?

 

-Forjo



#22 +BeerFan

BeerFan

    Neowinian Senior

  • Joined: 19-July 06

Posted 12 September 2013 - 15:47

No, not to my knowledge.

 

However, we are using customized default domain profiles. I'm betting that's what's doing it.  We probably do not yet have a Windows 8-based default profile that contains the WinX folder.  So, when a Windows 8 machine joins the domain and gets a default profile, it is not getting the WinX folder inside the user's profile.

 

Does that sound right?



#23 aplocher

aplocher

    Resident One Post Wonder

  • Joined: 29-April 14

Posted 29 April 2014 - 03:02

I ran into this once -- turned out the folder containing these commands was missing.  Check yours:

 

C:\Users\<your_userid>\AppData\Local\Microsoft\Windows\WinX

 

Make sure you have content there and compare it to a new user (you may have to make one).  If yours is empty, copy from the new user.

 

-Forjo

 

I just wanted to say thank you Forjo / Neowinian!  I had made some GPO changes on our domain controller and thought for sure it had something to do with that, but coincidentally I also cleaned up my %APPDATA% folders and temp folders.  It had nothing to do with my group policy updates!  In case anyone needs the folder contents (at least for Win 8.1 Update 1), I'm attaching it to this post.

 

So the contents of this attached zip needs to go to:

C:\Users\<username>\AppData\Local\Microsoft\Windows

 

Or simply enter this into an address bar / run dialog (WIN-R): %APPDATA%\..\Local\Microsoft\Windows

 

The sub-folder needs to be called "WinX"

 

-Adam

Attached Files

  • Attached File  WinX.zip   9.52KB   41 downloads




Click here to login or here to register to remove this ad, it's free!