• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

Ignored users and their posts

Recommended Posts

Circaflex    3,555

For the longest time, when using the dark theme if you have a user on your ignore list and come across one of their posts, if you chose "show this post" nothing would happen. Usually for me, the page just scrolls to the top. It seems on each theme, there is a different issue.

 

Currently, on any of the themes the post is shown automatically. As if the ignore function is not working properly. I have cleared my cache, but this dates back to before the last few updates. I know for a fact "show this post" hasn't ever worked on multiple computers, browsers and configs.

 

 

 

modern.thumb.PNG.01add1e479d22820ffd62455436e06cc.PNG

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
Steven P.    13,864

It's possible that the ignore function was reset, because now you can ignore PM, Posts and something else I can't remember right now. Go to your ignore settings and ensure that the correct checkbox is ticked, you might have to uncheck it/save/check it to reset the ignored user. I know of a bug with mobile where the post might be showing, but not on desktop (I also checked the setting myself last week when someone else complained about it on PM to me).

 

BTW by default, staff groups can't be ignored.

Share this post


Link to post
Share on other sites
Circaflex    3,555
6 hours ago, Steven P. said:

It's possible that the ignore function was reset, because now you can ignore PM, Posts and something else I can't remember right now. Go to your ignore settings and ensure that the correct checkbox is ticked, you might have to uncheck it/save/check it to reset the ignored user. I know of a bug with mobile where the post might be showing, but not on desktop (I also checked the setting myself last week when someone else complained about it on PM to me).

 

BTW by default, staff groups can't be ignored.

for the last year weve been able to ignore pm, posts and mentions that isnt anything new. "Posts" is checked, just the posts arent hidden they are expanded.

Share this post


Link to post
Share on other sites
Steven P.    13,864

Yeah what I am saying is, when I checked the feature myself it worked fine. But I had added a member (to test) right there and then.

 

I saw a text link and the post under it was hidden.

Share this post


Link to post
Share on other sites
Circaflex    3,555

Just removed the two I have on my list, and readded them and the content is still showing up automatically. I even tested it by adding another random member and same result.

 

 

edit @Steven P. it must have to do with subscriptions. If I add a user that has a neowin sub, their comment will show up automatically. Adding a standard user works.

Share this post


Link to post
Share on other sites
Steven P.    13,864
2 hours ago, Circaflex said:

Just removed the two I have on my list, and readded them and the content is still showing up automatically. I even tested it by adding another random member and same result.

 

 

edit @Steven P. it must have to do with subscriptions. If I add a user that has a neowin sub, their comment will show up automatically. Adding a standard user works.

AHA! The plot thickens! :shifty: 

  • Thanks 1

Share this post


Link to post
Share on other sites
Steven P.    13,864

Edit, I think I know what this is but I will have to do a bit of digging.

  • Thanks 1

Share this post


Link to post
Share on other sites
Steven P.    13,864

ATM it is looking like an IPB bug. In order to do post highlighting for staff and subscribers "highlight posts" has to be switched on in the group setting. "Can be ignored" is also enabled, but the "Highlight posts" seems to override it, I am pretty sure this is an IPS related bug since I removed the post highlighting CSS that I did to test and it doesn't make a difference.

 

I have reported it to IPS staff. I am too tired to find a workaround for it atm, maybe IPS will say it's known or come with a trick to override the highlight setting when ignored.

  • Thanks 1

Share this post


Link to post
Share on other sites
Circaflex    3,555

@Steven P. seems to be fixed now.

Share this post


Link to post
Share on other sites
Steven P.    13,864

It is :p

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.