• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

New GPU not being recognised

Recommended Posts

loux    0

Hi guys, 

 

I have an old PC that I have just started using again, the GPU is really not up to scratch, even for when I bought it so I have just upgraded it. I bought a Palit GTX 1650 Super however I cannot get it to be recognised. 

I have updated the Bios and have the latest Nvidia drivers installed, is this a problem of the card being too new and not compatible or is it that there is not enough power coming form the PSU? The PSU says its 500W however the research i've done says that the old/unbranded PSUs are unreliable, so if i bought a new PSU would it work or is there something else I can do for it to be recognised? 

 

Bit of a noob when it comes to computers so any help would be appreciated, thanks!

 

Specs:

Motherboard: Gigabyte GA-Z77-D3H

CPU: Intel i7 3770k

GPU: Palit GTX 1650 Super

PSU: AD-E500AE-A5/A6

 

 

Share this post


Link to post
Share on other sites
goretsky    1,184

Hello,

 

You can definitely try a newer, higher-wattage replacement supply. 

 

Regards,

 

Aryeh Goretsky

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.