Can't copy and paste links


 Share

Recommended Posts

I've noticed after the forum upgrade every time I try to paste a link in a forum post it strips out the link and all i'm left with is text.

 

As an example, i'm going to copy an amazon page link from the address bar of my browser and paste it below.

 

AmazonSmile: iodd Iodd2531 - USB3.0 - HDD - SSD - Virtual CD-ROM - Enclosures - Made in Korea … (1 Unit/lot): Electronics

Link to comment
Share on other sites

I noticed that the other day as well.  As a workaround I just pasted the link in Notepad and copied again and all is fine.

 

Looks like the forum is trying to get the title of the page but fails to actually turn it into a hyperlink after pasting.

Link to comment
Share on other sites

Link to comment
Share on other sites

just tried it with firefox and Edge . Only extension in Firefox is Lastpass. Also cleared my edge cache.

 

ConnectWise Control Remote Support Software (screenconnect.com)

Link to comment
Share on other sites

Amazon.com: iodd Iodd2531 - USB3.0 - HDD - SSD - Virtual CD-ROM - Enclosures - Made in Korea … (1 Unit/lot): Computers & Accessories

 

^ pasted Steve's link copied from Amazon's tab using Edge v87.0.634.0

 

Now if copy and paste the link directly from Steve's post, https://www.amazon.com/Iodd-Iodd2531-Black-Virtual-Enclosures/dp/B00TDJ4BJU/ref=sr_1_1?dchild=1&keywords=Iodd2531+-+USB3.0+-+HDD+-+SSD+-+Virtual+CD-ROM&qid=1600187742&sr=8-1 it fine.

Link to comment
Share on other sites

How to use DISM command tool to repair Windows 10 image | Windows Central (windowscentral.com)

 

Just tried it on my computer downstairs too.

Link to comment
Share on other sites

5 minutes ago, primortal said:

Amazon.com: iodd Iodd2531 - USB3.0 - HDD - SSD - Virtual CD-ROM - Enclosures - Made in Korea … (1 Unit/lot): Computers & Accessories

 

^ pasted Steve's link copied from Amazon's tab using Edge v87.0.634.0

 

Now if copy and paste the link directly from Steve's post, https://www.amazon.com/Iodd-Iodd2531-Black-Virtual-Enclosures/dp/B00TDJ4BJU/ref=sr_1_1?dchild=1&keywords=Iodd2531+-+USB3.0+-+HDD+-+SSD+-+Virtual+CD-ROM&qid=1600187742&sr=8-1 it fine.

Yep, if I copy a link already in this post it posts jus fine, but not if I copy it from the address bar.

Link to comment
Share on other sites

Can't copy and paste links - Site & Forum Issues - Neowin

2 minutes ago, Riggers said:

Test:

 

From address bar -> https://www.cgsecurity.org/wiki/TestDisk

 

Copy Paste from Wordpad -> https://www.cgsecurity.org/wiki/TestDisk

 

Got this pop up "The link could not be embedded because of an unexpected error: error: undefined."

 

Both seem fine now though 🙄

Which browser?

Link to comment
Share on other sites

Just testing using this page from address bar. I'm using current stable Edge Chromium. On Windows 10 2004.

 

https://www.neowin.net/forum/topic/1400157-cant-copy-and-paste-links/?tab=comments#comment-598583124

 

Before submitting, a box popped up saying your link has been embedded but gave option to just post as link instead.

 

Testing using a different address.

 

http://www.silverlakesanddunes.net/

 

Got a box saying that link couldn't be embedded because only https links are allowed.

Link to comment
Share on other sites

2 minutes ago, cork1958 said:

Just testing using this page from address bar. I'm using current stable Edge Chromium. On Windows 10 2004.

 

https://www.neowin.net/forum/topic/1400157-cant-copy-and-paste-links/?tab=comments#comment-598583124

 

Before submitting, a box popped up saying your link has been embedded but gave option to just post as link instead.

 

Ya ... I don't get any of that, it just spits out text.

Link to comment
Share on other sites

I imagine it relates to this: https://support.microsoft.com/en-gb/help/4575292/improved-copy-and-paste-of-urls-in-microsoft-edge#:~:text=Change the default behavior&text=In Microsoft Edge%2C select More,URL as a web address.

 

I'll have to have a look and see what it is about the format of what gets pasted that causes the editor to strip the actual link

Link to comment
Share on other sites

On 16/09/2020 at 17:07, DaveLegg said:

I imagine it relates to this: https://support.microsoft.com/en-gb/help/4575292/improved-copy-and-paste-of-urls-in-microsoft-edge#:~:text=Change the default behavior&text=In Microsoft Edge%2C select More,URL as a web address.

 

I'll have to have a look and see what it is about the format of what gets pasted that causes the editor to strip the actual link

 
 
 

That's seems to be the issue.  If change the setting to plain text, pasting links now are fine.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.