Decreased battery life since Android 11 installed?


Recommended Posts

+jnelsoninjax

Has anyone else noticed that the battery life seems to be decreased since the newest update? I have noticed that the battery seems to run down faster now then it did with the previous version. Is it me or is it decreased?

Link to post
Share on other sites
  • +jnelsoninjax changed the title to Decreased battery life since Android 11 installed?
techbeck

No.  Working fine for me and have not noticed a difference.

Link to post
Share on other sites
+jnelsoninjax

I have noticed it on my Pixel 3A, and my Niece has a Pixel 2, and her phone doesn't last the whole day, now that may have something to do with what she has installed, but I don't let things run in the background on my phone.

Link to post
Share on other sites
goretsky

Hello,

 

No difference noticed on my two relatively recently (1-2 years old) devices, however, if your device manufacturer was doing CPU throttling similar to Apple on their iPhones in order to improve battery runtime, they may have removed that functionality.  That is just a guess, of course.

 

Regards,

 

Aryeh Goretsky

 

Link to post
Share on other sites
+jnelsoninjax
47 minutes ago, goretsky said:

Hello,

 

No difference noticed on my two relatively recently (1-2 years old) devices, however, if your device manufacturer was doing CPU throttling similar to Apple on their iPhones in order to improve battery runtime, they may have removed that functionality.  That is just a guess, of course.

 

Regards,

 

Aryeh Goretsky

 

My device is a Google Pixel, so I don't think that they are doing throttling.

Link to post
Share on other sites
techbeck
On 23/11/2020 at 11:11, jnelsoninjax said:

I have noticed it on my Pixel 3A, and my Niece has a Pixel 2, and her phone doesn't last the whole day, now that may have something to do with what she has installed, but I don't let things run in the background on my phone.

I have the 4XL and my mom has the 3.  Both are fine.  Can always try a factory reset and see if that helps.  I have had to do that sometimes after a OS version update to address some issues.  Then installing apps one by one to see if one of them causes the issue.

 

Seeing reports that removing the Tunein Radio app fixed some users issue.  Not sure if that have that installed.

Link to post
Share on other sites
+jnelsoninjax
7 hours ago, techbeck said:

I have the 4XL and my mom has the 3.  Both are fine.  Can always try a factory reset and see if that helps.  I have had to do that sometimes after a OS version update to address some issues.  Then installing apps one by one to see if one of them causes the issue.

 

Seeing reports that removing the Tunein Radio app fixed some users issue.  Not sure if that have that installed.

Thanks for the suggestion. I have the 3A XL, and do not have the Tunein Radio, but I might get bored and do a reset and go from there!

  • Like 1
Link to post
Share on other sites
techbeck
2 hours ago, jnelsoninjax said:

Thanks for the suggestion. I have the 3A XL, and do not have the Tunein Radio, but I might get bored and do a reset and go from there!

Could be another app causing the issue as well.   Reset may or may not help but couldn't hurt.  Does not seem to me affecting all phones of the same model tho.  Prob a software fix that hopefully will come soon

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.