"Limited connectivity" starting with Vista RC2.


 Share

Recommended Posts

After several happy months of running Windows Vista RC1, I've upgraded to RC2. Ever since that day, I've been intermittently getting a "Limited connectivity" error that requires my network adapter to be reset. I don't want to go back to XP or RC1, so I need to make this work.

My specs: a Pentium D on an Intel board with integrated PRO/1000 PM network adapter. Linksys WRT54G v4 router, connected over wire.

The problem seems to be worst when the connection is consuming a lot of bandwidth (particularly when using uTorrent).

So far, I've tried a few things (based on extensive research):

1. Reinstalled the network card drivers

2. Changed the advanced settings to turn IPv4 and IPv6 checksums off

3. Disabled SPI firewall on the router.

4. Installed the DD-WRT firmware (v23SP2) on my router.

5. Decreased the number of allowable half-open connections in uTorrent to 2.

6. Unchecked the IPv6 protocol in my network settings.

7. Switched from using the router's DHCP to a static IP on my machine.

After all of these things, I still have intermittent connection drops where the lovely yellow triangle with an exclamation mark in it proclaims that I have limited connectivity. It seems to me to be more like *zero* connectivity, as I can't usually even reach my router once this happens.

Based on all the research I've done, I really feel like Vista's relationship with my router (specifically after the installation of RC2) is the area of trouble. I've considered going back to RC1, or XP, but I would like to resolve this issue if at all possible.

Thanks in advance for preventing me from having to reinstall my OS! ;)

Link to comment
Share on other sites

Try this - go into the properties of your network adapter and DISABLE the following:

IP Checksum Offload

TCP Checksum Offload (IPv4)

TCP Checksum Offload (IPv6)

UDP Checksum Offload (IPv4)

UDPChecksum Offload (IPv6)

Link to comment
Share on other sites

Try this - go into the properties of your network adapter and DISABLE the following:

IP Checksum Offload

TCP Checksum Offload (IPv4)

TCP Checksum Offload (IPv6)

UDP Checksum Offload (IPv4)

UDPChecksum Offload (IPv6)

I've already done this (see step 2 above). No dice. I'm considering changing network cards or getting a different router, but I would hate to make an unnecessary purchase. Does anyone else have any alternative thoughts on this?

Link to comment
Share on other sites

This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.