Sign in to follow this  

USB Hubs not working [windows 7 64 bit]

Recommended Posts

brandon99901    0

Recent Notable Laptop events


-Yesterday my laptop power just cut off unexpectedly so i thought nothing of it (it is an old laptop that overheats a lot),

-except today when i turned on my laptop i had found out that somehow a program had installed itself onto my laptop (i'm using Kaspersky internet security) The program turned out to be an extension for google chrome that added adverts to all websites. Luckily i had adblock turned on so when chrome was started my laptop didn't get any other uninvited visitors.

-Anyway after uninstalling and disinfecting my computer the laptop's graphics card just stopped working.(i am assuming it was the graphics card i have no proof but the windows pop up boxes i received was leaning towards the possibility that that had happened, It kept saying graphics something or other has stopped working)

-then when i rebooted my laptop there was some kind of proxy disconnecting me from the internet. Whenever i turned on any program witch required internet access it wouldn't connect although my router and internet was all fine and working.

-after trying to reset some of my settings i decided to roll back a couple of days to a point where this malware wasn't infected on my laptop.


USB issues started to arise


the virus is gone and all traces of it has been eradicated (or at least i think so) and my mouse and external hard drive etc was working fine until i moved my laptop. I didn't drop it or hit it i gently placed it on my desk then placed my keyboard (piano/keyboard) where my laptop was and moved my laptop to a bed side table. shortlly after i moved it i started plugging in my USB devices and after i placed in my mouse all my USB devices stopped receiving power.


Solutions i have tried


-i have tried to scan for hardware changes in the device manager and that hasn't worked

-I had also tried uninstalling my USB device controllers and restarting my laptop but that hasn't worked either


Laptop Specs


-processor - Intel® Core i5 CPU 2.4GHz            M450 @ 2.40 GHz

-Installed Memory (RAM) - 4.00GB (3.86 GB Usable)

-System Type - Windows 7 64 bit operating system

-Graphics Card - ATI Mobility Radeon HD 5470

-USB Controller - Intel® 5 series/3400 Series Chipset Family USB Enhanced Host Controller 3B34 and 3B3C


Other Notes


The Universal Serial Bus Controllers tabs have no errors on inspection and looking into the USB root hubs

Share this post

Link to post
Share on other sites
Nick H.    7,970

What happens if you unplug all of your USB devices and add them one by one again? You mentioned that they received power until you plug the mouse in, what if you plug the mouse in first?

I'm working with the idea that it's a power issue, and perhaps you are adding too many USB devices at one time which is causing the issues. It would also be an idea to try and find out why the power went out on the laptop in the first place.

Share this post

Link to post
Share on other sites
brandon99901    0

The second i unplugged my mouse the power returned to the other USB devices and when i plugged the mouse back in there was no power more power issues whatever the problem was it is gone. Maybe one of my earlier tries to resolve the problem just took time to kick in or maybe it was just an abnormality of using a really old laptop. And as for the power cutting i have just figured out what most likely is causing that. about 6 months ago i took the laptop apart to clear out the dust because it was overheating my laptop causing the safety mechanisms to turn on switching the laptop off, anyway upon opening the laptop up i managed to disconnect the power button from the processor causing the button to not work turning on or off my laptop after i fiddled with the white tab to get the wire back in i managed to get a connection working between the button and the laptop however the connection was a weak one and the light on the power button is a prime example of that as it has been extremely dim since that day.



Anyway thank you Nick H, i am not sure if your solution was the right one but the issue is resolved

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.