Windows 8.1 is forgetting Ctrl+1,2,3,4,5 shortcuts designated for keyboard layout switching after wa


 Share

Recommended Posts

I have a configuration of Ctrl+1,2,3,4,5 shortcuts for switching keyboard layouts on Windows 8.1.

 

Once I boot up my laptop they work just fine and the layouts shortcuts setup window looks like this if I open it:

original?v=mpbl-1&px=-1

 

However now when I close my laptop, putting it into sleep mode, and then open it again, the keyboard shortcuts stop working and if I open the aforementioned setup window, it also looks as if I have none configured:

original?v=mpbl-1&px=-1

 

To get my shortcuts back after sleep mode I have either to reboot the laptop, or assign the shortcuts again manually.

 

This is a problem I've experienced before on this same machine (Lenovo Yoga 13) with Windows 8 (before the 8.1 update) and I guess at that time it dissapeared after some editing of the list of layouts I use.

But now I've added some layouts to the list, and then removed some of them and so on and here is what I get again.

Maybe there is some branch of Windows Registry involved with the layouts and keyboard-shortcuts messed up and I could simply remove the registry branch and start with a clean slate?

Link to comment
Share on other sites

It looks like these settings are stored here:

HKEY_CURRENT_USER\Control Panel\Input Method\Hot Keys

 

Defaults are loaded here:

HKEY_USERS\.DEFAULT\Control Panel\Input Method\Hot Keys

 

I assume that your machine locks and you need to login after it wakes from sleep?

Link to comment
Share on other sites

It looks like these settings are stored here

 

Thank you!

 

If I just remove the HKEY_CURRENT_USER\Control Panel\Input Method\Hot Keys branch, will Windows recreate it clean, or will it cause some further error?

 

I assume that your machine locks and you need to login after it wakes from sleep?
 
Yes - it does. I was just about to ask how it matters, but actually now I see that the same problem appears once I do Win+L and log-in back. Is it some known bug then?
Link to comment
Share on other sites

 

Thank you!

 

If I just remove the HKEY_CURRENT_USER\Control Panel\Input Method\Hot Keys branch, will Windows recreate it clean, or will it cause some further error?

 

 

 
Yes - it does. I was just about to ask how it matters, but actually now I see that the same problem appears once I do Win+L and log-in back. Is it some known bug then?

 

 

I would assume that the keys will be re-created from values in the .DEFAULTS key if you wipe what's in HKCU. However, I would still export any existing values so that you have backups to restore. I'm skeptical that the values of these keys are being rewritten on logout/login, but it's worth a look.

 

I'd be curious to see whether rewriting the .DEFAULTS with your custom settings is sufficient to resolve the issue, or whether this arises with a different (fresh/local) user profile.

Link to comment
Share on other sites

What really seemed to help was rewriting the .DEFAULTS with my HKEY_CURRENT_USER settings!

 

Thank you a lot! I would have never figured this out myself and using Ctrl+1,2,3 is a huge part of my typing process!  :D

 

Ofcourse now one should remember to do it every time after changing the layout shortcuts settings! I guess we should make some kind of bug report for Microsoft out of it! :)

 

I am attaching my old (messed up) defaults and the new ones (these are .reg-files with extensions changed to .txt) for the record  :shiftyninja:

default hotkeys.txt

new default hotkeys.txt

Link to comment
Share on other sites

What really seemed to help was rewriting the .DEFAULTS with my HKEY_CURRENT_USER settings!

 

Glad you got this resolved.

 

Anyone on W10 Preview able to reproduce the issue? If so, may be worth a bug report if it's not already in feedback.

 

Edit: I'm not seeing this on Windows 8.1; my user's Standard/non-admin, linked to my MS account. So far only have two shortcuts assigned to languages, and tried locking and logging back in.

 

got it to work, have loaded Chinese, French? ??Occitan, assigned them to 1 -4 similar to that described in the first post. My hotkeys get wiped on lock and logging back in.

Link to comment
Share on other sites

  • 2 months later...
  • 4 months later...
  • 4 weeks later...
This topic is now closed to further replies.
 Share