• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

Vista slow at copying files

Recommended Posts

mrchetsteadman    476

Its fast as hell for me. I just transfered 146GB from one HD to another and it took about 15 minutes.

Share this post


Link to post
Share on other sites
1Frothy    0

Very very slow copying from DVD Disc to Hard Disc. And I have installed all the right Intel drivers as recommended by intel.

Share this post


Link to post
Share on other sites
Rahul    0

[ Smart Ass comment of the Day ] I think either we have to wait till the Retail release of the product or we have to wait till the Service Pack 1 or we all have to shift to a Mac or Linux or Stick to Windows XP [ /Smart Ass comment of the Day ]

Share this post


Link to post
Share on other sites
1Frothy    0

Fair comment. From my experiences with Vista I hope SP1 comes soon and really fixes this and dozens of other very annoying features.

Share this post


Link to post
Share on other sites
Brandon Live    232
Very very slow copying from DVD Disc to Hard Disc. And I have installed all the right Intel drivers as recommended by intel.

I'm going to bet that installing those Intel drivers was your mistake. The Microsoft-provided IDE/ATAPI drivers always work better...

Share this post


Link to post
Share on other sites
AxelStone    0

Remember, Vista tends to eat 300+Mb, where I've seen an average of 400+ of RAM at idle. You only have 512... that could be problem 1. Problem 2, HD near full/not defraged. Problem 3, Older Mobos sometimes cause all the winOS's to set the controler to PIO mode, make sure its set to UDMA. If i had a vista machine handy I'd give you step-by-step. Last problem, Check Intel's site for a chipset update. Microsofts Controler drivers tend to run "compatibility" Which you dont always get great performance out of, if you used intels they not be vista tested yet. Although I've rare to never had problems with intel's chipset drivers it could be you downloaded it before they completed the "vista" drivers.

Share this post


Link to post
Share on other sites
eleeter    0

Slow file copies has nothing to do with drivers, chipsets etc. Vista is just SLOW SLOW SLOW when copying large numbers of files. It's a pathetic bug that needs to be fixed!

Share this post


Link to post
Share on other sites
xpablo    136

I too have a similar problem, but more with networked Pc's on my Lan than between partitions.

I use sendto 1.6 for transfering files between hard drives and directories on Vista.

works great.

http://www.trogsoft.com/downloads/files/sendto16.exe

My main problem is with transferring files across my Lan from Vista, I now have to resort to pulling them off Vista from my other computers.

Share this post


Link to post
Share on other sites
Spooky    0

Concerning speed with moving files across LAN's; I found that my files moved slowly too while I had routers in place that didn't support IPV6. I've since switched the routers out for new ones that do support IPV6, but before I switched them I found that disabling IPv6 using the below reg entry solved the problem:

Windows Registry Editor Version 5.00

; Disable IPv6 over all interfaces and prefer IPv4 to IPv6
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters]
"DisabledComponents"=dword:000000ff

Also see http://www.microsoft.com/technet/community...guy/cg1005.mspx for information concerning IPV6 and the above reg key.

Share this post


Link to post
Share on other sites
aristofeles    12

Concerning speed with moving files across LAN's; I found that my files moved slowly too while I had routers in place that didn't support IPV6. I've since switched the routers out for new ones that do support IPV6, but before I switched them I found that disabling IPv6 using the below reg entry solved the problem:

Windows Registry Editor Version 5.00

; Disable IPv6 over all interfaces and prefer IPv4 to IPv6
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters]
"DisabledComponents"=dword:000000ff

Also see http://www.microsoft.com/technet/community...guy/cg1005.mspx for information concerning IPV6 and the above reg key.

Didn't fix for me - my processor goes to 100% on network transfers >from< my PC (I can get a file without any problem).

It has been like this since RC2: if I must transfer a large file, I "just" burn a DVD or log on XP.

Share this post


Link to post
Share on other sites
freak_power    0

Try to do hard drive defragmantion...and good luck with that...It takes hour to complete. And you can't even see the pogress...total CRAP!

Vista needs service pack..badlyyy

Share this post


Link to post
Share on other sites
Enphenate    0

yeah i have noticed that transferring files from 1 HD to another takes SOOOOOOO LONG#$R3

my system is

amd x2 4800+

2 gigs of corsair ram (2 sticks 1 gig each)

2 hard drives, main - hitachi 160 sata II hard drive... 2nd is 120gb drive..

nvidia 7800gtx

when i first installed vista i tried transferring files from my 120 gig to my 160, i was transferring like 50 gigs of music and it took about 2 hours...

than when i transferred my music back from my main hd to my secondary... it toook SOOOO loong about a hour n a half :angry:

theres no possible way its my hardware because on win xp i know that the max time it would take to copy that stuff would probably be like 20 minutes

i have no clue why its going so slow... but it sucks :no: :(

Share this post


Link to post
Share on other sites
NoFateVista    0

i have the same problems

copying files from partition to network folders or other partitions just take ages.... :s

Share this post


Link to post
Share on other sites
freak_power    0

i have the same problems

copying files from partition to network folders or other partitions just take ages.... :s

I pointed it like 4 months ago, nobody cared. I wonder what Beta testers were doing...taking screenshots i guess and uploading to rapidshare... :no:

Share this post


Link to post
Share on other sites
NoFateVista    0

*up*

no solution yet?

I encounter this problem everyday on my work, i hate it!!!!

Share this post


Link to post
Share on other sites
Hello1024    0

Same problem here - seems bad with either lots of small files, or a few big files, it doesn't seem to be hardware limited, because if I copy files from one vista pc to another vista pc via a gigabit network cable - neither hd's activity light is consistantly on (on less than 50%of the time) - the cpu usage on either pc isn't 100%, the network isn't saturated - I don't know what else to try. The maximum speed is about 5 Mbytes per sec.

If I have time, I might try writing my own copy program to work over the network, without using smb shares (using tcp and my own app-layer protocol instead), and see what transfer rate I get - that should eliminate the possibility of a hardware limitation or a driver problem, while also highlighting the speed the microsoft copy should be aiming for.

Share this post


Link to post
Share on other sites
l0g0ut    0

i might be shooting in the dark here but have you guys tried disabling Shadow Copy feature in Vista? i suspect it tried to make more than 1 copy of the file you're trying to move. i don't really know how Shadow Copy works in Vista. i'm just guessing here.

Share this post


Link to post
Share on other sites
NewB4Ever    0

Hey guys and gals,

I "Think" I solved the answer to the slow copying. I came across this while trying to uninstall the MS SQL sync program. This may work for you I have noticed a HUGE increase on the web and on my network with this. I use Ultimate btw.

Start >> Control Panel >> Programs and Features

Click on " Turn windows features on or off" on the left side of the panel

Takes a sec to load all the features

Uncheck "Remote Differential Compression"

I also unchecked "Print Services" (Since I don't have a printer)

Click "Ok" and you will be all set.

I then copied a 700 movie from one drive to another and it took less then 10 secs.

-+>Aaron

Let me know if it works for you.

Edited by NewB4Ever

Share this post


Link to post
Share on other sites
franzon    7

I've tested the file copy with XP and Vista RTM with a chronometer (file copy from DVD to Hard Disk and from Hard Disk to Hard Disk) and the speed is the same. No performances slow down

Share this post


Link to post
Share on other sites
NoFateVista    0

test it with a networkshare

Share this post


Link to post
Share on other sites
Brody McKee    2

I think you guys have some settings wrong... my PC is no slower than XP... not at all. Copying files is something I do reguarly and I wouldn't be using Vista if it was slower than XP.

Share this post


Link to post
Share on other sites
firemunki    0
Hey guys and gals,

I "Think" I solved the answer to the slow copying. I came across this while trying to uninstall the MS SQL sync program. This may work for you I have noticed a HUGE increase on the web and on my network with this. I use Ultimate btw.

Start >> Control Panel >> Programs and Features

Click on " Turn windows features on or off" on the left side of the panel

Takes a sec to load all the features

Uncheck "Remote Differential Compression"

I also unchecked "Print Services" (Since I don't have a printer)

Click "Ok" and you will be all set.

I then copied a 700 movie from one drive to another and it took less then 10 secs.

-+>Aaron

Let me know if it works for you.

This did not work for me...Using the Vista RTM from MSDN

Hopefully this issue gets resolved soon as I don't really feel like going back to XP...but these slow network transfers are pretty much unbearable

I think you guys have some settings wrong... my PC is no slower than XP... not at all. Copying files is something I do reguarly and I wouldn't be using Vista if it was slower than XP.

care to share with the rest of us what settings you changed or you are just lucky by default?

I don't think many of us went tinkering with things that made our transfers slower...

Share this post


Link to post
Share on other sites
Marciff    0

Copying files from HD to HD is very slow for me in Vista.

Share this post


Link to post
Share on other sites
McDave    9

What about turing off the indexing service? R.Click on the hard drive -> Porperties then the last tick box about indexing.

Share this post


Link to post
Share on other sites
maxsquared    0
Hey guys and gals,

I "Think" I solved the answer to the slow copying. I came across this while trying to uninstall the MS SQL sync program. This may work for you I have noticed a HUGE increase on the web and on my network with this. I use Ultimate btw.

Start >> Control Panel >> Programs and Features

Click on " Turn windows features on or off" on the left side of the panel

Takes a sec to load all the features

Uncheck "Remote Differential Compression"

I also unchecked "Print Services" (Since I don't have a printer)

Click "Ok" and you will be all set.

I then copied a 700 movie from one drive to another and it took less then 10 secs.

-+>Aaron

Let me know if it works for you.

That worked for me, I am on RC2, what is remote differetial compression anyway?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.