• Sign in to Neowin Faster!

    Create an account on Neowin to contribute and support the site.

Sign in to follow this  

Vista slow at copying files

Recommended Posts

Dane    176

I still have this problem as well. It sucks.

Share this post


Link to post
Share on other sites
Lawliet    0

Unchecking "Remote Differential Compression" seemed to have worked somewhat. Still needs some testing to figure out. That feature seems kinda cool to disable though...

More info on the feature: http://msdn2.microsoft.com/en-us/library/aa372948.aspx

EDIT: I think this started happening only when I turned on file sharing over network. Perhaps Windows thinks I am copying files over the network when in fact I'm not. :hmmm:

Share this post


Link to post
Share on other sites
Examinus    5

Hi,

I also had this problem but I think I've sorted it.

Go into Device Manager, open the properties windows for your HDD, select policies, check the box that says "enable advanced performance".

It seems to have sorted the problem for me. Sorry if it's already been posted.

:)

Share this post


Link to post
Share on other sites
Tomxun    0

Hi!

U guys have to try this: Rightklick on your HDD or partition -> properties -> disable the indexing option for the searchfunktion.

Sry for my english.

Share this post


Link to post
Share on other sites
Adam1V    90

im glad its not just me, it doe appear to be slightly slow.

It also seems to spend more time thinking about how long its going to take to do it before it starts to copy.

Atleast with XP it started to copy straight away, even if for the first 10 seconds it said it will take a week :)

Share this post


Link to post
Share on other sites
solardog    0
Hey guys and gals,

I "Think" I solved the answer to the slow copying. I came across this while trying to uninstall the MS SQL sync program. This may work for you I have noticed a HUGE increase on the web and on my network with this. I use Ultimate btw.

Start >> Control Panel >> Programs and Features

Click on " Turn windows features on or off" on the left side of the panel

Takes a sec to load all the features

Uncheck "Remote Differential Compression"

I also unchecked "Print Services" (Since I don't have a printer)

Click "Ok" and you will be all set.

I then copied a 700 movie from one drive to another and it took less then 10 secs.

-+>Aaron

Let me know if it works for you.

Holy crap, that worked. Thank you! I have just about had it with Vista. Seems every new OS takes me longer to get it running right. When I heard my HDD thrashing like a marlin over a friggin zip file I almost lost it. I had about 1 more minute of patience left.Thanks again.

Share this post


Link to post
Share on other sites
L3thal    2

I'll give NewB4Ever's tip a try to see if that will work.

Share this post


Link to post
Share on other sites
winXpert    0

You can also check the sytem board manufacturer's website for a newer bios update if available. Also, I remember reading a while ago that certian VIA southbridge chipsets caused issues with slow/corrupt data transfer -- try the VIA 4-in-1 update pack. For intel, I downloaded the latest INF utility and noticed updated drivers upon reboot. Let me know if you see better results.

::winXpert::

Share this post


Link to post
Share on other sites
L3thal    2

Thanks for the tip, Newb4Ever. Files are now being transferred with blazing speed after unchecking "remote differential compression". I left Print service on for my printer and that doesn't seem to cause anything abnormal to occur to the speed. The remote compression feature is what definiately slows down tranfers.

Share this post


Link to post
Share on other sites
Gurra    0

Did not help... Still about half network speed of XP... A real bug in vista.

Share this post


Link to post
Share on other sites
ZombieFly    222

i can confirm that disabling the remote differential compression service appears to have had a positive effect. I havent directly compared it to xp yet though, i will do that when i get home and post the result.

Share this post


Link to post
Share on other sites
balupton    0

yeah i also find that it copies extremely slow from one hdd or removeable media to another.... haven't tried the remote differential compression solution, but that must be there for a reason? And seems that it is a feature that should be helping....

Share this post


Link to post
Share on other sites
pewe    0
And seems that it is a feature that should be helping....

That may be - but disabling it on my system resulted in the file transfer speed copying files from an XP PC went up from 125KB/s to over 850 using a wireless connection!!!

Share this post


Link to post
Share on other sites
Gurra    0

I have 10% of my gigabit connection with vista and 50% with xp on same machine... So vista has some serious bugs with transfer speed.

Share this post


Link to post
Share on other sites
Infinione    3
You can also check the sytem board manufacturer's website for a newer bios update if available. Also, I remember reading a while ago that certian VIA southbridge chipsets caused issues with slow/corrupt data transfer -- try the VIA 4-in-1 update pack. For intel, I downloaded the latest INF utility and noticed updated drivers upon reboot. Let me know if you see better results.

::winXpert::

I never know what to do about Intel chipset drivers for Vista. At the moment I have left my system running 'as is' after installing Vista Home Premium 32bit.

The Intel INF chipset drivers on the intel page are dated 21 Nov 2006. Thats 2 months prior to Vista being released, so I'd hate to be installing an older version!

Can I have your thoughts about this issue please guys? What have most people here done - updated the Intel Chipset drivers or not?

I also have the slow transfer speed problem - and removing remote differential compression didnt seem to do too much for me :(

Share this post


Link to post
Share on other sites
rajputwarrior    280

is newb4ever tip an ultimate feature only?

Share this post


Link to post
Share on other sites
bobbba    9

"When you copy large files to or from earlier operating systems, the copy operation may be slower than expected on some Windows Vista-based computers"

http://support.microsoft.com/kb/932170

Edited by bobbba

Share this post


Link to post
Share on other sites
majortom1981    241

Are you guys sure this is not caused by a driver problem. In vista on my machine network transfers are actually running a tad faster on my machine then from xp.

Share this post


Link to post
Share on other sites
Gurra    0

I notice a strange thing: copy with vista gives approx 10-15% of network speed. BUT if i use Nero to cache a file from network i have full speed: 45-50% (on gigabyte network). So its not network stack thats fault, its something wrong with vistas file management

Share this post


Link to post
Share on other sites
Windam    0

I have about 1.5GB and its a bit slower than XP.

Share this post


Link to post
Share on other sites
betasp    56
Superfetch is a new thing thats dont really give any benefit. But anyway, disable superfetch and readyboost dont help to increase the copy/network speed

Wha...? You mean pre-caching applications into RAM to dramatically reduce start times give no benefit?

Share this post


Link to post
Share on other sites
Nitrius    0

Disabled the Remote Differential Compression thing, and copying files between my two harddisks and deleting files got much faster.

Only thing, what is "Remote Differential Compression"? i read some from the article but i'am still a bit clueless og what it dose.

Share this post


Link to post
Share on other sites
entropyx    0

So why disable something if you don't know what it does ... ?

Share this post


Link to post
Share on other sites
dfp    0

I've tried everything mentioned to no avail. If I copy a file from a Windows 2003 server on Vista PC I get about 12% Utilization's on a 1gbps link. If I copy the exact same file logged in from the Windows 2003 server over to the vista PC, the utilization is about 50%. That is copying the file in the same direction but just from the different machine, how can that be so! There must be serious bugs in Vista!

Edited by dfp

Share this post


Link to post
Share on other sites
Evolution    16

Remote Differential Compression is used if you're updating files over a network, it checks the difference between the two files and sends the difference to save on bandwidth. However, I'm not sure how it checks the difference without using the same amount of bandwidth + extra to send it...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.