Working Voodoo 3 2000/3000/3500 XP drivers!

I found this site that claims to have full working drivers for XP. This means, OpenGL, and Glide will work under XP!!! I tried them, and they seemed to work great. Maybe I wont throw out the ol' Voodoo 3. Try them for yourself and post your results!

Download: Voodoo 3 Drivers for XP

News source: Driver Site

Report a problem with article
Next Article

Command & Conquer Yuri's Revenge delayed

Previous Article

CounterStrike 1.3 Wednesday

-1 Comments - Add comment

Advertisement