Windows 10 Taskbar Icons look awful


 Share

Recommended Posts

I just did the upgrade from Win7 Pro today, which didn't go all that smoothly. Despite having updated drivers for my sound and graphics neither worked after the update and had to be fixed manually. But they seem to be working now. However the taskbar icons for the built in apps seem to be broken. Half of the, are just white squares, or just really ugly icons. I'm not a fan of the black/white icons in the system tray but they looks positively gorgeous in comparison.

How do I fix this?

Screen shot shows the icons for Edge, Mail, Groove, Get Started, Film & TV, Contacts, Calendar, Alarms, 3D Builder, Calculator, Solitaire, XBox, Store, and Maps.

Taskbar Icons.png

Link to comment
Share on other sites

Not seen this happen on any of my machines (or any friends either).

You note that you had to fix your graphics driver manually, and that looks very much the graphics issue. Can you tell us what graphics card you have and what you had to do to get it working?

Link to comment
Share on other sites

That looks like your graphics driver is still broken. I take it you've done a full restart since playing with the graphics driver?

Try reverting back to the basic one and see if it fixes the icons.

Link to comment
Share on other sites

My card is an nVidia 750ti, and I'm using the latest drivers released yesterday. I had to manually install them as Windows didn't seem to want to detect the card properly. I have a multi monitor display and it only detected the built in graphics card. If I move the taskbar to the monitor controlled by the built in graphics the icons look the same so that suggests to me that it isn't an issue with the nVidia driver.

I would just bite the bullet and do a reset to be honest.

Not going to happen. I have a lot of apps installed and configured, it would be a major PITA to redo everything. If I did a reset I'd just go back to Win7 as I'm not overly impressed so far with Win10 (so much half-assed stuff and inconsistencies).

Link to comment
Share on other sites

My card is an nVidia 750ti, and I'm using the latest drivers released yesterday. I had to manually install them as Windows didn't seem to want to detect the card properly. I have a multi monitor display and it only detected the built in graphics card. If I move the taskbar to the monitor controlled by the built in graphics the icons look the same so that suggests to me that it isn't an issue with the nVidia driver.

What do you mean by 'manually install them'? Did you run the nvidia installer? Would hardly describe that as a manual install. If you did it some other way - run the nVidia installer.

Link to comment
Share on other sites

Sorry, yes I had to run the nVidia installer. I called it a manual install because Windows didn't auto detect and install the drivers for me.

Link to comment
Share on other sites

If I move the taskbar to the monitor controlled by the built in graphics the icons look the same so that suggests to me that it isn't an issue with the nVidia driver.

Bad NVidia drivers have caused some very strange symptoms in the past.

Create a new local user account. Check icon appearance there to see whether it's global.

Link to comment
Share on other sites

I just did the upgrade from Win7 Pro today, which didn't go all that smoothly. Despite having updated drivers for my sound and graphics neither worked after the update and had to be fixed manually. But they seem to be working now. However the taskbar icons for the built in apps seem to be broken. Half of the, are just white squares, or just really ugly icons. I'm not a fan of the black/white icons in the system tray but they looks positively gorgeous in comparison.

How do I fix this?

Screen shot shows the icons for Edge, Mail, Groove, Get Started, Film & TV, Contacts, Calendar, Alarms, 3D Builder, Calculator, Solitaire, XBox, Store, and Maps.

Taskbar Icons.png

Try to uninstall your graphic driver and check the windows update to see if nVidia has put up the newest update. if the problem persist, it is more likely because some Windows 7 leftover are carried. I suggest if all problem still exist then the last thing you do would be reinstall a fresh copy of Windows 10 (trust me, i know the trouble from reinstalling all the apps but freshness and more stable state worth the installation.)

Link to comment
Share on other sites

How do the icons look if you select them from the Start menu, do they show up okay there?

Link to comment
Share on other sites

If you're using something like Icaros (that comes with a codec pack) or Media Preview to display thumbnails for media files (e.g. video files), disable it and reboot.

Link to comment
Share on other sites

i have a similar issue, the default win10 icons are completely blank transparent squares, edge and store don't show icons but can still be pressed. i updated from 8.1 and went through the tech previews over the last months, been the same on every update. as i use neither of these apps i just unpinned them. other icons show up fine though.

your issue looks like a corrupt driver install. completely remove it and go with the windows force-fed update auto version. how dare you try and install a driver yourself!?! MICROSOFT WILL TAKE CONTROL OF THAT :D

Link to comment
Share on other sites

How do the icons look if you select them from the Start menu, do they show up okay there?

The icons look fine on the Start menu.

 

Going to try removing the nVidia driver and seeing if it can auto-install them instead.

Link to comment
Share on other sites

The icons look fine on the Start menu.

 

Going to try removing the nVidia driver and seeing if it can auto-install them instead.

If they look fine on the Start Menu, what happens if you pin that to the taskbar does it then go wrong?  If it doesn't, remove those pined to the taskbar and re-pin them from the Start Menu.

Link to comment
Share on other sites

With latest nvidia driver did you mean 353.62? Since that driver is the latest available on the nvidia website and didn't show up the first time I checked the website.

Link to comment
Share on other sites

 

If they look fine on the Start Menu, what happens if you pin that to the taskbar does it then go wrong?  If it doesn't, remove those pined to the taskbar and re-pin them from the Start Menu.

If I pin them to the taskbar they go wrong.

With latest nvidia driver did you mean 353.62? Since that driver is the latest available on the nvidia website and didn't show up the first time I checked the website.

Yes, that is the version I have installed.

I have tried that, no joy.

What happens if you disable taskbar transparency? Just a thought, this could highlight a definite driver issue.

No change. 

Link to comment
Share on other sites

The icons are also messed up in the Group Policy Editor. They don't seem to honor the transparent background of the ICO resources and instead shows an unsightly black background:

 

iVM3qIi.png

 

Though Taskbar icons are working OK for me. I like how compact they are per row:  http://i.imgur.com/siDem1Y.png

[Not using IMG code for that one because its super wide] 

Link to comment
Share on other sites

This topic is now closed to further replies.
 Share