Windows 10 Laptop won't listen on port 445 no matter what solutions i've tried

Recommended Posts

Blinkblack88    0

Hi,

 

I have a Windows 10 laptop and I shared several folders from this laptop. A couple weeks ago, the folder sharing works fine and all other pc & laptops could do smb connection to this laptop just fine. Now suddenly, all other pcs can't do smb connect to this laptop. If I input \\LAPTOP from other pc, i'll do process waiting for a while and return this error: Windows cannot access \\LAPTOP. Check the spelling of the name. Otherwise, there might be a problemwith your network. To try to identify and resolve this network problems, click Diagnose.

 

I did netstat -a -n and i found my laptop is not listening on port 445

 

To make thing more simple, here is what I've done:

1. Turning off the Laptop's Windows firewall, on both public & private sections

2. Uninstall all antivirus & force disable windows defender from registry

3. Check and find that Server, Workstation & Computer Browser Service and all set to Automatic & all Running

4. Enable File & Printer sharing at the advanced network settings

5. Smb v1 registry entry is enabled

6. Ping to this Laptop is fine & Remote desktop connection to this laptop works, the only problem is the laptop won't accept smb connection

7. This laptop can do smb connection to other or laptop with no problem

8. I've checked the registry entries in NetBT & Lanmanserver and compare it to other working PC entry and found nothing that is different

9. I have made sure that File Sharing is checked at the network adapter setting

10. Tried system restore also to previous restore point with no avail

11. I have uninstall all vpn applications as well, that is hamachi & hide.me vpn

 

All this things I've done and the laptop still doesn't listen on port 445 and therefore can't accept smb connection. 

 

I'm hoping that someone can help me in anyway to make the laptop listen to port 445 again. I must have missed something. Thanks a lot in advance

 

John

Share this post


Link to post
Share on other sites
+warwagon    9,933

Have you tried power cycling your router? Maybe your router is doing funky things at the moment, that will be solved by power cycling it.

Share this post


Link to post
Share on other sites
Blinkblack88    0
4 minutes ago, warwagon said:

Have you tried power cycling your router? Maybe it's got a routing issue, that will be solved by power cycling it.

Okay I've just turned off and on again the router and no luck. Ping to the laptop from other computers is fine & i can do remote desktop connection to the laptop as well. The problem is the laptop is not listening to port 445 which i can't seem to find why.

 

Really appreciate you kind & prompt response though.

Share this post


Link to post
Share on other sites
+warwagon    9,933
6 minutes ago, Blinkblack88 said:

Okay I've just turned off and on again the router and no luck. Ping to the laptop from other computers is fine & i can do remote desktop connection to the laptop as well. The problem is the laptop is not listening to port 445 which i can't seem to find why.

 

Really appreciate you kind & prompt response though.

Just for ######'s and giggles, try setting your IP to static and change it to a new IP (different than the one it has now) .. and see if it works.

 

I've had an issue on 2 machines were all of the sudden the IP that it did have, stopped working for stuff that has always worked like remote desktop. Once I changed the IP everything started working again.

Share this post


Link to post
Share on other sites
Blinkblack88    0
5 minutes ago, warwagon said:

Just for ######'s and giggles, try setting your IP to static and change it to a new IP (different than the one it has now) .. and if it works.

Just changed to ip static 192.168.0.185 & tried \\Laptop & \\192.168.0.185 still got same result bro 

:cry:

12 minutes ago, warwagon said:

Have you tried power cycling your router? Maybe it's got a routing issue, that will be solved by power cycling it.

Okay I've just turned off and on again the router and no luck. Ping to the laptop from other computers is fine & i can do remote desktop connection to the laptop as well. The problem is the laptop is not listening to port 445 which i can't seem to find why.

 

Really appreciate you kind & prompt response though.

Share this post


Link to post
Share on other sites
xendrome    4,434

Is this laptop connected via a hardwire or wireless?

Share this post


Link to post
Share on other sites
+warwagon    9,933

Do you also have any network switches?

Share this post


Link to post
Share on other sites
theefool    5

Just a note, did this laptop get the recent Fall Creators update?

  • Like 1

Share this post


Link to post
Share on other sites
Blinkblack88    0
43 minutes ago, xendrome said:

Is this laptop connected via a hardwire or wireless?

Wireless but I've tried using cable same result

40 minutes ago, warwagon said:

Do you also have any network switches?

No I'm using just an asus router

21 minutes ago, theefool said:

Just a note, did this laptop get the recent Fall Creators update?

Yeah i believe so. My laptop usually got updated automatically. But is there anyway to make sure whether i got the update or not? The update could have caused my problem? When i tried to check for update just now it said Your device is up to date.

 

Thxx

Share this post


Link to post
Share on other sites
TAZMINATOR    12,107

Make sure the port 445 is not blocking in the firewall.

 

If you are not sure, go to firewall settings and see if the port 445 is on block list.  If so, unblock it then restart PC.

 

If it's clean and it's not working, turn off the firewall and see what happens.  if you are able to connect it, then it's the firewall issue. 

 

If you don't see the block list in there, then it might be registry or your system might be infected.

 

See if you try the switches as @warwagon was asking you.  if you don't have it then it could be firewall or infected.

 

 

  • Like 1

Share this post


Link to post
Share on other sites
Blinkblack88    0
35 minutes ago, TAZMINATOR said:

Make sure the port 445 is not blocking in the firewall.

 

If you are not sure, go to firewall settings and see if the port 445 is on block list.  If so, unblock it then restart PC.

 

If it's clean and it's not working, turn off the firewall and see what happens.  if you are able to connect it, then it's the firewall issue. 

 

If you don't see the block list in there, then it might be registry or your system might be infected.

 

See if you try the switches as @warwagon was asking you.  if you don't have it then it could be firewall or infected.

 

 

It's not blocked by Windows firewall, I have already turned off the firewall & uninstalled all antivirus apps & disabled windows defender just to make sure. I have also run antivirus & anti malware scan before uninstalling them and found no infection.

 

Is there any windows registry entries i should check to make sure port 445 is not disabled?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.