Safari 3.0.1 Beta for Windows


Recommended Posts

+Frank B.

Apple released a first bugfix for the beta of Safari 3 for Windows today. It is available over Apple Software Update as well as on the Safari website.

Link to post
Share on other sites
zeroday

I installed it, but still have the same problem as last time, anyone know how to fix this:

Screenshot

Link to post
Share on other sites
thertrain

Mine looks fine, but my main complaint is the scroll wheel on my mouse doesn't work with Safari. It scrolls up and down in all applications except Safari.

Link to post
Share on other sites
+Frank B.

The scrollwheel works here. What doesn't work are back and forward buttons on my mouse though.

Link to post
Share on other sites
Herculean

It said in the brief description you get in Apple Software Update, that actually it just fixes the security issues. Which is annoying; it looks terrible with classic on :(

Link to post
Share on other sites
kainashi
The scrollwheel works here. What doesn't work are back and forward buttons on my mouse though.
well. in my case, the side buttons of my mx1000 don't work but that's about it. seems to be a bit better with maximizing but that could just be me. ;)
Link to post
Share on other sites
red.

Still crashes on me on startup and i don't know why.

Link to post
Share on other sites
Julius Caro
I installed it, but still have the same problem as last time, anyone know how to fix this:

Screenshot

That's funny, that's the only web page in which I can read everything lol.

I could be mistaken but this only seems to render things better, but some text is still not showing up. Neowin for example looks just fine, but without text in a lot of places.

It still crashes when I attempt to write something into a form field.

The scroll wheel does work, what doesn't is the middle click that lets you scroll by moving your mouse.

I guess they patched security things and that's all

Link to post
Share on other sites
Damo R.

Is the memory issue fixed?

Link to post
Share on other sites
S550

all i ask is they let the browser use cleartype!

Link to post
Share on other sites
NY1
Is the memory issue fixed?

Nope, using 107mb of memory here.

But otherwise works perfectly, I just wish I could use my back and forth buttons on my mouse.

Link to post
Share on other sites
Herculean

Well I get about 43,000 with just neowin and google open in two tabs. So I bit of an improvement from 150k people were getting ;)

It's obvious Apple rushed this thing out for WWDC, just like iTunes 7 *shudders*

Link to post
Share on other sites
NY1
all i ask is they let the browser use cleartype!

I've read this fixes the blurry font issue :

"To fix the font issue, remove the crappy versions of Lucida Grande from your font folder. Then go into program files, find the safari folder, look for the 2 lucida grande fonts apple packaged safari with, install those, (restart to be safe) and the app should work fine now"

Also make sure you set the font smoothing to light in preferences.

Link to post
Share on other sites
+Frank B.
all i ask is they let the browser use cleartype!

Safari's font renderer is imho better than ClearType. It does take a while to get used to it, sure. After a while it grows on you though.

Link to post
Share on other sites
yardmanflex
Safari's font renderer is imho better than ClearType. It does take a while to get used to it, sure. After a while it grows on you though.

yeah right you need glasses buddy...

Link to post
Share on other sites
Damo R.
Safari's font renderer is imho better than ClearType. It does take a while to get used to it, sure. After a while it grows on you though.

I like Safaris font's....its just the scrolling and the memory that stops me from using it full time...

Link to post
Share on other sites
soumyasch

I hate the font. It looks like someone has used a smudge filter over the page.

Link to post
Share on other sites
The_Decryptor
all i ask is they let the browser use cleartype!

It uses ClearType, it just uses it's own settings.

Link to post
Share on other sites
cork1958

I finally got this thing to install today. Tried yesterday on a (POS)Vista Ultimate machine. On a XP Pro box today.

This doesn't look or act to bad. Add a little variety I guess, to the browsers I use. Does seem to use a little memory, doesn't it?

Link to post
Share on other sites
soumyasch

I dont think it uses ClearType , it uses its own subpel renderer. Much like Adobe uses CoolType or whatever they call it.

Link to post
Share on other sites
Mordkanin
I installed it, but still have the same problem as last time, anyone know how to fix this:

Screenshot

No, sorry. I don't think anyone's figured out how the make the UI not look like crap....

Link to post
Share on other sites
acido00

but, the bug is terrible :( please mac fix

Link to post
Share on other sites
Punio4

[EDITED-cut]

Forget this post, I was wrongly informed :)

Edited by Punio4
Link to post
Share on other sites
DanManIt

Sounds like there is a lot of bugs in it. I think I'll give it a quick try though.

Link to post
Share on other sites
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.