It's not you, it's Mozilla: Firefox is having trust issues with add-ons [Update]

About a month ago, it came to light that Mozilla would be rolling out its own Recommended Extensions program to users find add-ons that deliver what they promise while meeting high standards when it comes to security. While the program itself is yet to roll out, in the meantime an oversight by Mozilla seems to have caused quite a negative impact in the add-ons space.

According to an announcement on Mozilla Discourse, a certificate used to sign Firefox add-ons expired some hours ago and is causing new add-ons to fail to install and existing add-ons to stop working. As a result, users have reported on Reddit that they have been left without functioning add-ons such as content blockers, password managers, and download managers.

While the team is working on a permanent fix, a couple of interim solutions have been posted over on r/Firefox. The first of these involves using the Firefox debugging tools to temporarily install add-ons that will remain active until the next browser restart. The second workaround is to use Firefox Developer Edition or Firefox Nightly, some migration steps, and disabling signing.

Otherwise, if any of the above sounds too involved then you might be best to wait things out or you might like to take Microsoft's Chromium-based Edge browser that's still in public preview for a spin.

Thanks to Sonyboyj for the tip!

Update: Mozilla is now rolling out a fix for the issue affecting add-ons to release, beta, and nightly users on desktop and should automatically be applied to Firefox in the next few hours. However, it relies upon remaining opted into "Studies" found in the Firefox preferences under Privacy & Security > FireFox Data Collection and Use and making sure that Allow Firefox to install and run studies is enabled in addition to Allow Firefox to send technical and interaction data to Mozilla. These options can be disabled after the fix has been applied.

In the meantime, Mozilla is still working on a general fix that does not rely on the above configuration.

Report a problem with article
1556950318_google_shopping
Next Article

Google is showing shopping ads under YouTube videos as part of a test

1543476286_cybersecurity
Previous Article

Git repositories are being compromised by a hacker demanding a ransom in bitcoin

51 Comments - Add comment

Advertisement