MS02-015 - Cumulative Patch for Internet Explorer

Thanks to AaronXP for posting this info in the forums.

Recommendation: Consumers using IE 5.01, 5.5 and 6 should install the patch immediately.

Maximum Severity Rating: Critical

Technical description:

This is a cumulative patch that includes the functionality of all previously released patches for IE 5.01, 5.5 and IE 6. In addition, it eliminates the following two newly discovered vulnerabilities:

  • A vulnerability in the zone determination function that could allow a script embedded in a cookie to be run in the Local Computer zone. While HTML scripts can be stored in cookies, they should be handled in the same zone as the hosting site associated with them, in most cases the Internet zone. An attacker could place script in a cookie that would be saved to the user's hard disk. When the cookie was opened by the site the script would then run in the Local Computer zone, allowing it to run with fewer restrictions than it would otherwise have.

  • A vulnerability in the handling of object tags that could allow an attacker to invoke an executable already present on the user's machine. A malicious user could create HTML web page that includes this object tag and cause a local program to run on the victim's machine.
Originally posted: March 28, 2002

News source: Microsoft TechNet

View: Microsoft Security Bulletin MS02-015

Download: MS02-015 Security Patch Download Page

Report a problem with article
Next Article

Novell Offered Microsoft Help in Antitrust Case

Previous Article

Xbox: 'Microsoft has its teeth kicked in'

-1 Comments - Add comment

Advertisement