[VS] Clearscreen Sharp for Windows 7


 Share

Recommended Posts

-KJ

Note: This VS is in beta... there are bugs in it that I will try to get rid of.

The default Windows 7 Aero VS looks great. I didn't really feel like porting, but I had some requests asking me to port my theme over to Windows 7 and so I did. :)

I am posting this here because we don't have a dedicated Windows 7 'Completed Theme' section, yet.

Hopefully we can get one up soon now that Windows 7 has been released.

Check out http://k-johnson.deviantart.com/art/Clears...dows7-141360821 for updates, bug reports, etc.

Clearscreen_Sharp_for_Windows7_by_K_Johnson.jpg

Edited by -KJ
Link to post
Share on other sites

Ji@nBing

Oh, hell yes!! Been eagerly awaiting this. Beautiful work. One small request though. Can we get the triangle start button for the full sized task bar as well?

Link to post
Share on other sites

Rob2687

Nice to see some themes coming out already for Windows 7. When Vista came out and there weren't any decent themes at all and none for a long time after that either.

Link to post
Share on other sites

suicide_pact

Nice, thank you!

Link to post
Share on other sites

-KJ
Oh, hell yes!! Been eagerly awaiting this. Beautiful work. One small request though. Can we get the triangle start button for the full sized task bar as well?

I will keep that in mind; I want to fix whatever bugs there are first.

The reason I went with the orb (you probably know why as you've tweaked with the Start button before) is because the triangle start button is shared between all four superbar locations. So a large triangle button would look very out of place when you shift the superbar to the right.

Link to post
Share on other sites

Denis W.

Looks like a nice clean theme. (Y)

This screenshot shows two flaws in it so far in Windows 7 32-bit:

Link

The tray icons have a white background on them, but they have a slightly maligned background if you mouse over them. In the Start menu, the top edge's gloss doesn't match up.

Link to post
Share on other sites

Ji@nBing
I will keep that in mind; I want to fix whatever bugs there are first.

The reason I went with the orb (you probably know why as you've tweaked with the Start button before) is because the triangle start button is shared between all four superbar locations. So a large triangle button would look very out of place when you shift the superbar to the right.

Understandable. I do hope you do eventually release it though as it looks awesome :p.

Kudos on making everything work with all taskbar orientations too. A lot of themes seem to just do the bottom and call it a day?:blink:: .

Link to post
Share on other sites

chrisj1968

@KJ- Nice work. it would appear that you surely put sometime into that theme.

#1. how long on average do you find yourself using to complete a theme?

#2. How do I use your theme for my Laptop?

thanks

-Chrisj1968

Link to post
Share on other sites

ViperAFK

This is bar none the best visual style for vista/win7 I have ever seen. I used to be huge into themes in xp but since voista they've all been crap.

GREAT work man.

Link to post
Share on other sites

null_

Wow, this is absolutely beautiful! :)

Link to post
Share on other sites

ViperAFK

How the hell do you replace explorer.exe in win7. It wont even let me take ownership of it :/

Link to post
Share on other sites

Ji@nBing
How the hell do you replace explorer.exe in win7. It wont even let me take ownership of it :/

I had to make an admin account and do it in the admin account.

Link to post
Share on other sites

XmoshiX

Yeah, the white background on the systray is annoying.. o_o

Link to post
Share on other sites

Minifig

Are the active windows close buttons clear as well?!

Link to post
Share on other sites

ViperAFK
I had to make an admin account and do it in the admin account.

Found a way, you can go to the group policy editor and go to User Configuration > system > custom user interface and select enabled and type in the path of your new explorer.exe and it will use it as default :)

Link to post
Share on other sites

Ionium
Yeah, the white background on the systray is annoying.. o_o

Yeah that's why I won't use the theme yet

Link to post
Share on other sites

ViperAFK

Only problem I have noticed it there is a start menu graphic slightly out of alignment:

post-159052-1256444837_thumb.png

Also its really hard to differentiate between active and inactive windows with this theme.

Link to post
Share on other sites

-KJ

Sorry guys, that is a bug on x86 that I am trying to solve. Reverse happened on Vista when I made the theme on x86 it bugged out on x64.

@ minifig: They aren't, but they are when you have the window over another one (becomes hard to see). I am planning on making a frame just like Aero. With Windows Vista/Aero, you are very limited as to what you can do there. They automatically resize and have bounds there. I didn't want to do another Aero caption there because I didn't want people going "OH LAWD, ANOTHER AERO MOD". :)

@ ViperAFK: Thanks for the bug report, I missed that one. I use the Start Menu without the large icons there, and enabling them I see what you mean. I will try to sort this out ASAP. The default Aero caption should make things easier as to what is active and not.

Thanks for all the comments.

Link to post
Share on other sites

ViperAFK

Another bug with your explorer replacement this time. All the default windows system tray icons (colume, network) do not work and it does not allow me to enable them they are greyed out completely:

post-159052-1256445355_thumb.png

Link to post
Share on other sites

Panda X
Another bug with your explorer replacement this time. All the default windows system tray icons (colume, network) do not work and it does not allow me to enable them they are greyed out completely:

post-159052-1256445355_thumb.png

That has nothing to do with the theme. Sometimes it just bugs out like that.

Link to post
Share on other sites

ViperAFK

Well I even restarted and its still doing it.

Link to post
Share on other sites

Ionium
Well I even restarted and its still doing it.

Yeah it shouldnt do that...

Link to post
Share on other sites

-KJ
Another bug with your explorer replacement this time. All the default windows system tray icons (colume, network) do not work and it does not allow me to enable them they are greyed out completely:

Thanks for the heads up. I apologize for not telling this, I was going to mention it under the V1 section at the DA page that this Explorer.exe is outdated (it's RTM, but there is a newer one out). I will make note of it now as that is a serious problem. I will try and get that rectified now. I'm assuming that's the problem? :s

Link to post
Share on other sites

ViperAFK

Yeah its the explorer.exe, I switched back to default and all icons re-appeared.

Link to post
Share on other sites

This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.