Uxtheme installation under Windows XP/2003


Recommended Posts

Vice
i mean page #1 of this guide fyi. read it. looks like you did NOT.

585127628[/snapback]

I did, Look I didnt know which theme file to get in the first place, so before troubling u I tried the one under SP2.. now I did then use the CORRECT file and do what was said on the 1st page, .. with the file switcher thing and everything but it didnt work.

Link to post
Share on other sites
insanekiwi

try restoring your orginal file(s) and try again.

everybody managed to get it working, either using the nw replacer or the manual method. so i'm sure it's not on my end nor the applications' fault.

tell us what you did, step by step.

Link to post
Share on other sites
Vice
try restoring your orginal file(s) and try again.

everybody managed to get it working, either using the nw replacer or the manual method. so i'm sure it's not on my end nor the applications' fault.

tell us what you did, step by step.

585127647[/snapback]

ok, I tried the neowin autopatcher. it patched it. I restarted - it didnt work

I went to the site and got one of the SP2 files that had same numbers as my version... I renamed the old uxtheme.dll in my system32 folder to uxtheme.old replaced that with the new one rebooted - it didnt work.

Then I came here and asked, larney gave me a link to a uxtheme.dll file that was for my specific build. I then used the replacer program (not the rename to .old way of doing it) to replace the file. then I rebooted.

Link to post
Share on other sites
Larney

WinMacLin, try searching your whole computer for ALL uxtheme files and deleting them all apart from the ONE C:\Windows\System32 called uxtheme.dll

Then post a picture of Start -> Run -> Winver (we need to know the language of your computer as well like English or Russian or whatever) so me and insasnekiwi can direct you to the right file. Then me or insanekiwi can explain to you how to replace the file :)

Lets do it slowly step by step

Link to post
Share on other sites
digitalgimpus

I reinstalled my OS yesterday, and used the MS CD to update to SP2 (quicker than download).

For some reason, I can't get this working. Is something different from the CD SP? I've never had a problem before performing this patch *ever*.

I've searched all my HD's for "uxtheme", and the only file is in system32.

Something is very strange. I've tried every patched uxtheme.dll file available on the net... none have worked. No errors, but not success.

I've done this dozens of times. The only thing different was usng the CD to update to SP2 from Windows XP (no SP).

Link to post
Share on other sites
Vice

ok I did the search and removed the one that was not in the system32 folder redid everything and nothing not a sausage..

Here is the screenshot just a thing of note, this is an OEM copy.

post-70022-1103478121.jpg

Link to post
Share on other sites
Vice

Just like to thank larney :) he PM helped me out and its all up and running now thanks :D

Link to post
Share on other sites
Larney
Just like to thank larney :) he PM helped me out and its all up and running now thanks :D

585128727[/snapback]

Anytime (Y)

Link to post
Share on other sites
insanekiwi
Just like to thank larney :) he PM helped me out and its all up and running now thanks :D

585128727[/snapback]

oh my. how brave. do you mind telling us that exactly the problem WAS?

Link to post
Share on other sites
Larney
oh my. how brave. do you mind telling us that exactly the problem WAS?

585129043[/snapback]

No need to be like that insanekiwi. The problem was the i386 service pack files were over-writing the uxtheme.dll due to Windows File Protection.

Link to post
Share on other sites
ge_generation

Thanks insanekiwi for the guide! I am really enjoying my new desktop FINALLY without StyleXP. :D

Link to post
Share on other sites
Larney

Yep, StyleXP sucks (N)

Link to post
Share on other sites
Vice
oh my. how brave. do you mind telling us that exactly the problem WAS?

585129043[/snapback]

Brave? :laugh:

Link to post
Share on other sites
insanekiwi

wfp? hah. this doesn't happens when using replacer/neowin's uxtheme app properly. an wfp dialog should pop up and you press keep the modded file. easy as that.

Link to post
Share on other sites
Larney
wfp? hah. this doesn't happens when using replacer/neowin's uxtheme app properly. an wfp dialog should pop up and you press keep the modded file. easy as that.

585132144[/snapback]

No, the service pack files overwrite the patched file when you reboot which it says nothing about in your guide (which many people have problems with). Now stop being so rude as alot of people like to know what files they are replacing.

Link to post
Share on other sites
insanekiwi

well fine. write it down in your guide. nobody told me they had problems with wfp because there is no problem with it. the default xp will give you a wfp dialog and then you simply keep the replaced file. and it won't get replaced upon a reboot.

Link to post
Share on other sites
dansx6

Maybe you guys can help me out also. I have tried to use the Neowin Multipatcher but I keep getting an error message that says there are NT setup files in C:\Windows and it is not recommended that I continue. When I click OK the application closes. I have tried using replacer but after I follow the instructions and click Y/enter it starts up then stops with an error that the UXTHEME.dll could not be found. When I look in system32 I find the UXTHEME.dll v. 6.0.2900.2180 which is the version that I downloaded to patch the original file with. Even though it is in system32 I am unable to change my VS except to the MS XP styles.

I have disabled wfp.

Any help would be appreciated.

WINVER 5.1 (build 2600.xpsp_sp2rtm.040803-2158 : Service Pack 2)

Link to post
Share on other sites
insanekiwi

hrm, it sounds like the patch worked flawlessly. did you try doubleclicking the msstyle?

Link to post
Share on other sites
dansx6

Yes. I checked the msstyle and I even downloaded it again. It is in the correct place etc. I tried several different msstyles and none of them worked.

Link to post
Share on other sites
insanekiwi

did you put them in C:\WINDOWS\Resources\Themes so they show up in the desktop properties?

but theyshould pop up if you doubleclick them.

Link to post
Share on other sites
dansx6

they are in C:\windows\resources\themes. I have tried to access them with the properties dialog and by double-clicking them directly.

Link to post
Share on other sites
Larney

dansx6, search for all files called:

uxtheme

on ALL your hard-drives. Delete them all apart from the one named uxtheme.dll in C:\Windows\System32 Download this: http://67.21.149.202:8080/repository/Patch...900.2180_EN.rar Rename uxtheme.dll to uxtheme.dll.old and move the patched uxtheme.dll into C:\Windows\System32 then Reboot and try a theme. If it still doesn't work respond here

insanekiwi, its the problem with when the service pack files replace the files upon restart and some people have had problems with it, sorry if my post sounded nasty I was just explaning what the problem was :)

Link to post
Share on other sites
insanekiwi

your windows version says xpsp_sp2rtm..hrm

newest patcher:

so you used this one: http://www.neowin.net/forum/index.php?showtopic=140707 ?

manual way:

did you get the uxtheme.dll in your OS language (http://www.is-pimp.com/insanekiwi/neowin/uxtheme/windows%20xp/sp2/) ?

@Larney: alrighty right, i'm about to hit the road (6:30pm here) so you can do the uxtheme nightshift for me now :rofl:

Link to post
Share on other sites
Rafael

The DLL is not the problem if he cannot even see the themes in the drop-down list. This seems to be a common problem without a definite explaination... UxStyle will hopefully resolve this when it becomes public.

NOTE: Had to re-reg; Posting privs. on account Rafael were removed.

Old screenie:

UxStyle_Preview.png

Link to post
Share on other sites
Larney
@Larney: alrighty right, i'm about to hit the road (6:30pm here) so you can do the uxtheme nightshift for me now :rofl:

585134980[/snapback]

Sure thing (Y)

Uxtheme Rafael, just making sure he does everything right and I wonder you took away your priveliges. dansx6, what themes do you see on the appearances tab when you try and use a different theme?

Rafael: nice screenshot (Y)

Edited by Larney
Link to post
Share on other sites
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.