<!DOCTYPE html>
<!--[if lt IE 9 ]><html class="lt-ie9"  xmlns:og="https://opengraphprotocol.org/schema/" lang="en" itemscope itemtype="https://schema.org/Article"><![endif]-->
<!--[if (gte IE 9)|!(IE)]><!--><html  xmlns:og="https://opengraphprotocol.org/schema/" lang="en" itemscope itemtype="https://schema.org/WebPage"><!--<![endif]-->
<html>
<head>
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />
  <meta http-equiv="content-type" content="text/html; charset=utf-8" />
  <meta name="viewport" content="width=device-width, initial-scale=1.0" />
  <link rel="stylesheet" href="/css/orion/orion.min.css?ver=62f3b07" />
  <link rel="stylesheet" href="//fonts.googleapis.com/css?family=Open+Sans:400,300,600,700" />
  
  <link rel="mask-icon" href="/images/orion/pinned-icon.svg" color="#1e5078" />
  <link rel="canonical" href="https://www.neowin.net/news/google-reveals-high-severity-flaw-in-macos-kernel/" />
  <link rel="amphtml" href="https://www.neowin.net/amp/google-reveals-high-severity-flaw-in-macos-kernel/" />
  <link rel="shortcut icon" href="/images/orion/icons/favicon.ico" />
  <link rel="icon" sizes="196x196" href="/images/orion/icons/favicon-196x196.png" />
  <link rel="apple-touch-icon" sizes="57x57" href="/images/orion/icons/apple-touch-icon-57x57.png" />
  <link rel="apple-touch-icon" sizes="60x60" href="/images/orion/icons/apple-touch-icon-60x60.png" />
  <link rel="apple-touch-icon" sizes="72x72" href="/images/orion/icons/apple-touch-icon-72x72.png" />
  <link rel="apple-touch-icon" sizes="76x76" href="/images/orion/icons/apple-touch-icon-76x76.png" />
  <link rel="apple-touch-icon" sizes="114x114" href="/images/orion/icons/apple-touch-icon-114x114.png" />
  <link rel="apple-touch-icon" sizes="120x120" href="/images/orion/icons/apple-touch-icon-120x120.png" />
  <link rel="apple-touch-icon" sizes="144x144" href="/images/orion/icons/apple-touch-icon-144x144.png" />
  <link rel="apple-touch-icon" sizes="152x152" href="/images/orion/icons/apple-touch-icon-152x152.png" />
  <meta name="apple-mobile-web-app-title" content="Neowin" />
  <meta name="application-name" content="Neowin" />
  <meta name="mobile-web-app-capable" content="yes" />
  <meta name="theme-color" content="#1e5078" />
  <meta name="msapplication-TileColor" content="#1e5078" />
  <meta name="msapplication-TileImage" content="/images/orion/icons/mstile-144x144.png" />
  <meta name="msapplication-config" content="/images/orion/icons/browserconfig.xml" />
  <meta name="msvalidate.01" content="EBBCC7B1E848A910B212B70DE151D719" />
  <link rel="alternate" type="application/rss+xml" title="Neowin News" href="//feeds.feedburner.com/neowin-main" />
  <meta property="fb:pages" content="108763692386" />
  <link href="//plus.google.com/103621864990923776909" rel="publisher" />
  <meta name="google-site-verification" content="vCarIwq59Ms5CxqTUZa5YcO5ZLieFkPyajJ9Kp8Jzdw" />
  
  <meta name="twitter:site" value="@NeowinFeed" />
  <meta property="og:site_name" content="Neowin" />
  <meta property="fb:admins" content="702410021" />
  <meta property="fb:app_id" content="141241332490" />
  <!-- TradeDoubler site verification 2507204 -->
  

  <title>Google reveals &quot;high severity&quot; flaw in macOS kernel - Neowin</title>
		<meta name="title" content="Google reveals &quot;high severity&quot; flaw in macOS kernel" />
		<meta name="description" content="Google&#039;s Project Zero has exposed a &quot;high severity&quot; flaw in macOS&#039; kernel XNU - which apparently has issues in its implementation of copy-on-write behavior - after Apple failed to fix it in 90 days." />
		<meta name="twitter:url" content="https://www.neowin.net/news/google-reveals-high-severity-flaw-in-macos-kernel" />
		<meta name="twitter:creator" content="@@UsamaJawad96" />
		<meta name="twitter:title" content="Google reveals &quot;high severity&quot; flaw in macOS kernel" />
		<meta name="twitter:description" content="Google&#039;s Project Zero has exposed a &quot;high severity&quot; flaw in macOS&#039; kernel XNU - which apparently has issues in its implementation of copy-on-write behavior - after Apple failed to fix it in 90 days." />
		<meta property="og:title" content="Google reveals &quot;high severity&quot; flaw in macOS kernel" />
		<meta property="article:publisher" content="https://www.facebook.com/neowin" />
		<meta property="article:author" content="https://www.facebook.com/usama.jawad.96" />
		<meta property="og:type" content="article" />
		<meta property="og:description" content="Google&#039;s Project Zero has exposed a &quot;high severity&quot; flaw in macOS&#039; kernel XNU - which apparently has issues in its implementation of copy-on-write behavior - after Apple failed to fix it in 90 days." />
		<meta property="og:url" content="https://www.neowin.net/news/google-reveals-high-severity-flaw-in-macos-kernel" />
		<meta itemprop="name" content="Google reveals &quot;high severity&quot; flaw in macOS kernel" />
		<meta itemprop="description" content="Google&#039;s Project Zero has exposed a &quot;high severity&quot; flaw in macOS&#039; kernel XNU - which apparently has issues in its implementation of copy-on-write behavior - after Apple failed to fix it in 90 days." />
		<meta name="keywords" content="apple,google,macos,xnu,kernel,flaw,security,copy-on-write,cow,project zero,vulnerability,disclosure,cybersecurity" /><meta property="og:image" content="https://cdn.neow.in/news/images/uploaded/2017/10/1508182447_macos_story.jpg" /><meta name="twitter:card" value="summary_large_image" /><meta name="twitter:image" content="https://cdn.neow.in/news/images/uploaded/2017/10/1508182447_macos_story.jpg" />

  <!--[if IE]>
  <meta name="msapplication-task" content="name=Forums;action-uri=https://www.neowin.net/forum/;icon-uri=/images/icons/jumplist/forums.ico" />
  <meta name="msapplication-task" content="name=Follow us on Twitter;action-uri=https://twitter.com/NeowinFeed;icon-uri/images/icons/jumplist/twitter.ico" />
  <meta name="msapplication-task" content="name=Follow us on Facebook;action-uri=https://www.facebook.com/neowin;icon-uri/images/icons/jumplist/facebook.ico" />
  <meta name="msapplication-task" content="name=Tip Us;action-uri=https://www.neowin.net/contact/;icon-uri=/images/icons/jumplist/contact.ico" />
  <meta name="msapplication-starturl" content="./" />
  <script>
    // Windows Phone Fix Viewport
    if (navigator.userAgent.match(/IEMobile\/10\.0/)) {
      var msViewportStyle = document.createElement("style");
      msViewportStyle.appendChild(document.createTextNode("@-ms-viewport{width:auto!important}"));
      document.getElementsByTagName("head")[0].
      appendChild(msViewportStyle);
    }
  </script>
  <![endif]-->
    
        <meta name="msvalidate.01" content="E2C029245C0ADED4EDE21E897D0FCCAA" />
<meta name="google-site-verification" content="vCarIwq59Ms5CxqTUZa5YcO5ZLieFkPyajJ9Kp8Jzdw" />
<!-- Quantcast Choice. Consent Manager Tag -->
<script type="text/javascript" async=true>
    var elem = document.createElement('script');
    elem.src = 'https://quantcast.mgr.consensu.org/cmp.js';
    elem.async = true;
    elem.type = "text/javascript";
    var scpt = document.getElementsByTagName('script')[0];
    scpt.parentNode.insertBefore(elem, scpt);
    (function() {
    var gdprAppliesGlobally = false;
    function addFrame() {
        if (!window.frames['__cmpLocator']) {
        if (document.body) {
            var body = document.body,
            iframe = document.createElement('iframe');
            iframe.style.display = 'none';
            iframe.name = '__cmpLocator';
            body.appendChild(iframe);
        } else {
            // In the case where this stub is located in the head,
            // this allows us to inject the iframe more quickly than
            // relying on DOMContentLoaded or other events.
            setTimeout(addFrame, 5);
        }
        }
    }
    addFrame();
    function cmpMsgHandler(event) {
        var msgIsString = typeof event.data === "string";
        var json;
        if(msgIsString) {
        json = event.data.indexOf("__cmpCall") != -1 ? JSON.parse(event.data) : {};
        } else {
        json = event.data;
        }
        if (json.__cmpCall) {
        var i = json.__cmpCall;
        window.__cmp(i.command, i.parameter, function(retValue, success) {
            var returnMsg = {"__cmpReturn": {
            "returnValue": retValue,
            "success": success,
            "callId": i.callId
            }};
            event.source.postMessage(msgIsString ?
            JSON.stringify(returnMsg) : returnMsg, '*');
        });
        }
    }
    window.__cmp = function (c) {
        var b = arguments;
        if (!b.length) {
        return __cmp.a;
        }
        else if (b[0] === 'ping') {
        b[2]({"gdprAppliesGlobally": gdprAppliesGlobally,
            "cmpLoaded": false}, true);
        } else if (c == '__cmp')
        return false;
        else {
        if (typeof __cmp.a === 'undefined') {
            __cmp.a = [];
        }
        __cmp.a.push([].slice.apply(b));
        }
    }
    window.__cmp.gdprAppliesGlobally = gdprAppliesGlobally;
    window.__cmp.msgHandler = cmpMsgHandler;
    if (window.addEventListener) {
        window.addEventListener('message', cmpMsgHandler, false);
    }
    else {
        window.attachEvent('onmessage', cmpMsgHandler);
    }
    })();
    window.__cmp('init', {
    		'Language': 'en',
		'Initial Screen Reject Button Text': 'I do not accept',
		'Initial Screen Accept Button Text': 'I accept',
		'Purpose Screen Header Title Text': 'Privacy settings',
		'Purpose Screen Body Text': 'You can set your consent preferences and determine how you want your data to be used based on the purposes below. You may set your preferences for us independently from those of third-party partners. Each purpose has a description so that you know how we and partners use your data.',
		'Vendor Screen Body Text': 'You can set consent preferences for each individual third-party company below. Expand each company list item to see what purposes they use data for to help make your choices. In some cases, companies may disclose that they use your data without asking for your consent, based on their legitimate interests. You can click on their privacy policies for more information and to opt out.',
		'Vendor Screen Accept All Button Text': 'Accept all',
		'Vendor Screen Reject All Button Text': 'Reject all',
		'Initial Screen Body Text': 'We and our partners use technology such as cookies on our site to personalise content and ads, provide social media features, and analyse our traffic. Click below to consent to the use of this technology across the web. You can change your mind and change your consent choices at anytime by returning to this site.',
		'Initial Screen Body Text Option': 1,
		'Publisher Name': 'Neowin',
		'Publisher Logo': 'https://cdn.neow.in/news/images/uploaded/2018/05/1526052934_nw-text-black-small.png',
		'Publisher Purpose IDs': [1,2,3,4,5],
		'Consent Scope': 'service',
		'UI Layout': 'banner',
    });
</script>
<!-- End Quantcast Choice. Consent Manager Tag -->


<script id="nsgpt" src="//cdn.nsstatic.net/ns/neowin.net.js" async="true"></script>

<script>
 (function (s,o,n,a,r,i,z,e) {s['StackSonarObject']=r;s[r]=s[r]||function(){
 (s[r].q=s[r].q||[]).push(arguments)},s[r].l=1*new Date();i=o.createElement(n),
 z=o.getElementsByTagName(n)[0];i.async=1;i.src=a;z.parentNode.insertBefore(i,z)
 })(window,document,'script','https://www.stack-sonar.com/ping.js','stackSonar');
 stackSonar('stack-connect', '96');
</script>

    


<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-7094499-1', 'auto');
  ga('send', 'pageview');
</script>
</head>
<body id="top" class=" view-tile ">
<img src="https://cdn.neow.in/news/images/uploaded/2018/10/1540569436_giveaway2_mediump.jpg" style="display: none;"/>
<div class="wrapper">

  

  <header class="site-header" role="banner">
    <div class="wrap">

      <div class="site-logo">
        <a href="https://www.neowin.net">Neowin</a>
      </div>

      <span class="toggle-site-nav" id="toggle-nav">
        <span></span>
      </span>

      
      <span class="mobile-user-login-btn button button-primary">
        Login
      </span>
      

      <nav class="site-nav" id="nav" role="navigation">

        
        <div class="nav-user guest">
          <a class="nav-user-login-button" href="/forum/login/">Login</a>
          <a class="nav-user-register-button" href="/forum/register">Sign up</a>
        </div>
        

        <div class="nav-search">
          <form class="search-wrapper" id="search" method="get" action="/search">
            <input class="search-input" tabindex="1" type="search" name="terms" placeholder="Search News..." />
          </form>
        </div>

        <ul class="nav-menu menu">
          <li class="nav-item-news  active mega-parent" aria-haspopup="true" data-menu="news">
            <a href="/">News</a>
            
			
            
            <div class="mega-menu"></div>
            
          </li>
          <li class="nav-item-features  mega-parent" aria-haspopup="true" data-menu="features">
			<a href="#" class="toggle" data-toggle="features-nav">Features</a>
            <ul role="menu" class="menu" id="features-nav">
			  <li><a href="/news/tags/review">Reviews</a></li>
			  <li><a href="/news/tags/editorial">Editorials</a></li>
			  <li><a href="/news/tags/unboxing">Unboxings</a></li>
			  <li><a href="/">Trending</a></li>
            </ul>
			
            
            <div class="mega-menu"></div>
            
          </li>
          <li class="nav-item-forums">
            <a href="/forum/">Forums</a>
          </li>
          <li class="nav-item-deals mega-parent" aria-haspopup="true" data-menu="deals">
            <a href="/store">Store</a>
            
            <div class="mega-menu"></div>
            
          </li>
          <li class="nav-item-more mega-parent" aria-haspopup="true">
            <a href="#" class="toggle" data-toggle="more-nav">More</a>
            <ul class="menu" role="menu" id="more-nav">
              <!--<li><a href="/forum/index.php?app=spy">Forum Spy</a></li>-->
              <li><a href="/subscribe/">Subscribe</a></li>
              <li><a href="/store">Store</a></li>
              <li><a href="/irc/">Chat on IRC</a></li>
              <li class="menu-sep"><a href="/contact/">Send News Tip</a></li>
              <li><a href="/contact/apply">Write for Neowin</a></li>
              <li><a href="/credits/">About Us</a></li>
              <li><a href="/advertising/">Advertising</a></li>
            </ul>
          </li>
        </ul>

<!--
        <ul class="nav-social">
          <li class="facebook"><a href="https://www.facebook.com/neowin" title="Facebook">Facebook</a></li>
          <li class="twitter"><a href="https://twitter.com/neowinfeed" title="Twitter">Twitter</a></li>
          <li class="googleplus"><a href="https://plus.google.com/+neowin/posts" title="Google+">Google+</a></li>
          <li class="rss"><a href="https://feeds.feedburner.com/neowin-main" title="RSS">RSS</a></li>
        </ul>
-->

        <div class="nav-social-alt" aria-haspopup="true">
          <span class="nav-social-alt-toggle">
            <a href="https://www.facebook.com/neowin"><i class="icon facebook"></i></a>
            <a href="https://twitter.com/neowinfeed"><i class="icon twitter"></i></a>
            <a href="https://plus.google.com/+neowin/posts"><i class="icon googleplus"></i></a>
          </span>

          <div class="nav-social-alt-menu">

            <dl class="social">
              <dt class="facebook"><a href="https://www.facebook.com/neowin">Facebook</a></dt>
              <dd>
                <div class="fb-like" data-href="https://www.facebook.com/neowin" data-layout="button_count" data-action="like" data-show-faces="true" data-share="false"></div>
              </dd>

              <dt class="twitter"><a href="https://twitter.com/neowinfeed">Twitter</a></dt>
              <dd>
                <a href="https://twitter.com/neowinfeed" class="twitter-follow-button" data-show-count="false">Follow @neowinfeed</a>
              </dd>

              <dt class="googleplus"><a href="https://plus.google.com/103621864990923776909">Google+</a></dt>
              <dd>
                <div class="g-follow" data-annotation="bubble" data-height="20" data-href="https://plus.google.com/103621864990923776909" data-rel="publisher"></div>
              </dd>
            </dl>

          </div>
        </div>

      </nav>

    </div>

  </header>

  

  <div class="content" id="content" role="main">
    <div class="nav-secondary-menu-container">
      <div class="wrap">
        <ul class="nav-secondary-menu">
          <li><a href="/">Latest</a></li><li><a href="/news/cat/software">Software</a></li><li><a href="/news/tags/gaming">Gaming</a></li><li><a href="/news/tags/microsoft">Microsoft</a></li><li><a href="/news/tags/review/">Reviews</a></li><li><a href="/news/tags/fast_ring/slow_ring/skip_ahead/">Windows 10</a></li><li><a href="/news/were-looking-for-tech-minded-writers-to-join-neowin-we-pay-5-minimum-per-article">Write for us</a></li><li><a href="/contact#newstip">Tip</a></li>
        </ul>
      </div>
    </div>
    









    
<div class="header-banner header-banner-ads">
  <div class="wrap">
    <span class="header-banner-advertising">
      
<div class="ad" id="article_top_leaderboard"> <div data-ns="billboard"></div></div>
    </span>
  </div>
</div>

<section class="article">
  <div class="wrap">
    <div class="row">

      <article class="article-col d-col-8 w-col-8" id="article-202060" role="article" itemscope itemtype="https://schema.org/newsArticle">
        <meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="/news/google-reveals-high-severity-flaw-in-macos-kernel"/>
        <meta itemprop="dateModified" content="2019-03-03T08:12:01+00:00" />
        <meta itemprop="datePublished" content="2019-03-03T08:12:01+00:00" />
        <meta itemprop="headline" content="Google reveals &quot;high severity&quot; flaw in macOS kernel" />

        <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
            <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
                <meta itemprop="url" content="https://www.neowin.net/images/orion/icons/favicon-196x196.png">
                <meta itemprop="width" content="196">
            </div>
            <meta itemprop="name" content="Neowin" />
        </div>
        <div itemprop="author" itemscope itemtype="https://schema.org/Person">
            <meta itemprop="name" content="Usama Jawad" />
        </div>
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://cdn.neow.in/news/images/uploaded/2017/10/1508182447_macos_story.jpg">
            <meta itemprop="width" content="760">
            <meta itemprop="height" content="428">
        </div>
        <header class="article-header">

          
          
          
          <h1 class="article-title">
            <a rel="bookmark" href="/news/google-reveals-high-severity-flaw-in-macos-kernel" title="Permalink to Google reveals &quot;high severity&quot; flaw in macOS kernel">
              Google reveals &quot;high severity&quot; flaw in macOS kernel
            </a>
          </h1>

          <p class="article-meta">
            <span class="author vcard">
              By
              
                <a class="fn profile-link" rel="author" href="/profile/523233-usama_jawad">Usama Jawad</a>
                <span class="role"></span>
                <span class="org">Neowin</span>
                <a class="twitter-link" rel="me" href="https://www.twitter.com/@UsamaJawad96">@@UsamaJawad96</a>
              
               &middot;
            </span>
            <time class="date published" datetime="2019-03-03T08:12:01+00:00">Mar 3, 2019 03:12 EST</time>
             &middot; <span class="hot">Hot!</span>
	
            <span class="meta-comments">
              <span>with</span> <a href="#comments" class="comment-link scrollto " title="View 54 Comments">54 <span>comments</span></a>
              
            </span>
          </p>

        </header>

        <div class="article-content" itemprop="articleBody">
          <p>Google&#39;s Project Zero team is well-known for its knack of finding security flaws in the company&#39;s own products as well as those manufactured by other firms. Its members locate flaws in software, privately report them to the manufacturers, and give them 90 days to resolve the problem before publicly disclosing it.</p>

<p>Last year, the team revealed <a href="https://www.neowin.net/news/google-reveals-a-medium-severity-flaw-in-windows-10-s">vulnerabilities in Windows 10 S</a> and <a href="https://www.neowin.net/news/google-exposes-security-flaw-in-microsoft-edge">Microsoft Edge</a>. Now, it has exposed a <a href="https://bugs.chromium.org/p/project-zero/issues/detail?id=1726&amp;q=">&quot;high severity&quot; flaw in macOS&#39; kernel</a>.</p>

<figure class="image image--expandable"><a href="https://cdn.neow.in/news/images/uploaded/2017/10/1508182447_macos.jpg"><img alt="" src="https://cdn.neow.in/news/images/uploaded/2017/10/1508182447_macos_story.jpg" /></a></figure>

<p>A security researcher from Google&#39;s Project Zero has discovered that even though macOS&#39; kernel, XNU, allows <a href="https://en.wikipedia.org/wiki/Copy-on-write">copy-on-write (COW) behavior</a> in some cases, it is essential that any copied memory is not available for modifications from the source process. While COW is a resource-management technique that is not inherently flawed, it appears that Apple&#39;s implementation of it certainly is.</p>

<p>Project Zero has found out that if a user-owned mounted filesystem image is modified, the virtual management subsystem is not informed of the changes, which means that an attacker can potentially take malicious actions without the mounted filesystem knowing about it. The detailed explanation can be found below:</p>

<blockquote>
<p>This copy-on-write behavior works not only with anonymous memory, but also with file mappings. This means that, after the destination process has started reading from the transferred memory area, memory pressure can cause the pages holding the transferred memory to be evicted from the page cache. Later, when the evicted pages are needed again, they can be reloaded from the backing filesystem.</p>

<p>This means that if an attacker can mutate an on-disk file without informing the virtual management subsystem, this is a security bug. MacOS permits normal users to mount filesystem images. When a mounted filesystem image is mutated directly (e.g. by calling pwrite() on the filesystem image), this information is not propagated into the mounted filesystem.</p>
</blockquote>

<p>The researcher informed Apple about the flaw back in November 2018, but the company is yet to fix it even after exceeding the 90-day deadline, which is why the bug is now being made public with a &quot;high severity&quot; label. That said, Apple has accepted the problem and is working with Project Zero on a patch for a future macOS release. You can also view the proof-of-concept code that demonstrates the problem <a href="https://bugs.chromium.org/p/project-zero/issues/detail?id=1726&amp;q=">on the dedicated webpage here</a>.</p>

		  
		  

          

          
          
          <!-- newsitem.pager -->
        </div>

        <div class="article-tags">
          <h4 class="is-hidden">Tags</h4>
          <ul>
            <li><a href="/news/tags/apple" rel="tag" title="View all posts in Apple">Apple</a></li><li><a href="/news/tags/google" rel="tag" title="View all posts in Google">Google</a></li><li><a href="/news/tags/macos" rel="tag" title="View all posts in Macos">Macos</a></li><li><a href="/news/tags/xnu" rel="tag" title="View all posts in Xnu">Xnu</a></li><li><a href="/news/tags/kernel" rel="tag" title="View all posts in Kernel">Kernel</a></li><li><a href="/news/tags/flaw" rel="tag" title="View all posts in Flaw">Flaw</a></li><li><a href="/news/tags/security" rel="tag" title="View all posts in Security">Security</a></li><li><a href="/news/tags/copy-on-write" rel="tag" title="View all posts in Copy-on-write">Copy-on-write</a></li><li><a href="/news/tags/cow" rel="tag" title="View all posts in Cow">Cow</a></li><li><a href="/news/tags/project_zero" rel="tag" title="View all posts in Project zero">Project zero</a></li><li><a href="/news/tags/vulnerability" rel="tag" title="View all posts in Vulnerability">Vulnerability</a></li><li><a href="/news/tags/disclosure" rel="tag" title="View all posts in Disclosure">Disclosure</a></li><li><a href="/news/tags/cybersecurity" rel="tag" title="View all posts in Cybersecurity">Cybersecurity</a></li>
          </ul>
        </div>

        <div class="article-share">

          <div class="social-likes social-likes-icons" data-url="https://www.neowin.net/news/google-reveals-high-severity-flaw-in-macos-kernel" data-title="Google reveals &quot;high severity&quot; flaw in macOS kernel #Google #macOS #Apple #XNU">
            <div class="facebook" title="Share link on Facebook">Like</div>
            <div class="twitter" data-via="NeowinFeed" data-related="@UsamaJawad96" title="Share link on Twitter">Tweet</div>
            <div class="plusone" title="Share link on Google+">Share</div>
            <div class="reddit" title="Share link on Reddit">Share</div>
            <script>
              var socialLikesButtons = {
                reddit: {
                  clickUrl: 'https://www.reddit.com/submit?url={url}&amp;title={title}'
                }
              };
            </script>
          </div>
          <a class="report-article-button" id="report-article" href="/news/report/google-reveals-high-severity-flaw-in-macos-kernel" title="Report a problem with article">Report a problem with article</a>
          <div class="fb-like" data-href="https://www.facebook.com/neowin" data-layout="button_count" data-action="like" data-size="large" data-show-faces="false" data-share="false"></div>
          <a class="twitter-follow-button" href="https://twitter.com/neowinfeed" data-show-count="false" data-size="large">Follow @TwitterDev</a>

        </div>
        
          <!-- ad.after_article_body -->
        
		
        <div class="post-nav">
          
          <link rel="prev" href="/news/new-report-suggests-price-and-other-specs-for-samsung-galaxy-a40" />
          
          
          <link rel="next" href="/news/nintendo-switch-two-years-on-the-only-gaming-platform-i-use" />
          
          <div class="post-nav-links">
            
            <a href="/news/nintendo-switch-two-years-on-the-only-gaming-platform-i-use" class="post-nav-next" rel="nofollow">
			  <figure class="post-nav-item-thumb"><img src="https://cdn.neow.in/news/images/uploaded/2019/02/1550626215_img_20190220_000318_small.jpg" alt="1550626215_img_20190220_000318" /></figure>
              <header>
				  <span>Next Article</span>
				  <h3 class="post-nav-title">Nintendo Switch two years on: The only gaming platform I use</h3>
			  </header>
            </a>
            
			
            <a href="/news/new-report-suggests-price-and-other-specs-for-samsung-galaxy-a40" class="post-nav-prev" rel="nofollow">
			  <figure class="post-nav-item-thumb"><img src="https://cdn.neow.in/news/images/uploaded/2018/10/1539262170_img_20181011_180721_small.jpg" alt="1539262170_img_20181011_180721" /></figure>
              <header>
				  <span>Previous Article</span>
				  <h3 class="post-nav-title">New report suggests price and other specs for Samsung Galaxy A40</h3>
			  </header>
            </a>
            
          </div>

      	  <div class="post-nav-banner">
  	        
            <div>
              <div class="banner-left">
                <!-- ad.article_below_social -->
              </div>
              <div class="banner-right">
                <div data-ns="native" data-sharethrough="da75b481"></div>

              </div>
            </div>
            
      	  </div>
        </div>

        <!-- ad.article_below_article -->

      </article>

      <div class="sidebar-col d-col-4 w-col-4" id="sidebar">
        <div class="category-bar">
  <span class="news-view-switcher">
  </span>
  
	<div id="sidebar-theme-switcher">
		<a class="theme-switcher" data-theme="default" title="Switch from Automatic theme to Default"><span data-theme-current="Auto">Auto</span> theme</a>
		<a class="theme-switcher" data-theme="darkside" title="Switch from Default theme to Darkside"><span data-theme-current="Default">Default</span> theme</a>
		<a class="theme-switcher" data-theme="auto" title="Switch from Darkside theme to Automatic"><span data-theme-current="Darkside">Darkside</span> theme</a>
	</div>
	
  <a href="/contact#newstip" class="button submit newstip">
      Send news tip
  </a>
</div>

  <!-- ad.global_above_community_activity -->

<div class="widget widget-community">
  <div class="widget-header">
    <h3 class="widget-title"><a href="/forum">Community Activity</a></h3>
    <span class="widget-community-refresh" title="Refresh">Refresh</span>
  </div>
  <div class="widget-content">
    <ul>
      <li>
  <a class="community-item-topic" id="tid-link-1380400" href="/forum/index.php?/topic/1380400-usb-40-to-adopt-thunderbolt-3-with-40gbps-data-transfer-speeds/&do=getNewComment" title="USB 4.0 to adopt Thunderbolt 3 with 40Gbps data transfer speeds">USB 4.0 to adopt Thunderbolt 3 with 40Gbps data transfer speeds</a>
  <span class="community-item-forum">
    in
    <a href="/forum/index.php?/forum/266-front-page-news/" title="Goto forum">Front Page News</a>
  </span>
</li>
<li>
  <a class="community-item-topic" id="tid-link-1380406" href="/forum/index.php?/topic/1380406-trine-4-goes-back-to-25d-and-adds-four-player-coop-releases-later-this-year/&do=getNewComment" title="Trine 4 goes back to 2.5D and adds four-player coop, releases later this year">Trine 4 goes back to 2.5D and adds four-player coop, releases later this year</a>
  <span class="community-item-forum">
    in
    <a href="/forum/index.php?/forum/266-front-page-news/" title="Goto forum">Front Page News</a>
  </span>
</li>
<li>
  <a class="community-item-topic" id="tid-link-1380408" href="/forum/index.php?/topic/1380408-gwents-first-expansion-crimson-curse-is-coming-march-28/&do=getNewComment" title="GWENT's first expansion, Crimson Curse, is coming March 28">GWENT&#039;s first expansion, Crimson Curse, is coming March 28</a>
  <span class="community-item-forum">
    in
    <a href="/forum/index.php?/forum/266-front-page-news/" title="Goto forum">Front Page News</a>
  </span>
</li>
<li>
  <a class="community-item-topic" id="tid-link-1380353" href="/forum/index.php?/topic/1380353-theres-an-easter-egg-to-enable-facebook-messengers-dark-mode/&do=getNewComment" title="There's an easter egg to enable Facebook Messenger's dark mode ">There&#039;s an easter egg to enable Facebook Messenger&#039;s dark mode </a>
  <span class="community-item-forum">
    in
    <a href="/forum/index.php?/forum/266-front-page-news/" title="Goto forum">Front Page News</a>
  </span>
</li>
<li>
  <a class="community-item-topic" id="tid-link-1380360" href="/forum/index.php?/topic/1380360-google-reveals-high-severity-flaw-in-macos-kernel/&do=getNewComment" title="Google reveals &quot;high severity&quot; flaw in macOS kernel">Google reveals &quot;high severity&quot; flaw in macOS kernel</a>
  <span class="community-item-forum">
    in
    <a href="/forum/index.php?/forum/266-front-page-news/" title="Goto forum">Front Page News</a>
  </span>
</li>
<li>
  <a class="community-item-topic" id="tid-link-1380407" href="/forum/index.php?/topic/1380407-as-the-world-moves-on-from-passwords-webauthn-becomes-an-official-standard/&do=getNewComment" title="As the world moves on from passwords, WebAuthn becomes an official standard">As the world moves on from passwords, WebAuthn becomes an official standard</a>
  <span class="community-item-forum">
    in
    <a href="/forum/index.php?/forum/266-front-page-news/" title="Goto forum">Front Page News</a>
  </span>
</li>
<li>
  <a class="community-item-topic" id="tid-link-1380399" href="/forum/index.php?/topic/1380399-sony-offers-freebie-for-those-buying-xperia-10-or-xperia-10-plus-from-sony-estore/&do=getNewComment" title="Sony offers freebie for those buying Xperia 10 or Xperia 10 Plus from Sony eStore">Sony offers freebie for those buying Xperia 10 or Xperia 10 Plus from Sony eStore</a>
  <span class="community-item-forum">
    in
    <a href="/forum/index.php?/forum/266-front-page-news/" title="Goto forum">Front Page News</a>
  </span>
</li>
<li>
  <a class="community-item-topic" id="tid-link-1380345" href="/forum/index.php?/topic/1380345-nokia-71-review-top-notch-display-great-design-and-an-almost-premium-experience/&do=getNewComment" title="Nokia 7.1 review: Top-notch display, great design, and an almost premium experience">Nokia 7.1 review: Top-notch display, great design, and an almost premium experience</a>
  <span class="community-item-forum">
    in
    <a href="/forum/index.php?/forum/266-front-page-news/" title="Goto forum">Front Page News</a>
  </span>
</li>

    </ul>
  </div>
</div>



  
<div class="ad" id="global_below_community_activity"><div id="global_above_community_activity" class="widget widget-ad widget-ad-sidebar-top">
  <div class="widget-header">
    <h3 class="widget-title">Advertisement</h3>
  </div>
  <div class="widget-content">
<div style="background-color:#fff; padding 5px 0 5px 0;" data-ns="halfpage"></div>
  </div>
</div></div>

  <div class="widget widget-trending">
    <div class="widget-header">
      <h3 class="widget-title">Trending Stories</h3>
    </div>
    <div class="widget-content">
      <article class="trending-item">
  <figure class="trending-item-thumb">
    <a class="trending-item-thumb-link" rel="bookmark" href="/news/google-reveals-high-severity-flaw-in-macos-kernel">
			<img src="https://cdn.neow.in/news/images/uploaded/2017/10/1508182447_macos_small.jpg" alt="1508182447_macos" />
    </a>
  </figure>
  <header class="trending-item-header">
    <h3 class="trending-item-title"><a rel="bookmark" href="/news/google-reveals-high-severity-flaw-in-macos-kernel">Google reveals &quot;high severity&quot; flaw in macOS kernel</a></h3>
    <p class="trending-item-meta">
      <time class="date published" datetime="2019-03-03T08:12:01+00:00">Mar 3, 2019</time>
      <span class="comments">
        <span>with</span> <a href="/news/google-reveals-high-severity-flaw-in-macos-kernel#comments" class="comment-link " title="View 54 Comments">54 <span>comments</span></a>
      </span>
    </p>
  </header>
</article>
<article class="trending-item">
  <figure class="trending-item-thumb">
    <a class="trending-item-thumb-link" rel="bookmark" href="/news/a-github-project-is-bringing-windows-10-to-the-nintendo-switch">
			<img src="https://cdn.neow.in/news/images/uploaded/2019/03/1551720605_d0t8yq_uwaiwygv_small.jpg" alt="1551720605_d0t8yq_uwaiwygv" />
    </a>
  </figure>
  <header class="trending-item-header">
    <h3 class="trending-item-title"><a rel="bookmark" href="/news/a-github-project-is-bringing-windows-10-to-the-nintendo-switch">A GitHub project is bringing Windows 10 to the Nintendo Switch</a></h3>
    <p class="trending-item-meta">
      <time class="date published" datetime="2019-03-04T18:02:01+00:00"> 1 hour ago</time>
      <span class="comments">
        <span>with</span> <a href="/news/a-github-project-is-bringing-windows-10-to-the-nintendo-switch#comments" class="comment-link " title="View 0 Comments">0 <span>comments</span></a>
      </span>
    </p>
  </header>
</article>
<article class="trending-item">
  <figure class="trending-item-thumb">
    <a class="trending-item-thumb-link" rel="bookmark" href="/news/as-the-world-moves-on-from-passwords-webauthn-becomes-an-official-standard">
			<img src="https://cdn.neow.in/news/images/uploaded/2019/03/1551723828_fingerprint_small.jpg" alt="1551723828_fingerprint" />
    </a>
  </figure>
  <header class="trending-item-header">
    <h3 class="trending-item-title"><a rel="bookmark" href="/news/as-the-world-moves-on-from-passwords-webauthn-becomes-an-official-standard">As the world moves on from passwords, WebAuthn becomes an official standard</a></h3>
    <p class="trending-item-meta">
      <time class="date published" datetime="2019-03-04T18:34:01+00:00"> 35 minutes ago</time>
      <span class="comments">
        <span>with</span> <a href="/news/as-the-world-moves-on-from-passwords-webauthn-becomes-an-official-standard#comments" class="comment-link " title="View 0 Comments">0 <span>comments</span></a>
      </span>
    </p>
  </header>
</article>
<article class="trending-item">
  <figure class="trending-item-thumb">
    <a class="trending-item-thumb-link" rel="bookmark" href="/news/trine-4-goes-back-to-25d-and-adds-four-player-coop-releases-later-this-year">
			<img src="https://cdn.neow.in/news/images/uploaded/2019/03/1551721746_trine_4_screenshot_04_small.jpg" alt="1551721746_trine_4_screenshot_04" />
    </a>
  </figure>
  <header class="trending-item-header">
    <h3 class="trending-item-title"><a rel="bookmark" href="/news/trine-4-goes-back-to-25d-and-adds-four-player-coop-releases-later-this-year">Trine 4 goes back to 2.5D and adds four-player coop, releases later this year</a></h3>
    <p class="trending-item-meta">
      <time class="date published" datetime="2019-03-04T18:18:01+00:00"> 51 minutes ago</time>
      <span class="comments">
        <span>with</span> <a href="/news/trine-4-goes-back-to-25d-and-adds-four-player-coop-releases-later-this-year#comments" class="comment-link " title="View 4 Comments">4 <span>comments</span></a>
      </span>
    </p>
  </header>
</article>

    </div>
  </div>

  <!-- page.frontPagePoll -->






  <!-- ad.article_sidebar_bottom -->


      </div>

    </div>
  </div>
</section>

<aside class="related-news" id="related-news">
  <div class="wrap">
    <h3 class="related-news-title">Related Stories</h3>
    <div class="row">
      <article class="related-item">
  <figure class="related-item-thumb">
    <a class="related-item-thumb-link" rel="bookmark" href="/news/native-apple-music-support-may-be-expanding-to-google-home-speakers">
			<img src="https://cdn.neow.in/news/images/uploaded/2016/05/google-home-io-01_medium.jpg" alt="google-home-io-01" />
    </a>
  </figure>
  <header class="related-item-header">
    <h3 class="related-item-title"><a rel="bookmark" href="/news/native-apple-music-support-may-be-expanding-to-google-home-speakers">Native Apple Music support may be expanding to Google Home speakers</a></h3>
    <p class="related-item-meta">
      <time class="date published" datetime="2019-02-26T07:54:01+00:00">Feb 26, 2019</time>
      
    </p>
  </header>
</article>
<article class="related-item">
  <figure class="related-item-thumb">
    <a class="related-item-thumb-link" rel="bookmark" href="/news/microsoft-uncovers-spoofing-on-european-organizations-accountguard-expanded">
			<img src="https://cdn.neow.in/news/images/uploaded/2016/03/microsoft-security_medium.jpg" alt="microsoft-security" />
    </a>
  </figure>
  <header class="related-item-header">
    <h3 class="related-item-title"><a rel="bookmark" href="/news/microsoft-uncovers-spoofing-on-european-organizations-accountguard-expanded">Microsoft uncovers spoofing on European organizations, AccountGuard expanded</a></h3>
    <p class="related-item-meta">
      <time class="date published" datetime="2019-02-20T14:44:02+00:00">Feb 20, 2019</time>
      
    </p>
  </header>
</article>
<article class="related-item">
  <figure class="related-item-thumb">
    <a class="related-item-thumb-link" rel="bookmark" href="/news/several-pwas-in-the-microsoft-store-found-to-be-mining-cryptocurrencies">
			<img src="https://cdn.neow.in/news/images/uploaded/2018/05/1525900889_microsoftstore2b_medium.jpg" alt="1525900889_microsoftstore2b" />
    </a>
  </figure>
  <header class="related-item-header">
    <h3 class="related-item-title"><a rel="bookmark" href="/news/several-pwas-in-the-microsoft-store-found-to-be-mining-cryptocurrencies">Several PWAs in the Microsoft Store found to be mining cryptocurrencies</a></h3>
    <p class="related-item-meta">
      <time class="date published" datetime="2019-02-17T12:10:01+00:00">Feb 17, 2019</time>
       &middot; <span class="hot">Hot!</span>
    </p>
  </header>
</article>
<article class="related-item">
  <figure class="related-item-thumb">
    <a class="related-item-thumb-link" rel="bookmark" href="/news/google-rejected-55-more-android-app-submissions-in-2018-than-in-2017">
			<img src="https://cdn.neow.in/news/images/uploaded/2018/05/1526063859_androidsecurity_medium.jpg" alt="1526063859_androidsecurity" />
    </a>
  </figure>
  <header class="related-item-header">
    <h3 class="related-item-title"><a rel="bookmark" href="/news/google-rejected-55-more-android-app-submissions-in-2018-than-in-2017">Google rejected 55% more Android app submissions in 2018 than in 2017</a></h3>
    <p class="related-item-meta">
      <time class="date published" datetime="2019-02-14T08:08:01+00:00">Feb 14, 2019</time>
      
    </p>
  </header>
</article>

    </div>
  </div>
</aside>
<!-- ad.article_above_comments -->
<!-- Comments -->
<div class="comments" data-commentid="0" id="comments" itemprop="comment" itemscope itemtype="https://schema.org/comment">
  <div class="wrap">
    <div class="row">

      <div class="comments-col d-col-8 w-col-8">

        <button class="button show-comments-button">Show Comments</button>

        <header class="comments-header">
          <h2 class="comments-title">54 Comments - <a href="#add">Add comment</a></h2>
        </header>

        <div class="comments-menu">
          

          <span class="select-wrap comments-sort">
            <select class="select" id="commentSort">
              <option selected="selected" value="oldest">Sort by oldest first (thread view)</option>
              <option value="newest">Sort by newest first (thread view)</option>
              <option value="oldest_linear">Sort by oldest first (linear view)</option>
              <option value="newest_linear">Sort by newest first (linear view)</option>
            </select>
          </span>
        </div>

        <div class="comment-list" data-newsid="202060" data-topicID="1380360"><!-- comments.content --></div>
      </div>

      
      <div class="sidebar-col d-col-4 w-col-4 article-next-to-comments">
        <div class="ad" id="article_next_to_comments"><div class="widget widget-ad widget-ad-sidebar-middle">
  <div class="widget-header">
    <h3 class="widget-title">Advertisement</h3>
  </div>
<div style="float: left;"  data-ns="halfpage"></div>
</div>
</div>

      </div>
      

    </div>
  </div>
</div>
<!-- // Comments -->

<div class="modal" id="pop-comment-report">
  <div class="modal-window">
    <div class="modal-header">
      <h3 class="modal-title">Report Comment</h3>
      <span class="modal-close">Close</span>
    </div>
    <div class="modal-content">
      <p>Please enter your reason for reporting this comment.</p>
      <div class="form">
        <div class="field">
          <textarea class="textarea" rows="5"></textarea>
        </div>
      </div>
    </div>
    <div class="modal-actions">
      <input class="button button-primary" type="submit" id="submit-reported-comment" value="Report Comment" />
    </div>
  </div>
</div>

<div class="modal" id="pop-comment-help">
  <div class="modal-window">
    <div class="modal-header">
      <h3 class="modal-title">BBCode Helper</h3>
      <span class="modal-close">Close</span>
    </div>
    <div class="modal-content">
      <p>The following codes can be used in comments.</p>
      <ul>
        <li>[b]<strong>bold</strong>[/b]</li>
        <li>[i]<em>italics</em>[/i]</li>
        <li>[u]<u>underline</u>[/u]</li>
        <li>[s]<s>strikethrough</s>[/s]</li>
		<li>[url]link[/url]</li>
        <li>[img]imageurl[/img]</li>
        <li>[quote]text[/quote]</li>
      </ul>
    </div>
  </div>
</div>

<aside class="deals">
  <div class="wrap">
    <h3 class="deals-title">Deals</h3>
    <div class="row">
      <article class="deal-item deal">
  <figure class="deal-item-thumb">
    <a class="deal-item-thumb-link" rel="bookmark" href="//deals.neowin.net/sales/pay-what-you-want-the-adobe-cc-lifetime-a-z-bundle/?utm_source=neowin.net&amp;utm_medium=dealfeed-bottom&amp;utm_campaign=/sales/pay-what-you-want-the-adobe-cc-lifetime-a-z-bundle">
			<img src="https://cdnp1.stackassets.com/f2dd7e708da5c6d045da9a0d435edc6b95864aa6/store/opt/360/270/45cde7b3a9482e79f1c3d47f1b681287e1c9386cf1d317ad3d1c6d9138ba/sale_15856_primary_image.jpg" alt="" />
    </a>
  </figure>
    <header class="deal-item-header">
    <h3 class="deal-item-title"><a rel="bookmark" href="//deals.neowin.net/sales/pay-what-you-want-the-adobe-cc-lifetime-a-z-bundle/?utm_source=neowin.net&amp;utm_medium=dealfeed-bottom&amp;utm_campaign=/sales/pay-what-you-want-the-adobe-cc-lifetime-a-z-bundle">Pay What You Want: Adobe CC A-Z Lifetime Bundle</a></h3>

  </header>             <div class="deal-price">
                    <span class="deal-price-old">$2,593.98</span>
                    <span class="deal-price-new">$1.00</span>
                    <span class="deal-price-off">100% off</span>
                </div>
</article><article class="deal-item deal">
  <figure class="deal-item-thumb">
    <a class="deal-item-thumb-link" rel="bookmark" href="//deals.neowin.net/sales/anyone-can-make-a-video-game-build-a-battle-royale-with-unity-and-blender/?utm_source=neowin.net&amp;utm_medium=dealfeed-bottom&amp;utm_campaign=/sales/anyone-can-make-a-video-game-build-a-battle-royale-with-unity-and-blender">
			<img src="https://cdnp3.stackassets.com/a27aae34f5de9af4de4f154729a2205b4127c05c/store/opt/360/270/a9e4811dde06e2056db23790a4ac1fc6e78690a0eecc52b43406cbf72f89/sale_17812_primary_image.jpg" alt="" />
    </a>
  </figure>
    <header class="deal-item-header">
    <h3 class="deal-item-title"><a rel="bookmark" href="//deals.neowin.net/sales/anyone-can-make-a-video-game-build-a-battle-royale-with-unity-and-blender/?utm_source=neowin.net&amp;utm_medium=dealfeed-bottom&amp;utm_campaign=/sales/anyone-can-make-a-video-game-build-a-battle-royale-with-unity-and-blender">Build a Battle Royale with Unity & Blender</a></h3>

  </header>             <div class="deal-price">
                    <span class="deal-price-old">$199.99</span>
                    <span class="deal-price-new">$9.99</span>
                    <span class="deal-price-off">95% off</span>
                </div>
</article><article class="deal-item deal">
  <figure class="deal-item-thumb">
    <a class="deal-item-thumb-link" rel="bookmark" href="//deals.neowin.net/sales/nordvpn-2-yr-subscription-3/?utm_source=neowin.net&amp;utm_medium=dealfeed-bottom&amp;utm_campaign=/sales/nordvpn-2-yr-subscription-3">
			<img src="https://cdnp0.stackassets.com/fca7496be7fd44c2e55f9d90fbf550a242fbcb8e/store/opt/360/270/ba2ccc22f6dc613ff80aec7be77f1453769106a227902611a3e6e8fbb4dd/sale_16492_primary_image.jpg" alt="" />
    </a>
  </figure>
    <header class="deal-item-header">
    <h3 class="deal-item-title"><a rel="bookmark" href="//deals.neowin.net/sales/nordvpn-2-yr-subscription-3/?utm_source=neowin.net&amp;utm_medium=dealfeed-bottom&amp;utm_campaign=/sales/nordvpn-2-yr-subscription-3">NordVPN: 2-Yr Subscription</a></h3>

  </header>             <div class="deal-price">
                    <span class="deal-price-old">$286.80</span>
                    <span class="deal-price-new">$95.75</span>
                    <span class="deal-price-off">67% off</span>
                </div>
</article><article class="deal-item deal">
  <figure class="deal-item-thumb">
    <a class="deal-item-thumb-link" rel="bookmark" href="//deals.neowin.net/sales/pwyw-the-python-master-class-bundle/?utm_source=neowin.net&amp;utm_medium=dealfeed-bottom&amp;utm_campaign=/sales/pwyw-the-python-master-class-bundle">
			<img src="https://cdnp1.stackassets.com/b120fe07d25035236393ce30389e8d900852850b/store/opt/360/270/dc5ea1ff5d3ce7eac772858cd8499531cd904303bf3827093661e11594a5/sale_17485_primary_image.jpg" alt="" />
    </a>
  </figure>
    <header class="deal-item-header">
    <h3 class="deal-item-title"><a rel="bookmark" href="//deals.neowin.net/sales/pwyw-the-python-master-class-bundle/?utm_source=neowin.net&amp;utm_medium=dealfeed-bottom&amp;utm_campaign=/sales/pwyw-the-python-master-class-bundle">Pay What You Want: The Python Master Class Bundle</a></h3>

  </header>             <div class="deal-price">
                    <span class="deal-price-old">$1,066.00</span>
                    <span class="deal-price-new">$1.00</span>
                    <span class="deal-price-off">100% off</span>
                </div>
</article><article class="deal-item deal">
  <figure class="deal-item-thumb">
    <a class="deal-item-thumb-link" rel="bookmark" href="//deals.neowin.net/sales/pay-what-you-want-certified-white-hat-hacker-bundle/?utm_source=neowin.net&amp;utm_medium=dealfeed-bottom&amp;utm_campaign=/sales/pay-what-you-want-certified-white-hat-hacker-bundle">
			<img src="https://cdnp3.stackassets.com/b73a0ab8d0d6854aa11098de4e229b7613df113c/store/opt/360/270/43e361a481391138cfd9ec177b4c7c6f786b03c8ba458f5caf0a3f7fba38/sale_15576_primary_image.jpg" alt="" />
    </a>
  </figure>
    <header class="deal-item-header">
    <h3 class="deal-item-title"><a rel="bookmark" href="//deals.neowin.net/sales/pay-what-you-want-certified-white-hat-hacker-bundle/?utm_source=neowin.net&amp;utm_medium=dealfeed-bottom&amp;utm_campaign=/sales/pay-what-you-want-certified-white-hat-hacker-bundle">Pay What You Want: White Hat Hacker Training Bundle</a></h3>

  </header>             <div class="deal-price">
                    <span class="deal-price-old">$1,114.95</span>
                    <span class="deal-price-new">$1.00</span>
                    <span class="deal-price-off">100% off</span>
                </div>
</article>
    </div>
  </div>
</aside>



    
      
    
    
      
        <!-- Promos -->
<div class="promos" id="promos">
	<div class="promo promo--medium pos-1 slider" data-promoid="22992">
  <div class="main-carousel" data-initialindex="0">
		  <div class="carousel-cell">
   <a href="https://www.neowin.net/news/tags/mwc_2019">
    <div class="promo-block">
        <div class="promo-block-image"><img class="carousel-cell-image" src="https://cdn.neow.in/news/images/uploaded/2019/02/1549184135_mwc19_mediump.jpg" data-flickity-lazyload="https://cdn.neow.in/news/images/uploaded/2019/02/1549184135_mwc19_mediump.jpg" /></div>
    </div>
    <div class="promo-content" style="z-index:5">
      
        <div class=" promo-content-fade">
          <h3 class="promo-title">
            Catch all of the news to come out of Barcelona at Mobile World Congress 2019
          </h3>
          
          <p class="promo-excerpt">
            mobile world congress 2019
          </p>
          
      </div>
    </div>
   </a>
  </div>
  <div class="carousel-cell">
   <a href="https://www.neowin.net/news/mwc-2019-hands-on-with-the-lg-g8-thinq-and-lg-v50-thinq">
    <div class="promo-block">
        <div class="promo-block-image"><img class="carousel-cell-image" src="" data-flickity-lazyload="https://cdn.neow.in/news/images/uploaded/2019/02/1551216573_img_20190225_111630_mediump.jpg" /></div>
    </div>
    <div class="promo-content">
      
      <span class="badge">MWC 2019</span>
      
        <div class=" promo-content-fade">
          <h3 class="promo-title">
            Hands on with LG&#039;s new flagship phones, the G8 ThinQ and V50 ThinQ
          </h3>
          
          <p class="promo-excerpt">
            g8 thinq
          </p>
          
      </div>
    </div>
   </a>
  </div>
  <div class="carousel-cell">
   <a href="https://www.neowin.net/news/nintendo-switch-two-years-on-the-only-gaming-platform-i-use">
    <div class="promo-block">
        <div class="promo-block-image"><img class="carousel-cell-image" src="" data-flickity-lazyload="https://cdn.neow.in/news/images/uploaded/2019/02/1550626215_img_20190220_000318_mediump.jpg" /></div>
    </div>
    <div class="promo-content">
      
      <span class="badge">editorial</span>
      
        <div class=" promo-content-fade">
          <h3 class="promo-title">
            Nintendo Switch two years on: The only gaming platform I use
          </h3>
          
          <p class="promo-excerpt">
            nintendo switch
          </p>
          
      </div>
    </div>
   </a>
  </div>

  </div>
</div>
	
		<div class="promo promo--small pos-3 gallery-cell">
 <a href="https://www.neowin.net/news/tags/build_18348">
  <div class="promo-block">
    <div class="promo-block-image" style="background-image:url('https://cdn.neow.in/news/images/uploaded/2018/07/1531925026_19h1-pc-bugsv3_smallp.jpg')"></div>
  </div>
  <div class="promo-content">
	
    <span class="badge">FAST RING</span>
    
    <div class=" promo-content-fade">
      <h3 class="promo-title">
        Windows 10 build 18348 is out with emoji improvements
      </h3>
      
      <p class="promo-excerpt">
        19h1
      </p>
      
    </div>
  </div>
 </a>
</div>
<div class="promo promo--small pos-4 gallery-cell">
 <a href="https://www.neowin.net/news/mwc-2019-hands-on-with-the-microsoft-hololens-2">
  <div class="promo-block">
    <div class="promo-block-image" style="background-image:url('https://cdn.neow.in/news/images/uploaded/2019/02/1551203801_screenshot_(56)_smallp.jpg')"></div>
  </div>
  <div class="promo-content">
	
    <span class="badge">MWC 2019</span>
    
    <div class=" promo-content-fade">
      <h3 class="promo-title">
        Hands on with HoloLens 2
      </h3>
      
      <p class="promo-excerpt">
        hololens 2
      </p>
      
    </div>
  </div>
 </a>
</div>
<div class="promo promo--small pos-7 gallery-cell">
 <a href="https://www.neowin.net/news/mwc-2019-the-huawei-mate-x-gave-me-hope-for-the-future-of-foldable-phones">
  <div class="promo-block">
    <div class="promo-block-image" style="background-image:url('https://cdn.neow.in/news/images/uploaded/2019/02/1551291761_img_20190227_151435_smallp.jpg')"></div>
  </div>
  <div class="promo-content">
	
    <span class="badge">MWC 2019</span>
    
    <div class=" promo-content-fade">
      <h3 class="promo-title">
        Hands on with Huawei&#039;s foldable phone, the Mate X
      </h3>
      
      <p class="promo-excerpt">
        mate x
      </p>
      
    </div>
  </div>
 </a>
</div>
<div class="promo promo--small pos-8 gallery-cell">
 <a href="https://www.neowin.net/news/mwc-2019-hands-on-with-the-nokia-9-pureview-and-its-five-cameras">
  <div class="promo-block">
    <div class="promo-block-image" style="background-image:url('https://cdn.neow.in/news/images/uploaded/2019/02/1551131348_img_20190225_095044_smallp.jpg')"></div>
  </div>
  <div class="promo-content">
	
    <span class="badge">MWC 2019</span>
    
    <div class=" promo-content-fade">
      <h3 class="promo-title">
        Hands on with Nokia&#039;s penta-lens phone, the 9 PureView
      </h3>
      
      <p class="promo-excerpt">
        nokia 9 pureview
      </p>
      
    </div>
  </div>
 </a>
</div>

	
</div>
<!-- // Promos -->

      
    
	
    <footer class="footer" id="footer">

      <div class="footer-top">
        <div class="wrap">
          <div class="row">

            <div class="footer-top-nav t-col-7">
              <div class="row">
                <div class="footer-top-col t-col-3">
                  <h3>Company</h3>
                  <ul><li><a href="/contact/" title="Contact Us">Contact Us</a></li><li><a href="/credits/" title="About Us">About Us</a></li><li><a href="/credits/#jobs" title="Write for Neowin">Write for Neowin</a></li><li><a href="/advertising/" title="Advertising">Advertising</a></li></ul>
                </div>
                <div class="footer-top-col t-col-3">
                  <h3>Community</h3>
                  <ul><li><a href="/forum/" title="Forums">Forums</a></li><li><a href="/subscribe/" title="Subscribe">Subscribe</a></li><li><a href="/irc/" title="Chat on IRC">Chat on IRC</a></li><li><a href="//deals.neowin.net/" title="Neowin Deals">Neowin Deals</a></li></ul>
                </div>
                <div class="footer-top-col t-col-3">
                  <h3>Social</h3>
                  <ul class="footer-social">
                    <li class="facebook"><a href="https://www.facebook.com/neowin" title="Facebook">Facebook</a></li>
                    <li class="twitter"><a href="https://twitter.com/neowinfeed" title="Twitter">Twitter</a></li>
                    <li class="googleplus"><a href="https://plus.google.com/103621864990923776909" rel="publisher" title="Google+">Google+</a></li>
                    <li class="youtube"><a href="https://www.youtube.com/Neowin" rel="publisher" title="YouTube">YouTube</a></li>
                  </ul>
                </div>
                 <div class="footer-top-col t-col-3">
                   <h3>Partners</h3>                  
                    <ul><li><a href="https://www.stardock.com/games/starcontrol/" title="Star Control">Star Control</a></li><li><a href="https://www.stardock.com/products/fences/" title="Fences">Fences</a></li><li><a href="https://littletinyfrogs.com/" title="Brad Wardell">Brad Wardell</a></li><li><a href="https://www.neowin.net/store" title="Store">Store</a></li></ul>
                </div>
              </div>
            </div>

<!--
            <div class="footer-top-col footer-newsletter t-col-6" role="contentinfo">
              <form action="https://techspot.us1.list-manage.com/subscribe/post?u=e4cfda23de0688b6339e986ae&amp;id=087c9b1822" method="post" name="mc-embedded-subscribe-form" target="_blank">
                <h3 class="footer-newsletter-title">Subscribe to our Newsletter</h3>
                <input class="input" type="email" name="email" placeholder="signup@email.com" />
                <input class="newsletter-button" name="subscribe" type="submit" value="Subscribe" />
              </form>
            </div>
-->

          </div>
        </div>
      </div>

      <div class="footer-bot">
        <div class="wrap">
          <div class="row">

            <div class="footer-copyright t-col-11">
              <ul class="footer-copyright-links">
                <li><a href="/dmca/">DMCA <span>Policy</span></a></li>
                <li><a href="/terms/">Terms of Use</a></li>
                <li><a href="/privacy/">Privacy <span>Statement</span></a></li>
              </ul>
              <p class="footer-copyright-text">
                <span>&copy; Since 2000 <span class="org">Neowin</span> LLC.</span>
                All trademarks mentioned are the property of their respective owners.
              </p>
            </div>

            <div class="t-col-1">
              <a class="footer-top-of-page scrollto" href="#top">Top of Page</a>
            </div>

          </div>
        </div>
      </div>

    </footer>

  </div>

</div>


<form accept-charset="utf-8" action="/forum/login/" method="post" data-ipsvalidation="" novalidate="">
<div class="modal" id="site-signin">
  <div class="modal-window">
    <div class="modal-header">
      <h3 class="modal-title">Login</h3>
      <span class="modal-close">Close</span>
    </div>
    <div class="modal-content">
      <div class="signin-form">
        <input type="hidden" name="csrfKey" value="28ed2476f9260e570494a54d6421fc06">
		<input type="hidden" name="ref" value="aHR0cHM6Ly93d3cubmVvd2luLm5ldC9uZXdzL2dvb2dsZS1yZXZlYWxzLWhpZ2gtc2V2ZXJpdHktZmxhdy1pbi1tYWNvcy1rZXJuZWw=">
        <input type="hidden" name="referer" value="/news/google-reveals-high-severity-flaw-in-macos-kernel">
        <input type="hidden" name="login__standard_submitted" value="1">
        <div class="signin-input form">
          <div class="field required">
            <label class="label" for="auth">Username or email:</label>
            <input type="text" class="input" id="auth" name="auth" value="" />
          </div>
          <div class="field required">
            <label class="label" for="password">Password</label>
            <input type="password" class="input" id="password" name="password" type="password" value="" />
          </div>
          <div class="field options">
            <label class="label" for="remember_me_checkbox" title="This is not recommended for shared computers">
              <input type="hidden" name="remember_me" value="0">
              <input type="checkbox" id="remember_me_checkbox" checked="checked" name="remember_me_checkbox" value="1" class="checkbox" tabindex="0">
              Remember me
            </label>
          </div>
        </div>
      </div>
    </div>
    <div class="modal-actions">
      <button type="submit" id="elSignIn_submit" name="_processLogin" value="usernamepassword" class="button button-primary button-block">Sign In</button>
      <a class="social-login-button facebook" rel="nofollow" href="https://www.facebook.com/dialog/oauth?client_id=141241332490&amp;scope=email,user_status,publish_actions&amp;redirect_uri=http%3A%2F%2Fwww.neowin.net%2Fforum%2Fapplications%2Fcore%2Finterface%2Ffacebook%2Fauth.php&state=front-28ed2476f9260e570494a54d6421fc06" sl-processed="1">Sign in with Facebook</a>
      <a class="social-login-button twitter" rel="nofollow" href="/forum/login/?loginProcess=twitter" sl-processed="1">Sign in with Twitter</a>
      <a class="social-login-button google" rel="nofollow" href="https://accounts.google.com/o/oauth2/v2/auth?response_type=code&client_id=862306993829-cbvdsv2gh7762t2tmdl55msh7tch3s0t.apps.googleusercontent.com&redirect_uri=https%3A%2F%2Fwww.neowin.net%2Fforum%2Foauth%2Fcallback%2F&scope=https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fplus.login+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fuserinfo.email+https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fuserinfo.profile&access_type=offline&state=6-28ed2476f9260e570494a54d6421fc06" sl-processed="1">Sign in with Google</a>
      <a class="social-login-button liveid" rel="nofollow" href="https://login.live.com/oauth20_authorize.srf?client_id=000000004015ED77&scope=wl.signin+wl.emails+wl.offline_access&response_type=code&redirect_uri=http%3A%2F%2Fwww.neowin.net%2Fforum%2Fapplications%2Fcore%2Finterface%2Fmicrosoft%2Fauth.php&state=front" sl-processed="1">Sign in with Live ID</a>
    </div>
  </div>
</div>
</form>


<div class="modal" id="profile-card">
  <div class="modal-window profile-card">
    <!-- Profile content -->
  </div>
</div>

<div id="ajax-spinner"><span class="spinner"></span><span>Loading</span></div>


<script src="//ajax.googleapis.com/ajax/libs/jquery/2.2.4/jquery.min.js"></script>


<script src="/js/orion/scripts.min.js?ver=62f3b07"></script>


<script src="/forum/applications/core/interface/ckeditor/ckeditor/ckeditor.js"></script>
<script src="/js/ckeditor4/adapters/jquery.js"></script>



<script>
window.ZDStickyOpts = function() {
  return {
  	topLeaderboardAdContainer: '#article_top_leaderboard',
  	sidebarTopAdContainer: '#global_above_community_activity .widget-content',
  	sidebarMidAdContainer: '#article_next_to_comments .widget-content',
    sidebarBottomAdContainer: '#main_sidebar_bottom .widget-content',
  	pageContent: '#content',
  	fixedNavBar: '',
    extraCSS: '',
    unstickLeaderboardAfterTimeout: 15000,
    unstickTopSidebarAdAfterTimeout: 15000,
    unstickMidSidebarAdAfterTimeout: 15000,
    unstickBottomSidebarAdAfterTimeout: 15000
  }
}
</script>

<!-- Social -->
<div id="fb-root"></div>
<script>(function(d, s, id) {var js, fjs = d.getElementsByTagName(s)[0];if (d.getElementById(id)) return;js = d.createElement(s); js.id = id;js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=141241332490&version=v2.8";fjs.parentNode.insertBefore(js, fjs);}(document, 'script', 'facebook-jssdk'));</script>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
<script src="//apis.google.com/js/platform.js"></script>
<script type="text/javascript" src="//s.skimresources.com/js/2728X590260.skimlinks.js"></script>

</body>
</html>
